Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

javascript is not working on some sites, and some sites also display in what looks like arabic. whats going on? how do i fix the javascript problem? javascript IS functioning in other browsers.

more options

Site displays fine in IE but in Mozilla, displays in text only, with the message: "Billboard requires a JavaScript enabled browser to get the full experience." Getting similar messages on other sites. Also, some sites are displaying in part English, part what looks like Arabic to me. Whats that about? Havent played with any language settings- in the browser OR on my computer. The affected sites listed are both displaying in text only. The login page for Mozilla website is one of the sites i mentioned displaying in part (Arabic?)

Site displays fine in IE but in Mozilla, displays in text only, with the message: "Billboard requires a JavaScript enabled browser to get the full experience." Getting similar messages on other sites. Also, some sites are displaying in part English, part what looks like Arabic to me. Whats that about? Havent played with any language settings- in the browser OR on my computer. The affected sites listed are both displaying in text only. The login page for Mozilla website is one of the sites i mentioned displaying in part (Arabic?)

All Replies (2)

more options

Reload a web page and bypass the cache with:

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

See Keyboard shortcuts - Perform common Firefox tasks quickly and Use mouse shortcuts to perform common tasks in Firefox

  • "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

more options

Ok I found it- AdBlock Plus was the culprit (regarding JavaScript). When i disabled it for those pages and refreshed, they worked. Thought i would post it here in case anyone else had that problem. Regarding the weird fonts...... i dont know what happened but it seems like that resolved itself.