Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MP4s unable to play (Windows Home Edition)

  • 3 balasan
  • 1 ada masalah ini
  • 402 paparan
  • Balasan terakhir oleh cosey

more options

The whole system was only set up recently, so I'm not sure if the issue has been happening since Firefox was installed, but it is possible.

I've narrowed it down to MP4s being the issue, which as the relevant help articles state should be decoded by the OS. No problems watching the videos in Microsoft Edge for example.

Console gives:

   HTTP "Content-Type" of "video/mp4" is not supported [...]
   Cannot play media. No decoders for requested formats: video/mp4

or

   Specified "type" attribute of "video/mp4" is not supported

etc.

Same result when disabling all addons. Windows Media Player etc. installed and working.

Only the first (MPEG) video on the following test page doesn't work for example: https://tekeye.uk/html/html5-video-test-page

Any help would be greatly appreciated!

The whole system was only set up recently, so I'm not sure if the issue has been happening since Firefox was installed, but it is possible. I've narrowed it down to MP4s being the issue, which as the relevant help articles state should be decoded by the OS. No problems watching the videos in Microsoft Edge for example. Console gives: HTTP "Content-Type" of "video/mp4" is not supported [...] Cannot play media. No decoders for requested formats: video/mp4 or Specified "type" attribute of "video/mp4" is not supported etc. Same result when disabling all addons. Windows Media Player etc. installed and working. Only the first (MPEG) video on the following test page doesn't work for example: https://tekeye.uk/html/html5-video-test-page Any help would be greatly appreciated!

Penyelesaian terpilih

Ok I have no idea how this happened, but looking in about:config I discovered that

   media.mp4.enabled

was somehow set to false!

Reverting that to its default true has fixed the issue.

Baca jawapan ini dalam konteks 👍 0

All Replies (3)

more options

hello

cosey

follow the steps and instructions:

you may be needing this in case you do not have support for MP4 files:

Windows Media Feature Pack for Windows 7 N and for Windows 7 KN:

Also make sure that these prefs have the default value:

   media.windows-media-foundation.enabled
   media.directshow.enabled 

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

   http://kb.mozillazine.org/about:config 

tell me its help

thank you and regards,

Arman

more options

Thanks for the reply Arman.

I'm using Windows 10 Home Edition not Windows 7 N; I already have Windows Media Player installed. I can play MP4s in other areas of the OS (e.g. in Media Player itself, in the Edge browser etc).

Neither of those listed preferences were present. I'm assuming they're booleans and tried adding them but no combination of true/false for them seems to have made a difference.

more options

Penyelesaian Terpilih

Ok I have no idea how this happened, but looking in about:config I discovered that

   media.mp4.enabled

was somehow set to false!

Reverting that to its default true has fixed the issue.