Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't get borders around thumbnail links using PageStyle > No Style in Firefox 4

  • 6 replies
  • 3 have this problem
  • 7 views
  • Last reply by cor-el

more options

when a page has thumbnail links to larger pictures I used to use Page Style > No Style to get a border around those thumbnails in the default blue color which would change to the visited red color when I clicked them, making it easy to see which ones I'd already seen. e.g. This page

Now in Firefox 4 choosing No Style doesn't give any border around thumbnail links so I can't tell which ones I've already opened. How can I get the image borders back?

All Replies (6)

more options

Something like this?

@-moz-document domain(www.missing-lynx.com) {
:visited img { outline: 1px solid red !important; }
}
more options

Thanks for the reply. Which file do I insert that into, and would I need to do it for each domain I want?

Also, any idea why it worked in previous versions and not in FF4? Would there be one line to restore it for all sites?

more options

After a bit of googling I figured this must be added to userContent.css, but hasn't made any difference - still no borders.

more options

Do you see that outline after you have visited a link?

If the visited link status doesn't show then check that you keep history and that you do not run Firefox in Private Browsing mode.

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Permanent Private Browsing mode"

You can use this code for all sites.

:visited img { outline: 1px solid red !important; }


See this for other outline-style examples:

more options

Thanks for the follow up. No I don't get an outline after visiting, and am not in Private mode (no problem with text links showing visited colors), but I've tried some other examples that I found while searching and they don't work either so I must be doing something wrong.

I've just been adding the lines of code to the end of userContent.css on a new line after the last bracket already in the document. Is that right?

I also tried disabling the NoSquint plugin and restarting because it includes custom coloring for links so I thought it might be causing trouble but that didn't help either.

I'm also using the portable version of FF4, would that make any difference?

more options

You can try the Stylish extension to see if that works.