Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop annoying grouping messages!

  • 13 replies
  • 2 have this problem
  • 13 views
  • Last reply by Toad-Hall

more options

Looks like there is a bug in Thunderbird. On my laptop I did deactivate message grouping once and it works fine. On my desktop computer I have to deactivate this annoying ugly "feature" every time I start thunderbird.

How can I deactivate message grouping permanently? Can't imagine anybody uses this thing... it's the most annoying 'feature' I've seen since I've been using thunderbird - and that's maaaaany, many years!

Please stop this. It's really annoying. I can't believe it passed the quality check :(

Looks like there is a bug in Thunderbird. On my laptop I did deactivate message grouping once and it works fine. On my desktop computer I have to deactivate this annoying ugly "feature" every time I start thunderbird. How can I deactivate message grouping permanently? Can't imagine anybody uses this thing... it's the most annoying 'feature' I've seen since I've been using thunderbird - and that's maaaaany, many years! Please stop this. It's really annoying. I can't believe it passed the quality check :(

All Replies (13)

more options

There is threading, and grouping, and sorting features in the messge list pane

Please describe specifically what you are clicking on for "grouping", and post a screen shot if possible to show what you are referring to.

more options

=> menu => View => sort by => grouped by topic

That needs to be deactivated permamently :(

more options

Are we dealing with a translation of some sort back to English here? There is no such entry in the EN_US version 102.

Grouped by sorting (it your mail is sorted by topic, then the top part must have the sort set to "subject") is not a default and never has been.

Of course if you are accidentally clicking on the headings in the list, you will be sorting by the item you click on, a second click reverses the sort order. This certainly could look like sorting by "topic", but I am only guessing.

Do you exit Thunderbird on your desktop, or just shut it down from the start menu? As updates to many settings are only written on shut down, using the operating system force quit to end the program can have rather detrimental affects on it closing gracefully. Like the power going off before the write to disk actually occurs.

Laptops of course just go into some form of hibernation when you close the lid, often never terminating any programs in the process.

more options

Looks like it is the "threaded" setting. It's sooooo annoying! And it always re-activates :(


As I'm using my notebook only occasionally, I always shut it down properly. So there should be no difference in using either my desktop computer or my laptop.

I'm usually exiting thunderbird before I shut down my computer. So settings should be saved.

Modified by m.weber7

more options

Any news on this?

more options

Still no improvement on this :( It's really annoying...

more options

Can anyone suggest another mailclient? This behavior is really, really annoying! I have to change this setting everytime I start Thunderbird. Have been a Thunderbirduser for over 15 years now....but this 'feature' tells me: stop using thunderbird, look for something more basic, that doesn't hide mails you won't find in conversations. If I wanna chat, I have Telegram...but nobody needs this chat-view in mails!

more options

People who use Thunderbird offer their free time to help others in this Thunderbird forum so they are hardly going to suggest something else :)

I've just seen this question brought forward in the list. I do understand this constant resetting to 'threaded' is annoying. Clearly something has got stuck. It sounds like your settings are not getting properly stored after the session.

This may be the session.json file itself. It may have got corrupted. Probably the most common issue over the years has been security software (mostly ccleaner or wisecleaner) of various types deleting the file to protect your privacy. So each time Thunderbird is creating a new one.

So, before you do as suggested below - if you have any cleanup software like CCleaner, WiseCleaner or even some Anti-Virus products can offer cleaning up files like cache, session etc, I would strongly advise you make your thunderbird profile name exempt from access.

Please try the following:

  • Menu icon > Settings (or click on the gear icon at the bottom of left 'Spaces Toolbar' )
  • Select 'General'
  • Scroll to the bottom and click on 'Config Editor' button

It opens in a new tab and you may see a friendly warning.

  • In top search enter: mailnews.default_view_flags

The default is 1

  • click on the 'pencil icon to allow editing
  • Remove the 1 and type 0 (zero)
  • click on the tick icon to save.

Now access the profile and delete the current session file as it may be corrupted.

  • Menu icon > Help > More Troubleshooting information
  • Under 'Application Basics' - half way -Profile Folders' - click on 'Open Folder'

It opens in a new window showing the contents of your profile name folder.

  • Exit Thunderbird now this is important.

Delete the following files:

  • session.json
  • xulstore.json

Start Thunderbird

Select the 'Inbox' folder to check the sort is correct. View > Sort by > Unthreaded.

then right click on the column headers (star,attachment,read, From, Subject , Date ) to see drop down. At the bottom of list hover mouse pointer over : 'apply current view to' then hover over 'folder and it's children' then hover over the 'mail account name' to see list and select the mail account name folder at the top.

Use Thunderbird for a while and then exit. Wait a few moments for background processes to complete.

Start Thunderbird.

Please report on results.

more options

m.weber7 said

If I wanna chat, I have Telegram...but nobody needs this chat-view in mails!

I use threaded views quite extensively in a number of my folders. Especially those with mailing lists with replies from disparate users and where the topic goes off into separate branches. So as a "nobody", I would suggest you look to the information supplied by "Toad Hall". While there has been a switch from default off to default on. Nothing else has changed. Therefore your inability to save the changes is the problem, not the symptom which brought you here.

more options

Still an issue. Figured out, this happens on random computers. Just started a new job with a brand new computer which has the same, annoying behavior.

more options

m.weber7 said

Still an issue. Figured out, this happens on random computers. Just started a new job with a brand new computer which has the same, annoying behavior.

It is the default, nothing random about it!. If you do not want to have it you need to actually make the changes you have been advised about on each profile you create.

This is the last time I will post on this thread as the information is 100% complete here for you to make the changes. Anything else is just a waste of time.

more options

Matt, your suggestion worked very well.

I did a complete re-installation of Windows 10, downloading the software from the web, and when I re-installed Thunderbird, which had this very annoying feature.

Another annoying feature it has is that it automatically gets messages from my web server. I'd rather read messages when I want to devote the time to it. But I haven't yet figured out how to change that.

Many thanks.

more options

re: Another annoying feature it has is that it automatically gets messages from my web server.

You could set up Thunderbird to always open in 'Offline' mode and then manually swap to 'Online' mode when you want to download emails. In bottom far left corner of 'Status Bar' is the Online/Offline icon which can be used as a quick link to Online/Offline mode.

This is where you can set up your default 'Offline' options eg: if you want to start Thunderbird in Offline mode or ask you what you want on startup etc.

  • Menu icon > Settings > General
  • scroll to 'Network & Disk Space' section
  • click on 'Offline' button

Otherwise or in addition - you could set up the account to not check for messages.

  • In 'Account Settings'
  • Select: Server Settings

if you want to start up in Online mode and perform an initial check then select the first checkbox otherwise:

  • Uncheck checkbox: 'Check for new messages at start up' -
  • Uncheck checkbox: 'Check for new messages every x minutes'

If pop then:

  • Uncheck checkbox: Automatically download new messages
  • If imap then:

Uncheck checkbox: 'Allow immediate server notifications when new messages arrive' However, please note: if server uses IDLE and Push then you may discover server will connect to inform you about new messages even if this option is not selected.