Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Secure Connection Failed"

  • 4 replies
  • 1 has this problem
  • Last reply by jonzn4SUSE

more options

Hello. I've been using Firefox since it fist came out and never had this problem until recently. Many websites I've been visiting for years with Firefox, now won't load and I get the message "Secure connection failed" with the error "PR_END_OF_FILE_ERROR". There is nothing to click to bypass the error, and I end up having to use a different browser to go to those many websites. These are sites that I trust and use daily for my business. How do I set up a "trusted site" list or otherwise bypass this error? Why is this suddenly an issue? The error page says to "contact the website owners to inform them of this problem", but they couldn't care less. Every one of them has told me to just use a different browser. I don't want to stop using Firefox, but this has become such a constant problem that I'm ready to go elsewhere if you don't have a simple solution. From reading others posts, I see that this has become a big problem, but no easy solutions have been posted. Hope you can help. Thank you!

PS Why is it so difficult to contact someone for Firefox Support?

All Replies (4)

more options

Which sites? What security software are you running?

Modified by jonzn4SUSE


more options

You can try to disable DNS over HTTPS.

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

See also:

Modified by cor-el


more options

I've been using Bitdefender Security for years without any problems, and as I said, I can access these sites on other browsers, so it can't be an issue with the security software. The sites are all related to my business:

There are many more.

I haven't changed my settings in Firefox. And as I said, I would like a simple solution, not something I have to goose-chase.



more options

Have you tried the steps mentioned above? Have you tried turning off Bitdefender to see if you still have the same issue?


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.