Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Secure connection failed" on Firefox but not on other browser, starting in last week

  • 5 replies
  • 1 has this problem
  • 104 views
  • Last reply by ronks1

more options

Intermittently but more than half the time in the last week, links on Firefox (but not on Edge) to common sites like docs.microsoft.com return > Secure Connection Failed An error occurred during a connection to docs.microsoft.com. The OCSP response does not include a status for the certificate being verified. Error code: MOZILLA_PKIX_ERROR_OCSP_RESPONSE_FOR_CERT_MISSING

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

--- Have cleared cache and rebooted; no change. It looks like the problem is with the browser and not the web site. Running FF 95.0 64-bit on Windows 10

Intermittently but more than half the time in the last week, links on Firefox (but not on Edge) to common sites like docs.microsoft.com return > Secure Connection Failed An error occurred during a connection to docs.microsoft.com. The OCSP response does not include a status for the certificate being verified. Error code: MOZILLA_PKIX_ERROR_OCSP_RESPONSE_FOR_CERT_MISSING The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. --- Have cleared cache and rebooted; no change. It looks like the problem is with the browser and not the web site. Running FF 95.0 64-bit on Windows 10

Chosen solution

Hi ronks1,

We just release Firefox 95.0.1 that should fix this issue. Can you update your Firefox and confirm if your issue is fixed?

Read this answer in context 👍 1

All Replies (5)

more options

Many have reported issues with Microsoft. The thinking here is it is a website issue.

more options

Thanks! That was my first thought, too, and I sent MS Feedback a report. But Edge seems to have no problem with it. Either MS recognizes a family member  :-) or it's just the intermittent nature of the problem. Or their support staff is all at the company Christmas party. I'll try to wait it out.

more options

Related bug (should be fixed soon) Bug 1745600 MOZILLA_PKIX_ERROR_OCSP_RESPONSE_FOR_CERT_MISSING on some Microsoft sites

more options

Chosen Solution

Hi ronks1,

We just release Firefox 95.0.1 that should fix this issue. Can you update your Firefox and confirm if your issue is fixed?

more options

It was intermittent, so it's hard to be sure. But I think it has fixed the issue. Thanks!