X
Tap here to go to the mobile version of the site.

Support Forum

How to fix Java placeholders instead of buttons on Firefox 31?

Posted

I think this is Java... I have lots of placeholders instead of working icons, particularly on Twitter, DuckDuckGo and many other sites. I'm using FF31 on a MacAir, but have the same problem with FF28 on an iMac. I've tried restoring FF and that helps for one session; as soon as I close the browser we're back to placeholders.

I think this is Java... I have lots of placeholders instead of working icons, particularly on Twitter, DuckDuckGo and many other sites. I'm using FF31 on a MacAir, but have the same problem with FF28 on an iMac. I've tried restoring FF and that helps for one session; as soon as I close the browser we're back to placeholders.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.07
  • 5.1.30317.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

guigs
  • Top 10 Contributor
  • Administrator
  • Moderator
859 solutions 9541 answers

Helpful Reply

Hi rainbowcat, Can you clarify what you mean by java placeholder? Maybe a screenshot would help :-)

Hi rainbowcat, Can you clarify what you mean by java placeholder? Maybe a screenshot would help :-)

Question owner

Thank you for your reply. I've attached a screen shot from Twitter and DuckDuckGo. They are small boxes, with letters in the middle instead of a picture. Maybe it's not Java? I have the same problem with icons from websites on my toolbar. And just to make things even worse, FF now twitches and jumps every time I switch from one site to another. Any help would be greatly appreciated!

Thank you for your reply. I've attached a screen shot from Twitter and DuckDuckGo. They are small boxes, with letters in the middle instead of a picture. Maybe it's not Java? I have the same problem with icons from websites on my toolbar. And just to make things even worse, FF now twitches and jumps every time I switch from one site to another. Any help would be greatly appreciated!

Modified by rainbowcat

cor-el
  • Top 10 Contributor
  • Moderator
13055 solutions 119587 answers

Helpful Reply

The missing icons are supplied by a font that is downloaded from the server (@font-face) as you can probably see by little boxes that show the hex code of the characters.

Make sure that you allow pages to choose their own fonts to make Firefox use downloadable fonts.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

The missing icons are supplied by a font that is downloaded from the server (@font-face) as you can probably see by little boxes that show the hex code of the characters. Make sure that you allow pages to choose their own fonts to make Firefox use downloadable fonts. *Firefox > Preferences > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Modified by cor-el

Question owner

Thank you so much - that fixed it! Strange how I can over-ride fonts on Safari and not have that problem.

Any idea why I don't have icons on my toolbar? Or how to stop the twitching when I browse?

Thanks again for taking the time to help!

Thank you so much - that fixed it! Strange how I can over-ride fonts on Safari and not have that problem. Any idea why I don't have icons on my toolbar? Or how to stop the twitching when I browse? Thanks again for taking the time to help!
cor-el
  • Top 10 Contributor
  • Moderator
13055 solutions 119587 answers

You're welcome.

If you disable website fonts in Firefox then you also disable icon fonts as many websites use these days.


Are that bookmark favicons on the Bookmarks Toolbar?

If you see the favicon on the tab if you open such a link then you should also see that on a bookmark unless the link redirects to another web page or domain.

You're welcome. If you disable website fonts in Firefox then you also disable icon fonts as many websites use these days. ---- Are that bookmark favicons on the Bookmarks Toolbar? If you see the favicon on the tab if you open such a link then you should also see that on a bookmark unless the link redirects to another web page or domain.

Question owner

Yes, those are favicons. They don't work any more, but they don't redirect. I've reinstalled them twice while FF is jumping about.

Yes, those are favicons. They don't work any more, but they don't redirect. I've reinstalled them twice while FF is jumping about.
cor-el
  • Top 10 Contributor
  • Moderator
13055 solutions 119587 answers

You can check for problems with the places.sqlite database file in the Firefox profile folder.


You can let all favicons expire to see if that makes Firefox store them properly if you revisit the web page.

You can open the Browser Console (Firefox/Tools > Web Developer). Paste the JavaScript code in the command line and press the Enter key to run the code.

  • Toggle the devtools.chrome.enabled pref on the about:config page to true to enable the command line
var fS = Components.classes["@mozilla.org/browser/favicon-service;1"]
         .getService(Components.interfaces.nsIFaviconService);
fS.expireAllFavicons();

See also:

You can check for problems with the <b>places.sqlite</b> database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file *Places Maintenance: https://addons.mozilla.org/firefox/addon/places-maintenance/ ---- You can let all favicons expire to see if that makes Firefox store them properly if you revisit the web page. You can open the Browser Console (Firefox/Tools > Web Developer). Paste the JavaScript code in the command line and press the Enter key to run the code. *Toggle the devtools.chrome.enabled pref on the <b>about:config</b> page to true to enable the command line <pre><nowiki>var fS = Components.classes["@mozilla.org/browser/favicon-service;1"] .getService(Components.interfaces.nsIFaviconService); fS.expireAllFavicons();</nowiki></pre> See also: *https://developer.mozilla.org/Tools/Browser_Console#Browser_Console_command_line

Question owner

I guess they are not really favicons - they are tool buttons. KeepIt! downloads video, and PinIt is for pinning a picture or video onto Pinterest. Neither button works. Sorry for having the wrong vocab, and I thank you muchly for your time trying to solve this for me.

I guess they are not really favicons - they are tool buttons. KeepIt! downloads video, and PinIt is for pinning a picture or video onto Pinterest. Neither button works. Sorry for having the wrong vocab, and I thank you muchly for your time trying to solve this for me.
jscher2000
  • Top 10 Contributor
3981 solutions 34762 answers

Aha, "bookmarklets" are scripts that don't have a site icon. If you want to attach an icon to them, you could craft a custom style rule for each one, but it might be more trouble than it's worth.

Aha, "bookmarklets" are scripts that don't have a site icon. If you want to attach an icon to them, you could craft a custom style rule for each one, but it might be more trouble than it's worth.
cor-el
  • Top 10 Contributor
  • Moderator
13055 solutions 119587 answers

I have code in userChrome.css to set a default favicon for items that do not have one. Some suitable icons are in this file:

  • chrome://global/skin/icons/folder-item.png

This should work for the Bookmarks Toolbar:

@namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.bookmark-item:not(src):not([container]):not([type]){
 list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
 -moz-image-region: rect(0px,16px,16px,0px)!important;
}
.bookmark-item[container]:not([livemark]):not([query]){
 list-style-image: url("chrome://global/skin/icons/folder-item.png")!important;
 -moz-image-region: rect(0,32px,16px,16px)!important;
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css. Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file
I have code in userChrome.css to set a default favicon for items that do not have one. Some suitable icons are in this file: *chrome://global/skin/icons/folder-item.png This should work for the Bookmarks Toolbar: <pre><nowiki> @namespace url("https://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ .bookmark-item:not(src):not([container]):not([type]){ list-style-image: url("chrome://global/skin/icons/folder-item.png")!important; -moz-image-region: rect(0px,16px,16px,0px)!important; } .bookmark-item[container]:not([livemark]):not([query]){ list-style-image: url("chrome://global/skin/icons/folder-item.png")!important; -moz-image-region: rect(0,32px,16px,16px)!important; } </nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive) *Paste the code in the userChrome.css file in the editor window *Make sure that the userChrome.css file starts with the default @namespace line *Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css. Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

Question owner

Thank you for all that research and work! These critters had icons before - they disappeared with FF31. I really don't want to go back to 28, which is where I was when they worked. I'll just use Safari for Keep It and PinIt and make everyone's life easier. You are an awfully kind soul to do all this work for me. Thanks again.

Hate to impose, but do you have any idea how to stop the twitching about?

Thank you for all that research and work! These critters had icons before - they disappeared with FF31. I really don't want to go back to 28, which is where I was when they worked. I'll just use Safari for Keep It and PinIt and make everyone's life easier. You are an awfully kind soul to do all this work for me. Thanks again. Hate to impose, but do you have any idea how to stop the twitching about?

Modified by rainbowcat

jscher2000
  • Top 10 Contributor
3981 solutions 34762 answers

What is the twitching? Something wrong in pages when you scroll them? Something odd on the toolbar?

What is the twitching? Something wrong in pages when you scroll them? Something odd on the toolbar?

Question owner

Toolbars are okay. The entire page jumps up and down every time I switch pages. Often when scrolling down when I release the track pad the page scrolls itself back up.

Toolbars are okay. The entire page jumps up and down every time I switch pages. Often when scrolling down when I release the track pad the page scrolls itself back up.