Showing questions tagged: Show all questions
  • Solved
  • Archived

User agent string wrong, about:config claims it's the default one

My UserAgent string is wrong. It has the wrong OS and the wrong Firefox version. I ran into the article explaining how to reset it, but when I search for "useragent", I d… (read more)

My UserAgent string is wrong. It has the wrong OS and the wrong Firefox version. I ran into the article explaining how to reset it, but when I search for "useragent", I don't see any of the suggested preferences (see also screenshots).

It might be relevant that I had the UAControl extension installed, until it got automatically disabled due to the switch to WebExtensions. That might have had the "wrong" user agent selected when it was disabled. But I still can't find where it was set or how to reset it.

Asked by aiviv 1 year ago

Answered by jscher2000 1 year ago

  • Solved

Firefox has the wrong user-agent set

It looks like Firefox has the wrong user-agent set. I've made a few changes to about:config that I found on privacytools.io but none of them had anything to do with the u… (read more)

It looks like Firefox has the wrong user-agent set. I've made a few changes to about:config that I found on privacytools.io but none of them had anything to do with the user-agent. I read through Mozilla's "reset the default user-agent" article but none of the mentioned settings are in my about:config so there's nothing to reset. I would create them myself but I don't know what they should be set to (the article only says to click the "reset" button next to them). I'm running Ubuntu Linux but it seems Firefox is telling websites I'm running Windows...for proof see the screenshot attached to this post.

Hmm...it seems this page detected that I'm running a variation of Linux although no other pages (such as the one in the screenshot) could. What can I do?

Edit: it looks like this page says my user agent is correct (it shows Linux), however many many other sites on the internet say I'm running Windows. I'm really confused now.

Asked by jacobsimone12 2 months ago

Answered by cor-el 2 months ago

  • Solved
  • Archived

Why do other websites think I am using Opera version 38 when I have FireFox version 65.0.1?

I am using FireFox v65.0.1 with the latest macOS Mojave. When I go to some websites, I get a message that my browser is outdated. If I go to whatismybrowser.com, I get th… (read more)

I am using FireFox v65.0.1 with the latest macOS Mojave. When I go to some websites, I get a message that my browser is outdated. If I go to whatismybrowser.com, I get the message that I am using Opera version 38. Why is my FireFox browser being misidentified.

Asked by jhuller 1 year ago

Answered by philipp 1 year ago

I changed my user agent, now I can't chage it back. I can't get through to your site on the computer with the changed browser. What do I do?

To upload photos to Instagram I changed my user agent to replicate an iPhone. Now I can't change it back. I can't get through to your site on the effected computer with t… (read more)

To upload photos to Instagram I changed my user agent to replicate an iPhone. Now I can't change it back. I can't get through to your site on the effected computer with the changed browser. Thus, I can't download a new version of Firefox. I understand there may be a "revert to original" command somewhere, but I can't find it. HELP! What do I do? Thank you very much for your assistance,

Asked by Richard Nodine 3 months ago

Last reply by cor-el 3 months ago

  • Archived

While using fully updated Firefox and logged in, I cannot download any addon because I am only asked to Download Firefox.

My browser is 65.0.2 (64-bit), up-to-date. When attempting to download/install a new add-on, I am provided no option for doing so. The only available button for download … (read more)

My browser is 65.0.2 (64-bit), up-to-date. When attempting to download/install a new add-on, I am provided no option for doing so. The only available button for download is "Only with Firefox, Get Firefox Now". This is the same for every add-on. I have tried using Firefox in Safe Mode with all add-ons off and it still did not work.

Asked by marineqtip 1 year ago

Last reply by FredMcD 1 year ago