Showing questions tagged: Show all questions
  • Solved

Firefox exclusively scrolling extremely fast

Scrolling in Firefox is causing any webpage to scroll many lines at once with a single click, and it seems to be exclusively happening to Firefox, as every other applicat… (read more)

Scrolling in Firefox is causing any webpage to scroll many lines at once with a single click, and it seems to be exclusively happening to Firefox, as every other application scrolls normally. I have tried searching here and elsewhere for a solution, and I have tried to change about:config settings based on the recommendations I could find to no avail. I have also tried to refresh Firefox and have used Troubleshoot Mode, but those too have not worked. I have no clue as to what could have caused this, as I have not been messing with any settings prior to this.

Asked by eventfulhorizon 2 months ago

Answered by eventfulhorizon 2 months ago

  • Solved

Installing custom Firefox extension

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about … (read more)

I'm at a loss for words here. I have a website I frequent and it has a really annoying behavior. I'm a developer so finally I mustered the strength to do something about it. I googled how to create an extension in Firefox and within 5 minutes I had a working extension that solved their annoyance. However, I can only load it temporarily. If I close Firefox, it goes away. When I try to actually install it, it says I need to have it signed. I have now spent the better part of an hour trying to find out how to self sign it. I refuse to believe that I have to submit this to Mozilla for me to be able to install my own code. Can someone please send me in the direction of how i self sign and install my own extension. I have no intention of publishing, I only want to run this for myself.

Asked by viktor37 2 months ago

Answered by cor-el 2 months ago

  • Solved

macOS disable Firefox default browser prompt non-interactively

I am trying to configure Firefox on macOS to not prompt the user to make it the default browser. I am using the following script to create the profile and set the user p… (read more)

I am trying to configure Firefox on macOS to not prompt the user to make it the default browser.

I am using the following script to create the profile and set the user preferences after installing Firefox by copying `Firefox.app` from the downloaded DMG: ```

  1. !/bin/sh

open -a Firefox.app --args -CreateProfile default sleep 1

write_userpref() { USER=$(whoami) PROFILE=$(ls -1 "/Users/${USER}/Library/Application Support/Firefox/Profiles/" | grep -E "\.default$") cat << EOF > "/Users/${USER}/Library/Application Support/Firefox/Profiles/${PROFILE}/user.js" // mandatory comment? user_pref("app.update.auto", false); user_pref("app.update.disable_button.showUpdateHistory", false); user_pref("app.update.enabled", false); user_pref("breakpad.reportURL", ""); user_pref("browser.newtabpage.activity-stream.feeds.topsites", false); user_pref("browser.newtabpage.activity-stream.feeds.section.topstories", false); user_pref("browser.tabs.crashReporting.sendReport", false); user_pref("browser.discovery.enabled", false); user_pref("browser.defaultbrowser.notificationbar", false); user_pref("browser.shell.checkDefaultBrowser", false); user_pref("browser.shell.didSkipDefaultBrowserCheckOnFirstRun", false); user_pref("browser.shell.skipDefaultBrowserCheckOnFirstRun", true); user_pref("browser.newtabpage.enabled", false); user_pref("experiments.enabled", false); user_pref("extensions.pocket.enabled", false); user_pref("toolkit.telemetry.enabled", false); user_pref("update_notifications.enabled", false); EOF }

write_userpref

open -a Firefox.app --args -new-tab -P default "about:blank" sleep 3 osascript -e 'quit app "Firefox"' sleep 2

open -a Firefox.app --args -P default about:blank ```

Here's the behaviour I'm seeing:

  1. Firefox starts to an `about:blank` tab, however there is a second "Firefox Privacy Notice" tab
  2. AppleScript quits Firefox
  3. Firefox starts to an `about:blank` tab, however it is now prompting me to make it the default browser

I do not want Firefox to prompt the user to become the default browser.

My ideal scenario is that Firefox starts without the "Firefox Privacy Notice" tab and without prompting me to make it the default browser. From the observed behaviour, this doesn't seem possible.

Can anyone tell me how I can accomplish this without user interaction or MDM?

Asked by hal.martin 3 days ago

Answered by hal.martin 2 days ago

  • Solved

honey shopping app - drop down boxes wont open

If i am on amazon for example and an item has more than 1 option, Honey presents drop down selection box so you can choose which one to drop list The issue is the drop d… (read more)

If i am on amazon for example and an item has more than 1 option, Honey presents drop down selection box so you can choose which one to drop list The issue is the drop down box never opens when you click on it, doesn't matter where on it you click, it wont open. I have cleared cache, reinstalled honey and nothing helps. I have multiple desktop pc's all running tumbleweed and they all have this issue. If i load Chromium that works ok, but i use Firefox and not Chromium. I'm using openSuse Tumbleweed (latest update).

Asked by Cat22 4 months ago

Answered by Cat22 4 months ago

  • Solved

Webpage elements do not open.

On this webpage on the link below, when the 'Comments' button is clicked, nothing happens. It works via the Chrome browser. https://www.mirror.co.uk/news/politics/george… (read more)

Asked by johnh009 2 months ago

Answered by zeroknight 2 months ago

  • Solved

Hostinger h-panel

Since about 13:00 GMT yesterday, Firefox could not load or display the Hostinger h-panel. It sometimes partially and sometimes completely displays all the page content. B… (read more)

Since about 13:00 GMT yesterday, Firefox could not load or display the Hostinger h-panel. It sometimes partially and sometimes completely displays all the page content. But all the controls are dead. Firefox seems to be very busy doing something. I told Hostinger and they spent some time looking into the problem. They got Firefox to load the h-panel but said that it was vastly slower than other browsers in doing so. With me, Firefox still stops doing anything once the content is loaded and ALL controls on the page are still dead. When closing Firefox in this state, there is considerable delay before the window actually closes.

I thought that perhaps Hostinger had done an update that called in some proprietary JavaScript extensions that Firefox couldn't handle. I get the impression that in trying to display the h-panel pages, Firefox is trying to acquire some content from an external site, as requested somewhere within the HTML/JavaScript source code.

Any ideas? robert_john.morton@yahoo.com

Asked by robert_john.morton 4 months ago

Answered by robert_john.morton 4 months ago

  • Solved
  • Archived

Impossible to use an unusual port number in local URL

Hi all :) From a fresh Linux Debian Bullseye I try to connect to a local machine with Firefox (v97 64-bits) by its hostname (avahi server with default domain "local… (read more)

Hi all :)

From a fresh Linux Debian Bullseye I try to connect to a local machine with Firefox (v97 64-bits) by its hostname (avahi server with default domain "local") with the port 6180 bound to a remote web service port (61 is the distant machine IP and 80 is the forwarded port).

When I want to open this URL : http://bionic.local:6180/ FF displays "We can't find this site ... Unable to connect to server at bionic.local ... check your network connection and firewall"

BUT ping bionic.local works perfectly and resolve the good IP address from the Chromium navigator the same URL works without a problem, I can open the distant web site.

This workaround works : add a static resolution in the /etc/hosts file : 192.168.0.71 bionic bionic.local => so FF works in the expected way for now ! But as I said this a workaround and a bad solution.

I supposed too the port was blocked because I accessed an unusual port. So I tried this without success.

How the hell make that FF v97 allows me to use an unusual port ? Or is it bound to the domain "local" which is no more accepted by FF ?

Thank you in advance for your help. With adelphity, lnj

How to do

Asked by estebann 2 years ago

Answered by estebann 2 years ago

  • Solved
  • Archived

how is profile blanked, but not fully gone?

Basically, a requested relaunch blanked my profile and I can't get it back. I have a lengthy workaround that will take over an hour to fix from backups, before this inc… (read more)

Basically, a requested relaunch blanked my profile and I can't get it back.

I have a lengthy workaround that will take over an hour to fix from backups, before this incident, but I'd really like to understand what's going on. How can my add-ons, bookmarks, history, logins, etc. be gone? If I did a refresh on purpose, why would my shortcuts remain intact? And, I started by backing up my profile folder to a neutral spot, so why isn't replacing it reversing the changes?

As background: The "about:profiles/Restart With Add-ons disabled" button brings up a small button dialogue to choose "refresh" or default "open." I selected "open" because I didn't want to fix my profile and assumed I would relaunch with only add-ons disabled, so this was a potential point of screw-up. I assume selecting "refresh" would reset application defaults and make a mess exactly like I find myself in now. Shouldn't "Restart with Add-ons disabled/Open" relaunch a temporary and reversible state? Doesn't "refresh" prompt a new default profile?

Considering evidence only, it appears I did something to roast my profile before I backed it up, but that's strange and really out in the weeds, and I'm assuming I wrecked it with my current activity.

The default profile name and path are correct. My shortcut links and labels that I use for a home page are intact but with icons missing, the same appearance as if I deleted the cache; is this detail part of application settings and not profile?

Asked by SkyHook 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

Prevent websites from opening new tabs

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop… (read more)

I just reinstalled my operative system, and with that my Firefox settings got reset. I know there is an entry in about:config to prevent ads from opening new tabs and pop ups without authorization, even from legit websites like the login pop-up windows when doing a sign in in Google, in those cases to allow the windows it's needed to click on the lock icon next to the URL bar and allow it from there. The problem is that I don't remember the name of that setting and I have spend an hour looking for it on Google.

Asked by ttfh3500 2 years ago

Answered by ttfh3500 2 years ago

  • Solved
  • Archived

Unable to show File Picker

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it … (read more)

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it was nowhere near the top of Google's results, I thought I'll share my solution in the hopes that this would help someone facing this same issue.

The hardware:

  • Asus UM425IA Zenbook (AMD Ryzen 7 4700U CPU)

Worked in:

  • Ubuntu 20.04 LTS
  • Firefox provided by APT repository
  • Xorg display server

Not working in:

  • Ubuntu 22.04 LTS
  • Firefox 99.0.1 provided by snap
  • Wayland display server
  • File picker worked briefly on fresh install, but something (not sure what) quickly breaks file picker functionality

The symptoms:

  • Firefox stopped being able to open file picker dialogs
  • Right clicking an image and selecting "Save Image As..." does nothing
  • With forms that accept file upload (such as on this post question page "Add images (optional):"), clicking "Browse" does nothing
  • File downloads work correctly when set to "Save files to ..." under Settings, but nothing happens when set to "Always ask you where to save files"
  • No response to "Ctrl + O" open file shortcut

Similar questions and solutions:

Things I tried that did not work:

  • Disabling hardware acceleration
  • Starting with add-ons disabled
  • Troubleshoot mode
  • Clearing startup cache
  • Clearing cookies and site data
  • Clearing history
  • Refreshing Firefox
  • Creating and using a new profile
  • Deleting the `xulstore.json` file from the profile directory
  • Toggling all permissions under Ubuntu Settings > Applications > Firefox to off and then back to on
  • chmod 777 ~/Downloads
  • Disabling native file picker "ui.allow_platform_file_picker = false"

And finally, what fixed it for me was to go into "about:config" and change "widget.use-xdg-desktop-portal.file-picker" from "2" to "0". Credit to this post that clued me in.

I really hope this saves someone else 2 days of hair pulling and I would appreciate advice from someone more knowledgeable than me on:

  • Why this fixed the problem
  • Whether I should be opening a bug report either against Firefox, or Ubuntu
  • Whether I should also be changing "widget.use-xdg-desktop-portal.mime-handler" and "widget.use-xdg-desktop-portal.settings", both are currently set to "2"

Asked by James Fu 2 years ago

Answered by Kiki 1 year ago

  • Solved
  • Archived

Firefox Automatically Redirecting from HTTP to HTTPS (RESOLUTION)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites. I finally found a fix for th… (read more)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites.

I finally found a fix for the issue. The problem appears to be with DuckDuckGo Privacy Essentials Extension which apparently *may automatically redirect to the http site. In order to prevent this, I added my development sites to 'Unprotected Sites' and this prevented DuckDuckGo from doing the automatic redirect to https.

  • - Odd thing is that I had multiple domains pointing to the same web instance and only one of the domains was having this issue with the DDG extension. Both were going to the same IP through a HTTP proxy. The proxy and web server were not the issue. This symptom points to an maybe an issue in Firefox....

In summary, be wary of odd redirects and the DuckDuckGo Privacy Essentials extension if you are doing web development work.

Asked by Timothy C. Quinn 2 years ago

Answered by Timothy C. Quinn 2 years ago

  • Solved
  • Archived

opt-out the saved passwords proposals

Hi, is there a config option to prevent the showing of user/pw proposals when opening a website for which user account data is saved? When i'm logging into a website wit… (read more)

Hi,

is there a config option to prevent the showing of user/pw proposals when opening a website for which user account data is saved? When i'm logging into a website with already saved user data, i get account proposals (as ff saves the data "per domain", say if you have 3 accounts to one website, e.g. a test user, an administrator and a cms administrator, they are all presented where needed content may be...) see pict. I would like to opt out this behavior, as i have more than one website with 2 or more accounts.


-- cu

jth

Asked by jth 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

How to unbind Ctrl+K?

I was using Ctrl+K on some websites to do things like site-specific search, task bars, and so forth, but recently Firefox started capturing it for focusing on the search/… (read more)

I was using Ctrl+K on some websites to do things like site-specific search, task bars, and so forth, but recently Firefox started capturing it for focusing on the search/address bar (https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_search).

Is there a way to unbind `Ctrl+K` in Firefox?

Asked by astrojuanlu 2 years ago

Answered by astrojuanlu 2 years ago

  • Solved
  • Archived

Log in problems on 3rd party websites

On certain websites I notices I have 'unknown errors' when trying to log in. Usually this is remedied by either using Chrome or clearing cookies and the cache. Both of … (read more)

On certain websites I notices I have 'unknown errors' when trying to log in.

Usually this is remedied by either using Chrome or clearing cookies and the cache.

Both of there are inconvenient and result in a great deal of wasted time.

The usual response by these websites is "get Mozilla to fix this".

I'm getting sick of this.

I don't want to switch to Chrome but I will have to if this persists.

Asked by dominicpukallus 2 years ago

Answered by Amelia 2 years ago

  • Solved
  • Archived

Crash when loading some tabs on VNC server host

Since the Firefox 99 update loading some pages (for example, the Gmail sign-in page) using Firefox on my Linux Mint machine, that I'm running a VNC remote desktop session… (read more)

Since the Firefox 99 update loading some pages (for example, the Gmail sign-in page) using Firefox on my Linux Mint machine, that I'm running a VNC remote desktop session on, results in a crash.

Crash report ID: bp-5dc1e89d-dc1f-40f2-9dbe-7f4380220419

I've tried running Firefox in safe-mode and the crash doesn't happen, but turning off hardware acceleration, swapping to default themes, removing all extensions, and completely removing Firefox and the .mozilla folder and then re-installing Firefox have not changed the crash behaviour in the absence of the safe-mode flag.

I would appreciate help in identifying what other paths of investigation I can take.

Asked by KhaanephEx 2 years ago

Answered by KhaanephEx 1 year ago

  • Solved
  • Archived

Horizontal scrolling w. touchpad doesn't work on linux

I saw this post https://bugzilla.mozilla.org/show_bug.cgi?id=542690 where it seems implied that it should work, but on LMDE 5 w. firefox 98.0.2 64-bit scrolling horizonta… (read more)

I saw this post https://bugzilla.mozilla.org/show_bug.cgi?id=542690 where it seems implied that it should work, but on LMDE 5 w. firefox 98.0.2 64-bit scrolling horizontally w. touchpad doesn't work for scrolling on pages nor for scrolling the tab list at the top.

Asked by maartentenvelden 2 years ago

Answered by maartentenvelden 2 years ago

  • Solved
  • Archived

How do I get my home page in Firefox on all my tabs?

Now on Firefox 100.0.1 On earlier versions of Firefox I was able to set a particular url for my home(opening) page. That is still true. However, on past versions I was … (read more)

Now on Firefox 100.0.1 On earlier versions of Firefox I was able to set a particular url for my home(opening) page. That is still true. However, on past versions I was also able to make *my home page* appear on every tab I opened. On the current edition I get a choice of only Firefox Home Page (default) or Blank page. I cannot get my home page on the new tab. How can I bypass the restrictions of the settings under Home to get my home page on every tab?

That the question I need an answer to. Everything below this is explanation of why I want this and a complaint about how Firefox changes things that I would appreciate being passed on to the developers.

                                                                    <---------------------->

If I choose Firefox Home Page (default), I am *forced* to use the address box to put in my search terms. I have become accustomed to the various search engines with their splash screens - with the nice big search box in the middle of the screen (both horizontally and vertically). It is absolutely unnerving to me to try to type in the box in the middle and have nothing show up there but up above in the address box.

I am a project person in a multi-tasking world, which means whether I like it or not, I have to multitask too. For me to do this successfully, all my tools need to be where I expect and perform as I expect them. Even putting duckduckgo.com in the current home page/new window setting, doesn't get the duckduckgo splash page, but even though I'm not that technically advanced, I found a way of getting it in my home page window. However, the tabs section doesn't offer me an opportunity to put my own choice in.

I wish Firefox would stop tinkering with otherwise minor things. I understand fixing found vulnerabilities. I understand providing new services and technology when they're developed. But why force people to use search and tabs the way Firefox wants them to rather than the way the user is accustomed to.

Asked by bdjim 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

Unable to play Twitter/Reddit/Facebook Video and GIFs on Firefox 99.0.1 (64-bit)

I have fedora 36 Linux on my laptop and I have installed Firefox from the software store. The version in Help>About>About Firefox shows 99.0.1 (64-bit). I am able … (read more)

I have fedora 36 Linux on my laptop and I have installed Firefox from the software store. The version in Help>About>About Firefox shows 99.0.1 (64-bit).

I am able to play videos on Youtube but no video or GIF is playing on Twitter/Reddit/Facebook.

I have installed media codecs as per this fedora help

My autoplay setting look like as per the attached image. I do not have any extensions except Bitwarden on Firefox.

I also tried playing videos on Firefox 100 by downloading it directly from firefox website but faced the same issue.

Asked by Bhanu Magotra 2 years ago

Answered by Bhanu Magotra 1 year ago

  • Solved
  • Archived

Add-ons don't work, and tabs crash, since update to F36

$ dnf list installed | grep firefox firefox.x86_64 100.0-4.fc36 Since upgrading to Fedora 36, Firefox seems to have stopped being stab… (read more)

$ dnf list installed | grep firefox firefox.x86_64 100.0-4.fc36

Since upgrading to Fedora 36, Firefox seems to have stopped being stable at all. Having any add-ons enabled causes webpages to frequently break. Even in troubleshooting mode, I get a tab crash immediately on start, and infrequently during later browsing.

Troubleshooting mode has the same issues, trying a completely clean profile has the same issues. Chromium works with no issues.

See tab crash report here: https://pastebin.com/wNPFhpgN

Asked by zoknozelte 2 years ago

Answered by FredMcD 2 years ago