Showing questions tagged: Show all questions
  • Solved
  • Archived

Some websites say I need to upgrade my browser even though I already did.

Hey, I've downloaded the last version of Firefox like 5 times but some sites like Youtube, Myspace and Twitter keep telling me that I need to upgrade Firefox because my v… (read more)

Hey,

I've downloaded the last version of Firefox like 5 times but some sites like Youtube, Myspace and Twitter keep telling me that I need to upgrade Firefox because my version is no longer supported. I also have the latests versions of Flash Player and Java. I've tried everything, uninstalling those three and installing them again. And if I use Google Chrome or even an older version of Internet Explorer everything seems right. This just happens while on Firefox. What's going on?

I'm asking this because I like to use Firefox and I don't want to have to migrate to Chrome.

Thank you,

Andrea.

Asked by HarinaPana 10 years ago

Answered by TonyE 10 years ago

  • Archived

Latest Firefox is installed, but all sites say I have version 2.0 still. Tried Uninstalling, didn't work. Tried updating, didn't work. I can't use add-ons or go to certain sites because they all say I have 2.0! But I've got 3.6 installed.

What else can I do? Myspace and youtube are blocking me because my browser is out of date, but i've downloaded and re-downloaded 3.6, and it still says 2.0.

Asked by RileyBrooks 10 years ago

Last reply by RileyBrooks 10 years ago