Showing questions tagged: Show all questions
  • Solved

Downloading and Opening docx Firefox appends doc onto file

I am using Hotdocs portal, which is an in-house document assembly tool. Firefox is the recommended browser, but it is recently handling 2016 docx files incorrectly. Whe… (read more)

I am using Hotdocs portal, which is an in-house document assembly tool. Firefox is the recommended browser, but it is recently handling 2016 docx files incorrectly. When we choose a file on the portal site (internal site), we go through the interview and are presented with a link to "download" the assembled file. When you click that link, a pop-up appears showing the file name as abc.docx but then says it is a Word 97 - 2003 document, even though it is not. The original template is not. If I choose to open the file, it ends up opening and showing as abc.docx.doc If I save the file, instead of opening it, it saves as abc.docx.

If we run this same process in IE/Edge, the file opens as abc.docx as it should. I have uninstalled Firefox and reinstalled. Is there anything that could be causing this? I've tried a bunch of troubleshooting steps and nothing seems to change this outcome.

Thank you.

Asked by misscrf 5 months ago

Answered by cor-el 5 months ago

  • Solved

Firefox refreshed/update and deleted all my passwords, cookies, links everything!

Firefox restarted/updated and it cleared my entire browser history, bookmarks, logins, passwords, links etc... how do I get all my data back?!?!?! wth!!! there's no Folde… (read more)

Firefox restarted/updated and it cleared my entire browser history, bookmarks, logins, passwords, links etc... how do I get all my data back?!?!?! wth!!! there's no Folder on my desktop with all my data :( I'll wait for feedback. Thank you!

Asked by ruana.m7 4 hours ago

Answered by jscher2000 4 hours ago

  • Solved

Hexadecimal characters in Firefox, NOT in Chrome

When I open Wunderground in FF I get hexadecimal character maps for many buttons. https://www.dropbox.com/s/ci3v1ag7ppynkbw/Screen%20Shot%202020-11-22%20at%209.35.59%20P… (read more)

When I open Wunderground in FF I get hexadecimal character maps for many buttons. https://www.dropbox.com/s/ci3v1ag7ppynkbw/Screen%20Shot%202020-11-22%20at%209.35.59%20PM.jpg?dl=0

In Chrome, they're fine: https://www.dropbox.com/s/zj855hxep7mx7rs/Screen%20Shot%202020-11-22%20at%209.30.49%20PM.jpg?dl=0

HUH?? With the Wunderground page open, the "text encoding" under the View menu is grayed out so I can't change the encoding. Suggestions?? THANKS!!!

Asked by RobertL39 17 hours ago

Answered by cor-el 6 hours ago

  • Solved

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (read more)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

Asked by mt3ch 3 months ago

Answered by cor-el 3 months ago

  • Solved

FTP link wants to open in other app

Hi! I found a strange thing today. I wanted to open an ftp link and firefox asked me in which app I wanted to open it. Of course I wanted to open it in Firefox, but the o… (read more)

Hi! I found a strange thing today. I wanted to open an ftp link and firefox asked me in which app I wanted to open it. Of course I wanted to open it in Firefox, but the only app on list was Internet Explorer. So, I added Firefox to the list, but I couldn't open the link with it, because when I marked Firefox and tried to click "open", nothing happend and the box still appeared. So, I ended up using IE. I'm using Firefox Nightly (81.0a1 atm of encountering this).

Asked by Qbsoon 15 hours ago

Answered by cor-el 7 hours ago

  • Solved

Yahoo Mail not working properly after downloading the latest Firefox browser.

I have downloaded the latest browser today. I can access my Yahoo Mail, but I cannot delete or send any mail from it when using this browser. My Yahoo Mail is now useless… (read more)

I have downloaded the latest browser today. I can access my Yahoo Mail, but I cannot delete or send any mail from it when using this browser. My Yahoo Mail is now useless when using Firefox. Please advise me of the solution to the problem as soon as you can.

Asked by barr_italia 5 months ago

Answered by Andrew 5 months ago

  • Solved

Error code 36 when I try to reinstall Firefox after it crashed following update 1 hour earlier

On my MacBook pro running macOS Catalina 10.15.7 (most recent version) Firefox crashed after an update around one hour ago. I've uninstalled Firefox in the end and downlo… (read more)

On my MacBook pro running macOS Catalina 10.15.7 (most recent version) Firefox crashed after an update around one hour ago. I've uninstalled Firefox in the end and downloaded a new one from the site. I get 'error code - 36' over and over, see attached screen shot. I've downloaded Firefox on various different browsers, bat always this same error code. Always enjoyed Firefox without any hiccup up to now! Suggestions anyone? Thanks. Chris

Asked by chrismiddeldorp 9 hours ago

Answered by chrismiddeldorp 9 hours ago

  • Solved

Can't seem to recover my session

Hi, I always have dozens of tabs opened, if not hundreds. They have vanished. I’ve been trying to follow the topics on the matter, such as the one named ‘Session won't lo… (read more)

Hi,

I always have dozens of tabs opened, if not hundreds. They have vanished. I’ve been trying to follow the topics on the matter, such as the one named ‘Session won't load’ (questions/1254740), to no avail.

Finally, this time I remembered not to close Firefox when I saw my tabs where suddenly missing. I’ve never seen the ‘Restore the previous session’ on the Firefox menu, and neither did I this time. Without closing the browser, I did a backup of the ‘sessionstore-backups’ folder. It contains:

‘previous.jsonlz4’, from 22/11/2020 17:42 ‘recovery.baklz4’, from 22/11/2020 18:57 ‘recovery.jsonlz4’ from 22/11/2020 18:58 ‘upgrade.jsonlz4-20201027185343’ from 31/10/2020 13:42 ‘upgrade.jsonlz4-20201108180448’ from 10/11/2020 15:05 ‘upgrade.jsonlz4-20201112153044’ from 22/11/2020 10:34

The one I need is ‘previous.jsonlz4’, since by 18:57 I’ve already lost my tabs. From the update backups I think I could also use the one from 22/11. In any case, I don’t understand what I am doing wrong so as to recover the ‘previous.jsonlz4’. This is what I’ve tried from different threads on my profile folder:

The ‘-backup’ and ‘OLD’ changes belong to different attempts

- Rename (on ‘sessionstore-backups’ folder) ‘recovery.jsonlz4’ and ‘recovery.baklz4’ to ‘recovery-backup.jsonlz4’ and ‘recovery-backup.baklz4’, and also tried with ‘recoveryOLD.jsonlz4’ and ‘recoveryOLD.baklz4’ - Rename ‘sessionstore-backups’ folder to ‘sessionstore-backupsOLD’ - Rename (on the main profile folder) ‘sessionstore.jsonlz4’ file to‘sessionstore-backup.jsonlz4’, and also tried with ‘sessionstoreOLD.jsonlz4’ - Copy/paste the ‘previous.jsonlz4’ file into the main profile folder. - Rename ‘previous.jsonlz4’ to ‘sessionstore.jsonlz4’

Nothing has worked. Once followed the steps, Firefox keeps opening my startup page. Note that it does not restore my previous session (that is, some tabs regarding this same subject), but my startup page, which means my attempts are having some effect, although not the desired one. I do have the ‘Restore previous session’ checkmarked in ‘Setting/General/Startup.

I also tried to replace ‘recovery.baklz4’ (on ‘sessionstore-backups’ folder) with ‘previous.jsonlz4’, from 22/11/2020 17:42, hoping to be prompted with the ‘Well, this is embarrassing’ + ’Restore’ window. I had no success.

I’ve been trying to recover my tabs for hour by now and don’t find what I am doing wrong. Why does Firefox refuse to load my ‘previous.jsonlz4’ file? Am I missing something? Maybe ‘previous.jsonlz4’ is corrupted or something? Should I try to use the ‘upgrade.jsonlz4-20201112153044’ from 22/11/2020 10:34 file? (Although I would lose some information)

Some people talk about a ‘History > Restore Previous Session’. I cannot find anything similar.

Thank you very much

Asked by delfion.815 1 day ago

Answered by jscher2000 1 day ago

  • Solved

Site blocked because "not secure"... How to force/bypass this beeep feature ?

Hello, Firefox is blocking some website because it says it's not secure (see picture). I don't give a .... So I want to access the website anyways. However, there is NO w… (read more)

Hello,

Firefox is blocking some website because it says it's not secure (see picture). I don't give a .... So I want to access the website anyways. However, there is NO way to do that, NONE. I've searched everywhere. So I can only rely on you guys. How can I force the connection or bypass the F security, or get rid of it, or something... anything.

Here is a historic of my tests : My issue is simple. 2 days ago I could surf on some website completely fine. Then all of a sudden half my website get SO CALLED "The connection has timed out".

- Test server : So I go on the usual website-server-is-down to test if the server is down. The website itself is perfectly fine according to 5 testing website. - Test server 2 : Then I go through a "browser inside browser" website to test it again (dunno how it's called). I can access the main page then navigate fine on all test-browser. The website is therefore fine. - "Not secure" : Despite the viciously misleading message saying "connection timed out" that makes you believe the website is down and gone, it is actually fine, as proven above. It's just for some god unknown reason Firefox decided to block it, without telling you it's actually blocking it (nice move!). - No button : I searched but could not find a way to either force the connection or create security exception. I tried disabling all security in "privacy" tab in the option, no deal. - Certificate : I also went to try and add the website as an exception in the certificate list, but Firefox pretends it cannot connect to the website, therefore you cannot add the certificate. - Security.enterprise : I have removed the access from Avast to Firefox allowing me to unlock security.enterprise_roots.enabled. Once I had it unlocked, I tried either True or False, but no deal (including reboots comp & browser) - I spent 4 hours searching solutions on the web, but couldn't fin any. Is Firefox actively preventing me for surfing the web as I like... ?

In the end, I still cannot access this website. And I wanna say to Mozilla : It's my own liberty if I want to go and shoot myself in the foot by visiting a so-called "unsecured website". I should be able to do so if I want to...

Anyway, if any gosu out there has the skill, please help ? ^^; Thanks

Asked by cyborga41 1 day ago

Answered by jscher2000 1 day ago

  • Solved

'An unexpected error has occurred' when trying to access one site only

Hi Since yesterday morning I can't log into my energy provider, having entered Username and Password, I get 'An unexpected error has occurred' in the centre of the scree… (read more)

Hi Since yesterday morning I can't log into my energy provider, having entered Username and Password, I get 'An unexpected error has occurred' in the centre of the screen. I can access the site using a different account on the same DT, also from FF on my phone. I've deleted cache and all history several times, to no avail - which is a pain, setting it up again. Clearly something has changed, Any pointers please? Thanks.

Asked by comms 16 hours ago

Answered by comms 14 hours ago

  • Solved

Autoplay not always blocked

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing. This worked in 77. Some … (read more)

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing.

This worked in 77. Some about:config entries I'd swear were set in 77 have vanished; I tried adding them manually, but the autoplay blocking is still hit and miss.

Also, not sure if Troubleshooting Information uploaded successfully or the page broke (see screenshot).

Asked by Jens Lyn IV 4 months ago

Answered by Jens Lyn IV 4 months ago

  • Solved

Saved password cleared after reset account password

Hi, my latop was stolen and today I start configuring a new one. After install Firefox on Lubuntu Linux , I performed the flow to reset password , I got the mail, I chose… (read more)

Hi, my latop was stolen and today I start configuring a new one. After install Firefox on Lubuntu Linux , I performed the flow to reset password , I got the mail, I chosen a new password, however the saved password section are empty .. I think I had thousands, I waited some minutes , also clicked several times on button "Sync Now" with no success . Is there a way to recover them? Any help will be useful , thanks

- Walter

Asked by wnasich 19 hours ago

Answered by FredMcD 19 hours ago

  • Solved

Question: How-To put add-on's on toolbar in Firefox Portable

I have installed 2 of the most popular add-on's (in the world) both NoScript and uBlock Origin in my firefox portable browser and I cannot find a way to add the addon ico… (read more)

I have installed 2 of the most popular add-on's (in the world) both NoScript and uBlock Origin in my firefox portable browser and I cannot find a way to add the addon icon's to my toolbar for browsing to both ensure they are functioning as they should and also to turn them off or adjust settings when needed. I have version 83 of the portable firefox browser installed.

Asked by Darren 20 hours ago

Answered by Darren 19 hours ago

  • Solved

Remove Sponsored Link From Address Bar History

Is there a way to remove the sponsored link from the address bar drop down? Yesterday a link from a company that is run by terrorists showed up in the list. Shift+Del d… (read more)

Is there a way to remove the sponsored link from the address bar drop down? Yesterday a link from a company that is run by terrorists showed up in the list. Shift+Del does not remove it. I understand Mozilla needs to get money somehow, but this is offensive. The link is for Ebay and it has the word sponsored next to it. Since the address bar drop down disappears when I hit any key, it is impossible to screenshot.

Asked by jake-firefox 2 days ago

Answered by cor-el 2 days ago

  • Solved

Address bar text alignment changed to right aligned on Mac

I have the same issue as this https://support.mozilla.org/en-US/questions/1229895 but on Mac. I tried pressing Shift+Cmd+X but it doesn't work. Any idea what the keyboard… (read more)

I have the same issue as this https://support.mozilla.org/en-US/questions/1229895 but on Mac.

I tried pressing Shift+Cmd+X but it doesn't work. Any idea what the keyboard shortcut in Mac is?

Asked by anatolzak 1 day ago

Answered by cor-el 1 day ago

  • Solved

Newegg.com always goes to UK site?

I am running a WIN10 Pro 20H2 PC with Firefox 83.0. All software up-to-date. My Internet connect is cable with a U.S. IP location. All O.K, until I open "https://www.ne… (read more)

I am running a WIN10 Pro 20H2 PC with Firefox 83.0. All software up-to-date. My Internet connect is cable with a U.S. IP location.

All O.K, until I open "https://www.newegg.com/" with my default Firefox browser, which always opens "https://www.newegg.com/global/uk-en/".

Opening the same "https://www.newegg.com/" URL from the same password manager entry explicitly using Chrome or Edge I get to the desired U.S. location.

Does not occur on my other PCs.

Firefox is changing the URL so that I am always going to the UK location?

Can't find where this is happening. Can anyone assist?

Asked by rbdmg75 1 day ago

Answered by cor-el 1 day ago

  • Solved

Firefox Randomly Causes Wrong Characters to Type In

I have been avidly using Firefox for 10+ years. However, I notice a trend that if I have several Firefox tabs open for quite a while, it starts typing in some wrong chara… (read more)

I have been avidly using Firefox for 10+ years. However, I notice a trend that if I have several Firefox tabs open for quite a while, it starts typing in some wrong characters.

A list of character errors it makes is: é appears when typing slash beside shift on the right side. è appears when typing the apostrophe symbol beside enter. à appears when typing slash above enter ç appear when typing the right square bracket ^^ appears when typing the left square bracket (does not type anything 1st try, then enters that the 2nd try. Or if pressing it once, then backspace, it enters ^) / appears when typing key to the left of 1 at the top. É appears when typing a question mark. @ is working right now, although it usually does not work when this occurs.

Restarting the computer fixes it every time. This EXCLUSIVELY occurs times I have at least a few Firefox tabs open. I first came across this in Windows 7. In Windows 7, it made those character errors in Firefox but entered the correct characters when typed in apps like Word and Excel. It only occurred around once per month, I got by it by typing characters in Word then pasting them in Firefox until I got a chance to reboot. They pasted fine, just typing them gave the character errors.

With Windows 10 though, it is more than 10 times worse. I get these errors nearly every day. And in Windows 10, once the incorrect characters start getting typed in Firefox they also type that way in apps like Word too.

In msconfig.exe, I disabled all non-Microsoft services and disabled everything in the startup list, but it continues doing this.

Anyone have suggestions what to do? I honestly think the most likely explanation for this is Google bribing Microsoft to make it like this to drive people away from Firefox to use Chrome. That way Google can micromonitor us that much better.

Asked by crossr74 1 day ago

Answered by cor-el 1 day ago

  • Solved

Minimize and Restore Icons Missing

I am trying to minimize Firefox, but the minimize icon in the upper right-hand corner is missing. I am still able to close Firefox using the 'X' in the upper right corne… (read more)

I am trying to minimize Firefox, but the minimize icon in the upper right-hand corner is missing. I am still able to close Firefox using the 'X' in the upper right corner of the window, but I am unable to minimize or restore. All other applications still have these icons available.

Asked by sabo11236 1 month ago

Answered by cor-el 1 month ago