Showing questions tagged: Show all questions
  • Solved

2 factor authentication

Unless I'm totally blind, there is no Two-step authentication option on the security panel. What is going on? I can't use sync without activating 2FA. If there is really … (read more)

Unless I'm totally blind, there is no Two-step authentication option on the security panel. What is going on? I can't use sync without activating 2FA. If there is really no way to sync other than a non-existent 2FA, I'm going back to Chrome.

Asked by Maureen 2 weeks ago

Answered by TyDraniu 2 weeks ago

How can I permanently force firefox's automatic updates to be turned off?

How can I permanently force firefox's automatic updates to be turned off? Which guy modified the original design for the new version of Firefox bookmarks? Is there someth… (read more)

How can I permanently force firefox's automatic updates to be turned off? Which guy modified the original design for the new version of Firefox bookmarks? Is there something wrong with that man's brain? Is the spacing of the new bookmark item too large to read? It's very uncomfortable.

Asked by gem_536 3 months ago

Last reply by EF80 1 week ago

  • Solved

Losing login status when closing Firefox Browser despite excepting web sites

Still trying to figure out what is wrong after refresh of Firefox. I cannot get my handful of preferred websites to remain logged in when closing and reopening Firefox. I… (read more)

Still trying to figure out what is wrong after refresh of Firefox.

I cannot get my handful of preferred websites to remain logged in when closing and reopening Firefox.

I have FF set to clear cookies and data on closing, but this handful of sites are listed as exceptions.

After reopen FF, the relevant cookies are not sticking. This used to work better.

I redownloaded FF and no improvement.

I'm thinking conflicting settings or....?

FF beta for Mac OS, 93.0b3.

Asked by Foxfree99 2 weeks ago

Answered by cor-el 2 weeks ago

  • Solved

Can no longer manage cookies to save logged in status?

I remember from past rodeos that I need to know the precise name of the cookies. But now when I check which cookies are added when I login, I can only see them grouped b… (read more)

I remember from past rodeos that I need to know the precise name of the cookies. But now when I check which cookies are added when I login, I can only see them grouped by the main website title--nytimes.com and I see that they have added 7 cookies. But I cannot see individual cookies.

How can I see the cookies to copy their addresses for the 'exceptions' table for data management to allow the right ones to be retained; OR just tell FF to allow my 3 preferred sites to stay 'always' logged in when I reopen FF?

FF beta 93.0b3 Mac OS 10.14.6

Asked by Foxfree99 2 weeks ago

Answered by Foxfree99 2 weeks ago

Firefox 92 causes cross domain authentication errors

I currently run several environments for Dynamics 365 products. Our clients can choose to use our authentication (ADFS 4.0) or we set up a SSO option for them (normally … (read more)

I currently run several environments for Dynamics 365 products. Our clients can choose to use our authentication (ADFS 4.0) or we set up a SSO option for them (normally also ADFS of some flavor). The piece that is similar between both is that the domain they authenticate to would not be the same as the application they are necessarily using. For example my clients have a mixture of on premise and cloud deployments but if they are SSO only pull their tokens from one domain.

Anyways the real TLDR as I can determine is as follows:

Has anyone seen a problem with firefox 92 stripping out headers? My scenario is I have an AD FS server that I use for single sign on with a domain name that is different from the application that it federated with. When I attempt to login using Firefox, the traffic flows as: 1. Hit the app url and get 302 redirected to the IDP 2. enter credentials at the IDP and get redirected to the app url 3. the app has an internal and external claims URL, so the internal claims url 302 redirects me to the external url 4. FF brings up the external url, but does NOT pass the MSISAuth and MSISAuth1 cookies from the IDP 5. The app thinks I've not authenticated, so it 302 redirects me back to the IDP 6. The IDP sees the MSISAuth and MSISAuth1 cookies, so it knows it authenticated me and it 302 redirects me back to the app wash, rinse, repeat for 5 times until AD FS realizes that I've done this 5 times, then it throws an error at me to stop the loop. This was working fine in FF 91 and it currently works in Chrome and Edge. The expected flow is almost the same, except that the app get's the cookies presented to it from AD FS. I was thinking this was something to do with Enhanced Tracking Protection. When I selected Custom and unchecked all the options (I think this disables ETP) I still get the cookies stripped from the header. I re-enabled ETP with standard protections and manually added the URLs using the steps outlined at https://bugzilla.mozilla.org/show_bug.cgi?id=1432644#c27. Is this a bug where FF doesn't honor the settings to disable ETP in V92? The reason I was thinking that ETP was to blame is the IDP has a domain of IDP.example and the app has the URL's of internalclaim.app and externalclaim.app.

I feel like I am missing something obviously here but I can't find it. If I create a CRM deployment using the same domain as our ADFS servers it works fine. If I use what our public designation is, it fails. SSO obviously fails. It only started after upgrading to 92 and that is consistent amount all of our clients. I have tried to go through every advance config that was touched with the 92 upgrade and nothing there seems to help. We compared our UAS to a friend of ours who is not having issues since the 92 release and they look the same. If this was a system 92 problem I would expect the internet to be exploding by now but it is not. It makes me think there is something I am missing in our fundamental set up but for the life of me I can't identify a missing update, compatibility issue, known issue blah blah blah. Edge, Chrome, Safari they all still work fine. It is just the Firefox 92 update that all of a sudden killed our authentication.

Asked by christopher.butler.02 2 weeks ago

FFox v92 - Menu Spacing - Bug? (No, not the usual question)

FFox 92 update today. Menu spacing went to double. No shock there. Found the CSS code below for UserChrome.css and set it up. EX. menupopup > menuitem, menupopup >… (read more)

FFox 92 update today. Menu spacing went to double. No shock there. Found the CSS code below for UserChrome.css and set it up.

EX. menupopup > menuitem, menupopup > menu {

 padding-block: 4px !important;

}

root {
 --arrowpanel -menuitem -padding: 4px 8px !important;

}

Here's the issue: I want it tighter than 4px. So, I set it down to 2px... eventually dropping it to all 0px settings.

EX: menupopup > menuitem, menupopup > menu {

 padding-block: 0px !important;

}

root {
 --arrowpanel -menuitem -padding: 0px 0px !important;

}

But, it doesn't get any smaller than the above 4/8px set up. Bug? Perhaps there's another CSS setting to be tweaked for V 92? I do not have any other CSS for these items elsewhere in my UserChrome file.

Asked by MozzieBob 2 weeks ago

Last reply by cor-el 2 weeks ago

Dark Theme

Dark Mode used to work beautifully in Firefox. Today it stopped working. I can choose Dark Mode in the settings page, and the settings page itself then uses Dark Mode. Bu… (read more)

Dark Mode used to work beautifully in Firefox. Today it stopped working. I can choose Dark Mode in the settings page, and the settings page itself then uses Dark Mode. But Dark Mode does not work in any of the other pages, only the settings page. I think it must be a flaw in an update that was installed automatically today. (September 7, 2021)

Is there a way to uninstall this update and go back to the previous version. Dark Mode used to work beautifully and Firefox was my favorite browser. Can someone help? Thanks.

Asked by cmrus777 2 weeks ago

Last reply by thegrubernator 2 weeks ago

Passwords

I recently changed my browser from chrome to fire fox but all my passwords are saved on chrome. I tried to import them on firefox but nothing gets imported from chrome. T… (read more)

I recently changed my browser from chrome to fire fox but all my passwords are saved on chrome. I tried to import them on firefox but nothing gets imported from chrome. There is no autofill option for passwords here. I clicked on the three dots and did everything it said on the website but still the error message keeps popping up saying " An error occurred while trying to save this password". I tried going in the Passwords option and doing it manually but then the error message comes every time. Im using Firefox on my laptop.

Asked by imsinghshambhavi 2 weeks ago

Last reply by Techfreaks 2 weeks ago

Black background via Windows 10's "High Contrast Theme" ignored

Firefox just updated a few minutes ago, and since the update my background in every website I visit is white. Previously my backgrounds were all black due to my Windows 1… (read more)

Firefox just updated a few minutes ago, and since the update my background in every website I visit is white. Previously my backgrounds were all black due to my Windows 10 "High Contrast Theme" being activated. Well since the update it seems Firefox "ignores" the Windows Theme settings and overrides them with its own. As far as I can tell, there is no way to make websites display with a black background like they did before the update. I hope this gets fixed.

Asked by rgp384 2 weeks ago

Last reply by cor-el 2 weeks ago

Menus

My menu items are now (9/7/2021) White and double-spaced. Why does FireFox change things that don't need changing with no path back. First, they changed menu color to def… (read more)

My menu items are now (9/7/2021) White and double-spaced. Why does FireFox change things that don't need changing with no path back. First, they changed menu color to default to another (I think same as Toolbar color) with no recourse. Now the menus are white and double spaced (today! out of the blue sky!!). FireFox, at LEAST make these features configurable. Why do you do this?

Asked by r.j.dill 2 weeks ago

Last reply by jscher2000 2 weeks ago

e-mail

I have Wind 7, after logging in I get my home page (Century Link) when I clk on e-mail it reverts back to my home page. What is wrong or am I doing something wrong?? Thi… (read more)

I have Wind 7, after logging in I get my home page (Century Link) when I clk on e-mail it reverts back to my home page. What is wrong or am I doing something wrong?? This is new, never happened B-4, Tks Bill

Asked by billreal1 2 weeks ago

Last reply by FredMcD 2 weeks ago

How do I get Spell Checker back, for Outlook and gmail ?

It seems Microsoft and google has changed outlook and gmail HTML for the message text body DIV to specify spellcheck="false". div dir="ltr" class="[]" role="textbox" … (read more)

It seems Microsoft and google has changed outlook and gmail HTML for the message text body DIV to specify spellcheck="false".

   div dir="ltr" class="[]" role="textbox" aria-multiline="true" aria-label="Message body" spellcheck="false" contenteditable="true"

Any idea how yo solved this ?

Asked by Ichigo 2 weeks ago

Last reply by jscher2000 2 weeks ago

Gmail chat messages do not open

Hello! I understand that Google just updated Gmail's chat feature, and I wanted to report that I'm having issues opening chats in Gmail's new UI. Whenever I click on a na… (read more)

Hello! I understand that Google just updated Gmail's chat feature, and I wanted to report that I'm having issues opening chats in Gmail's new UI. Whenever I click on a name, the chat bubble does not open in Firefox, even when chats open in other browsers.

I've been able to replicate this issue in Troubleshoot mode, so I don't believe the problem is with any of my add-ons.

Any advice/is this a known issue?

Asked by mcannizzaro1 2 weeks ago

Last reply by mcannizzaro1 2 weeks ago

Firefox times out when connecting to a site with URL redirection unless HTTPS protocol is explicitly typed

I am running Firefox Developer Edition 92.0b9 on macOS Monterey 12.0 Beta 6 (21A5506j). I noticed lately that I couldn't open some sites, either when I tried to follow a … (read more)

I am running Firefox Developer Edition 92.0b9 on macOS Monterey 12.0 Beta 6 (21A5506j).

I noticed lately that I couldn't open some sites, either when I tried to follow a link or typed the URL in the address bar. After a few trials and errors, I think I have identified a pattern but no idea of what the root cause is:

  • the sites I am trying to access all redirect to a different URL;
  • I can open the sites just fine if I explicitly type `https://` in the address bar.

A few of the sites I am struggling with:

I noticed that I could open the above URLs just fine in a Private window, so tried the following to no avail:

  • Clear cache;
  • Restart Firefox in Troubleshooting Mode (still on as I am writing this);
  • Install Firefox Beta side-by-side;
  • Completely uninstall Firefox and remove the existing profile, before doing a fresh install.

None of the above solutions work and I am a bit stumped. Safari, Chrome and Brave all work fine.

Asked by damianoferrari 3 weeks ago

Last reply by cor-el 3 weeks ago

Add-ons

When some websites use DRM Software's I must Disable my extensions to play the video. How can I disable the add-ons to the specific website? And if it cannot be done how… (read more)

When some websites use DRM Software's I must Disable my extensions to play the video. How can I disable the add-ons to the specific website? And if it cannot be done how can I disable all my extensions at once. Without un-ticking one by one?

Because every time I visit the website with DRM I must Go one by one to disable my add-ons.

Asked by අකිඳු කල්හාන් 3 weeks ago

Last reply by FredMcD 3 weeks ago

  • Solved

Firefox Bookmark Tags limited to 10 entries

Hello, I love the tagging bookmarks feature in Firefox. But unfortunately it does not work properly like explained in the help docs. I search for tags by typing '[+] + [T… (read more)

Hello,

I love the tagging bookmarks feature in Firefox. But unfortunately it does not work properly like explained in the help docs.

I search for tags by typing '[+] + [Tag]'. This works for me but I only can search for 10 entries maximum.

Why there is this limitation to bookmark entries in my search bar? And how can I see all my tagged entries even when there are more than 10?

Kind regards Benni

Asked by bempemann 1 month ago

Answered by TyDraniu 1 month ago