Firefox insists on opening files from local temp dir, discarding URLs

My question is a blend of these two previous questions: https://support.mozilla.org/en-US/questions/1303566 https://support.mozilla.org/en-US/questions/1277388 I have a b… (read more)

My question is a blend of these two previous questions:

https://support.mozilla.org/en-US/questions/1303566 https://support.mozilla.org/en-US/questions/1277388

I have a bunch of open tabs which used to simply contain pdf documents, opened in the Firefor pdf viewer, with the file URL in the address bar rather than a local temp dir address. This behaviour however changed with a recent update (I'm on 82.0b5), and now when I reload those old tabs, I get prompted for a download, and a new tab is opened following the download with a local temp dir replacing the URL. As all these files previously opened just fine in the FF preview with the URL present, this is unlikely to be related to whether the server sends files as "application/pdf" or otherwise, as the same files have changed behaviour, and it is unlikely that a bunch of servers changed the way they send files at the same time.

Further, the answer to the second question above proposed to select "Preview in Firefox" to get around this, however this option doesn't seem to exist anymore.

Is this a known behaviour change in FF82? If so, is there a way to get the old behaviour back?

Asked by Nils 16 hours ago

Last reply by Nils 11 minutes ago

Firefox in China.

Ladies & Gentlemen! What about Firefox in China? When I'm in China or when I want to install Firefox on my Chinese Huawei Smartphone, I'm always getting something dif… (read more)

Ladies & Gentlemen! What about Firefox in China? When I'm in China or when I want to install Firefox on my Chinese Huawei Smartphone, I'm always getting something different.

I did write this to you some weeks agou, without receiving any answer. (See copy below.)

Regards, K. Schröer



Weitergeleitete Nachricht --------

Betreff: Firefox highjacked in China? On Apple-App-Store? Datum: Mon, 7 Sep 2020 19:30:06 +0800 Von: Dr. K. Schröer <k.schroer@t-online.de> An: Mozilla <Mozilla@e.mozilla.org>


Ladies and Gentlemen!

On my iPhone XR Apple App-Store made an update of Firefox to 28.1 some days ago. (I'm currently in China.)

Afterwards, there was another (Chinese) browser opening under the Firefox App-Logo. I deleted everything immediately (hoping that the Chinese invader didn't have access to my passwords stored with Firefox).

Regards, K. Schröer

--

Dr. Klaus Schröer Privat - Deutschland: Mobil-D: 0171 77 64 291 Am Havelufer 15 Skype: +49 30 89 39 64 42 14089 Berlin e-mail: k.schroer@t-online.de

                                       Fax:     +49 322 237 626 35

Privat - China: Abritz Hotel Mobil: +86 175 1910 0448 NO. 888 Guigu Street Mobil: +86 137 0819 8410 nur CN 130012 Changchun

Asked by schroer-berlin 49 minutes ago

Close synced tabs on one device from another device

I've a lots of tabs sync'ed to desktop version which were originally opened on android device. Now when I'm done going through the article (from desktop), I want to close… (read more)

I've a lots of tabs sync'ed to desktop version which were originally opened on android device. Now when I'm done going through the article (from desktop), I want to close the tab from android too and remove it from sync'ed tabs too. Is this possible?

Asked by magdum_nikhil 53 minutes ago

Random tabs never load ("rotten" FF sub-processes?)

First I need to point out I'm very difficult user for FF :) Right now I have 52 windows and 476 tabs open This not a hardware problem as I have good CPU (Ryzen 5 3600) an… (read more)

First I need to point out I'm very difficult user for FF :) Right now I have 52 windows and 476 tabs open

This not a hardware problem as I have good CPU (Ryzen 5 3600) and 64 gigs of memory - running FF 80.0.1 x64 on Windows 10 19041 x64

Until recently everything was fine - I'm not able to tell when that changed but it's just few days

When I start FF, some tabs (from "restore" session) never load. Tab just shows its loading but never finishes. Moreover if I try to open new tabs, they RANDOMLY also never load - doesn't matter which site/page (in other browser same url opens instantly). I need to open X new tabs, paste URL and hit enter into each and after a while the Xth tab loads instantly. X is changing - with freshly started browser its something like 2-4 new tabs. Later it can be 10 or more until "I find" the tab which loads. When I do that, i can open Dev Tools before pasting URL - Networking tab shows no requests, nothing. Same with right-clicking links in working tabs (open link in new tab).

Working tabs are usually good - left clicking links or F5 works fine. But if the tab is left open for some time without activity, it can also stop working (F5 doesn't help)

What i tried: - disable my Firewall (Kaspersky) - restart FF in safe mode without plugins - no "clear cache and cookies" as its not related to any specific site or page

I got the idea recently that maybe there is some problem with FF processes "rotting" (multi process architecture) so I'v tried to kill some of the sub-processes in Task Manager. Of course its hard to find the right one but I'v managed multiple times to hit the right process and suddenly all "loading forever" tabs showed as "crashed" and when I hit "Restart all crashed", all loaded instantly

Any help appriciated! Thanks!

Asked by michal.liwoj 1 week ago

Last reply by michal.liwoj 23 hours ago

Video Tearing in Netflix after Firefox 81 Update

After the Firefox 81 Update on Pop OS 20.04, I have been experiencing video tearing in Netflix when using integrated graphics mode. The problem goes away when switching t… (read more)

After the Firefox 81 Update on Pop OS 20.04, I have been experiencing video tearing in Netflix when using integrated graphics mode. The problem goes away when switching to NVIDIA Graphics. This was not a problem in Firefox 80.0.1.

I am also not the only one having this issue: https://askubuntu.com/questions/1278653/video-tearing-in-firefox-81-0-popos-20-04

The data I am sharing is from being in Nvidia Graphics Mode. I can switch back to Integrated Graphics Mode and share the firefox data from there if need be.

Asked by Adam 23 hours ago

Last reply by Adam 1 hour ago

I want to switch my Primary Brouser to be Firefox!

So, My 1st. Goal is to make firefox My Primary internet Brouser, ok.? Also ; I want my old I-pad to use Firefox through a thither to my Samsung20 cell phone --- to … (read more)

So, My 1st. Goal is to make firefox My Primary internet Brouser, ok.? Also ; I want my old I-pad to use Firefox through a thither to my Samsung20 cell phone --- to Reach & sync as it's internet Brouser through Firefòx ! ! Thank You , Community ! It does take a Village ; Or, Nice Happy People like You ! !

Asked by chaz.burtonbro 5 hours ago

DRM pop-up window apears on screen incessantly.

The banner pop-up on the top of the screen that continuously nags me to turn on DRM on news web pages is very irritating. I do not approve of DRM and do not want it on m… (read more)

The banner pop-up on the top of the screen that continuously nags me to turn on DRM on news web pages is very irritating. I do not approve of DRM and do not want it on my browser. I have been unable to stop this banner and the irritation is now reaching a point where I am considering moving to another browser. There are plenty of non-Google and non-Microsoft ones available now.

Please advise me how I can eliminate this DRM banner.

Asked by twb999 5 hours ago

Can't find saved credit card information

I allowed my credit cards to sync and I now have no option to view them. I had it set so it needed to have my Windows password before it opened them. I attempted to unsy… (read more)

I allowed my credit cards to sync and I now have no option to view them. I had it set so it needed to have my Windows password before it opened them. I attempted to unsync them and look again, but there is still no option. I had all of my current plugins before this problem occurred. I also had my Anti-Virus before this problem occurred.

Asked by cleverguy16 17 hours ago

Last reply by cleverguy16 6 hours ago

is it possible installing firefox browser on my old ubuntu 13.04 running with armhf?

Hello! I have an old PC; dynabook AZ/M05. I have already changed OS from android to ubuntu 13.04. As long as I searched, the latest version available with the PC are ubu… (read more)

Hello!

I have an old PC; dynabook AZ/M05.

I have already changed OS from android to ubuntu 13.04. As long as I searched, the latest version available with the PC are ubuntu 13.04 and 13.10. The former version has chromium browser installed but the later does firefox. Though I could install both version, wifi does not work well with the later version; 13.10. (I tried many but unable to make the wifi work well")

Due to some obsolete OS reason, chromium failed to connect to internet with an error message : "err_ssl_version_or_cipher_mismatch".
Although I want to try to use firefox on the ubuntu 13.04, I can not find out available firefox for the CPU: armhf.

can anyone help me?

Tomi from J@p@n

Asked by tomi2 7 hours ago

MS Access 2016 files won't open from a link in Firefox

In last couple of the most recent versions of both Firefox and Firefox Enterprise, Access files with ACCDB extensions will not open from a link on an html page. Basicall… (read more)

In last couple of the most recent versions of both Firefox and Firefox Enterprise, Access files with ACCDB extensions will not open from a link on an html page. Basically, it will show an error in firefox. It can be saved to the local desktop if we set the option to do so, but we would like to be able to open it only. The file is on a network. We've also tried opening the file in several other browsers (chrome, edge, etc.) and get the same results in all of them except IE. That remains the only browser we can open an Access file in with a link. Microsoft Word and Excel files appear to still be opening fine.

Asked by green_sage 9 hours ago

Last reply by green_sage 8 hours ago

making firefox my default browser

make firefox my default browser. I did what advice said and uninstalled and then reinstalled firefox to override Edge but now all my bookmarks I created BEFORE uninstalli… (read more)

make firefox my default browser. I did what advice said and uninstalled and then reinstalled firefox to override Edge but now all my bookmarks I created BEFORE uninstalling have disappeared'

Asked by chrisandian 14 hours ago

Last reply by chrisandian 8 hours ago

Control of print margins

When I try to print a document, including from your frequent questions site, the right and left margins are equal to 1 3/4 inches even though on the web site the margins … (read more)

When I try to print a document, including from your frequent questions site, the right and left margins are equal to 1 3/4 inches even though on the web site the margins are set at .5 inches. I have tinkered with all the available options but no matter what I do the result is 1 3/4 inch right and left margins.

This also happens when I try to print a document from Vanguard's message center.

How do I resolve this matter

John V.

Asked by johnand.margie 10 hours ago

Receipt printer slow after update

We use Lightspeed POS for our retail location. Firefox updated this morning and now my receipt printer is so slow its useless. I've tried resetting Firefox, uninstall and… (read more)

We use Lightspeed POS for our retail location. Firefox updated this morning and now my receipt printer is so slow its useless. I've tried resetting Firefox, uninstall and reinstall printer, adjusting settings and nothing works. It's a Star TSP 100iii. Works just fine on Chrome and Edge.

Asked by ron87 12 hours ago

Firefox Rt Click / Send To Device is Not Working

When sending a page to my devices, (RtClk/Send to device) it does not work. I do not receive the page on the device chosen. I get the blue check confirmation at the top … (read more)

When sending a page to my devices, (RtClk/Send to device) it does not work. I do not receive the page on the device chosen. I get the blue check confirmation at the top saying it was sent but do not receive anything on the device chosen. I have tried this on several devices. Anyone know how to fix this?

Asked by jmillerah 12 hours ago

Top Sites

I used to like Top Sites - but now when I wish to REMOVE a site from a box, whether by "dismiss" or "remove from history", it doesn't remove it - it either puts it in ANO… (read more)

I used to like Top Sites - but now when I wish to REMOVE a site from a box, whether by "dismiss" or "remove from history", it doesn't remove it - it either puts it in ANOTHER box, replacing the site that WAS in that box, and/or replaces it with another site I have NOT designated as a Top Site - I have 4 rows already, do not desire any more - but now I can make NO new empty boxes for something I want, and have a bunch of boxes with sites I do NOT want.

 This might be amusing as a Whack-a-Mole game - but I stopped laughing some time ago ...

Asked by s1p0h2 15 hours ago

Streaming from Soundcloud through Wix site fails

I have a Wix website. On one page I stream a podcast that I host on Soundcloud. It used to work fine in Firefox. I haven't changed anything, but now I get an error mes… (read more)

I have a Wix website. On one page I stream a podcast that I host on Soundcloud. It used to work fine in Firefox. I haven't changed anything, but now I get an error message "Couldn't play media file" using Firefox on my PC. Streaming the podcast works fine on my iPad using Safari, and on the same PC using Edge. Seems to be a Firefox issue. My Firefox dashboard says the browser is up to date.

Any suggestions?

Thanks. Jeff

Asked by jefflowe56 17 hours ago

Dropdown List not working

Every droplist is much too short so it doesn't display all entries, it's on the upper side of the page and not below the droplist as expected. I've removed firefox and my… (read more)

Every droplist is much too short so it doesn't display all entries, it's on the upper side of the page and not below the droplist as expected. I've removed firefox and my profiles, all mozilla and firefox data, when i reinstall firefox it works for around 30-50 seconds as expected and after that time, when i refresh the page it looks broken again.

System: MacOSX Catalina. Firefox 81

Asked by gummipunkt 19 hours ago

Last reply by gummipunkt 17 hours ago