My website page layout is broken on Firefox only - and even good developers can't fix it

I truly hope somebody can give me some help. I am struggling to understand why my website page containers go nuts on Firefox. I tried so much, I payed a good developer w… (read more)

I truly hope somebody can give me some help. I am struggling to understand why my website page containers go nuts on Firefox. I tried so much, I payed a good developer who told me the issue was over, but it is still there. I'm trying everything but my project is being a failure due to very nasty WP Theme issues, like this one. I had to spend my time fixing the Theme and my project completely past its deadline. Maybe I'm going to be fired, without fox.

I clearly cannot add site credentials for anybody, but maybe some developer knows what could be of help.

It seems that the issue has something to do with page Container and Flex attribute. The website is a Wordpress site and the page is built with WPBakery Visual Editor. All updated, no customizations, pages should work easy... As you can see the page title is ok, but then inside the main page container, the Visual Editor rows (which have display = flex) behave as if they had no width. Despite that, changing the flex attribute to display = block targeting FF specifically through Css, it doesn't seem to work either. It's not something simple just as a Row option inside the Visual Editor.

Please see attachments. Many pages behave like that. My questions: - is there a possibility to speak with Firefox assistance and get a clue? - did any developer from community, experience something similar before? How did you manage to solve it? - Firefox, why are you behaving like that with an old supporter?

Thank you to anybody spending his time to help.

Asked by sviluppo5 7 minutes ago

More Problems Affecting Firefox

Another problem that's started with Firefox for Windows this wee. Firefox takes a long time to load pages, up to a minute. In the bottom right of the page it says "waitin… (read more)

Another problem that's started with Firefox for Windows this wee.

Firefox takes a long time to load pages, up to a minute. In the bottom right of the page it says "waiting of fonts.googleapis.com" or something like that.

The other problem of it not displaying graphs still hasn't been resolved.

Neither of these problems exist on Chrome.

Asked by JohnDoyle 45 minutes ago

Last reply by JohnDoyle 41 minutes ago

Content is getting cut while doing print from firefox while on all other browser it's working.

Content is getting cut while doing print from firefox while on all other browser it's working. attached imgaes for firefox and chrome, on chrom all content is getting sho… (read more)

Content is getting cut while doing print from firefox while on all other browser it's working.

attached imgaes for firefox and chrome, on chrom all content is getting shown.

Asked by bpawar 52 minutes ago

Can't access normally mewe.com

Hi I can access mewe.com with the last firefox, but only while browsing using the "private mode". All other websites are ok, only this one. When I enter the url "mewe.com… (read more)

Hi

I can access mewe.com with the last firefox, but only while browsing using the "private mode". All other websites are ok, only this one. When I enter the url "mewe.com", it switches to https://..... and then... nothing, no relad available, just a desperately empty page. Obviously, all other browsers don't have such problems.

Asked by Y-Phil 12 hours ago

Last reply by Y-Phil 1 hour ago

Firefox won't open links in duckduckgo

Hello everyone, I'm an avid user of Firefox latest on Manjaro, up to date. Since yesterday, when I updated from Firefox 87.0-1 to 87.0-2, I have a strange bug using Duckd… (read more)

Hello everyone,

I'm an avid user of Firefox latest on Manjaro, up to date.

Since yesterday, when I updated from Firefox 87.0-1 to 87.0-2, I have a strange bug using DuckduckGo.

What happens ?

  • When on DuckduckGo result page, clicking a link won't open when using the "Open in another tab" setting
  • I will open the link if that setting is not used
  • I can open it in a new tab with the right-click menu, or by ctrl-clicking it.
  • When hovering above a link, the bottom-left tooltip does show up and the cursor does become a hand, suggesting the link should work. Alas, it doesn't.

What did I try ?

  • I did restart in "safe mode", with all addons disabled.
  • I did reset the cache.
  • I tried testing the same behavior on Google, and it did work as expected.
  • I tried DDG in another browser (Gnome Web/Epiphany), and it worked as expected.

I have yet to notice the same issue with any other website. Any Idea where I should report this minor, but annoying but ?

Thanks & Cheers, -- JAB

Asked by Jacques-Alexandre Bossu 13 hours ago

Last reply by Jacques-Alexandre Bossu 1 hour ago

URL bar search shortcut for Russian Wikipedia fails after browser update

After a Firefox version upgrade, my URL bar search shortcut for Russian Wikipedia has begun to fail. Say, if i search for Диснейленд (Disneyland in English), wikipedia re… (read more)

After a Firefox version upgrade, my URL bar search shortcut for Russian Wikipedia has begun to fail. Say, if i search for Диснейленд (Disneyland in English), wikipedia reports that the page does not exist, showing the error message like in the attached screenshot. I've tried recreating the search shortcut, but to no avail, it still shows the error. How do i fix the situation?

Asked by robokopfer 2 days ago

Last reply by robokopfer 1 hour ago

about opening word files(*.doc)

When opening word files(*.doc) on the server with Firefox browser, it is very slow, but other browsers open word very quickly. Is this a bug in the design of the firebox … (read more)

When opening word files(*.doc) on the server with Firefox browser, it is very slow, but other browsers open word very quickly. Is this a bug in the design of the firebox browser?

Asked by 1346942613 5 hours ago

Last reply by 1346942613 2 hours ago

Pinned facebook tabs unpin and reload automatically on browser restart

I've facebook container addon installed https://addons.mozilla.org/en-US/firefox/addon/facebook-container/. If I pin any facebook tab and restart the browser, all the fac… (read more)

I've facebook container addon installed https://addons.mozilla.org/en-US/firefox/addon/facebook-container/. If I pin any facebook tab and restart the browser, all the facebook tabs unpin and automatically reload themselves. browser.sessionstore.restore_pinned_tabs_on_demand is already set to true.

This is pretty annoying. How do I get rid of this?

Asked by Nikhil 2 hours ago

YouTube and random no sound, Raspberry Pi

Raspberry Pi 4B Raspberry Pi OS -- Fully updated OS. Firefox 78.9.0esr (32-bit) -- Latest and greatest for Raspberry Pi OS. Some videos I am getting no sound. I try the … (read more)

Raspberry Pi 4B Raspberry Pi OS -- Fully updated OS. Firefox 78.9.0esr (32-bit) -- Latest and greatest for Raspberry Pi OS.

Some videos I am getting no sound. I try the effected videos in Chromium for Raspberry Pi OS and it works fine. I read about a possible fix and tried disabling hardware acceleration with no effect. I also blew out all the cookies,. history and stored site data. Each attempt closing and reopening Firefox. Same thing on the same videos, no sound in Firefox but fine in Chromium.

Any tips or pointers?

Asked by Tabatchnick 1 day ago

Last reply by Tabatchnick 7 hours ago

Mini Firefox icon on end of dock in macOS Big Sur 11.2.3

Long story short... this is my first Mac (MacBook Pro 13-inch, M1, 2020). I noticed that there is a mini Firefox icon at the end of my dock before the "stack" downloads f… (read more)

Long story short... this is my first Mac (MacBook Pro 13-inch, M1, 2020). I noticed that there is a mini Firefox icon at the end of my dock before the "stack" downloads folder and trash icon. I was wondering if anyone else has the same issue. Restarting seems to help but comes back, removing Firefox from the dock also seems to help but once it's back in there it comes back after a while.

Asked by Jorge Hernandez 9 hours ago

Problems sharing openboard window over google meet within firefox

Hello FF team I've problem sharing an Open Board program window over a google meet session. Though I think it´s more likely a google problem than FF´s or Open Board's I'… (read more)

Hello FF team I've problem sharing an Open Board program window over a google meet session. Though I think it´s more likely a google problem than FF´s or Open Board's I'm sending you this message in case this problem is known to them and they have some information that can help me to solve it Thanks in advance Regards Miriam G López

Asked by MGL-NET 9 hours ago

Autofill Logins & Passwords

In Preferences > Security & Privacy, I have the boxes checked to ask to save and autofilling login & password info. But the browser does not do it. It asks, … (read more)

In Preferences > Security & Privacy, I have the boxes checked to ask to save and autofilling login & password info. But the browser does not do it. It asks, but saves nothing when I answer Yes. This has been the case since I refreshed the browser at Firefox's suggestion last week. Worked fine prior to that. iMac running macOS High Sierra version 10.13.6. Thanks.

Asked by tonyber 10 hours ago

Change Background Image in Firefox, instead of black main page.

Hello All, I am looking for a method to change my standard black main background in Firefox. In the older version, you could choose Color Pic option and upload an image. … (read more)

Hello All,

I am looking for a method to change my standard black main background in Firefox. In the older version, you could choose Color Pic option and upload an image. That option is gone. So if anyone knows the solution for this problem I would be very grateful! Thanks in advance!

Cheers, Rubax

P.S. I use the latest version of Firefox (87.0) and Windows 10 Pro

Asked by Rubax 10 hours ago

Huge consumption of resources (99%) whenever YouTube is playing

Playing youtube video on Firefox has become a hazard. The power consumption sharply rises whenever a video is plying AND (specifically) when the this youtube tab is the o… (read more)

Playing youtube video on Firefox has become a hazard. The power consumption sharply rises whenever a video is plying AND (specifically) when the this youtube tab is the one open (current). As soon as I move to another tab and let the video continue playing this problem disappears and resource consumption looks normal. Then if I go back to the youtube tab then it spikes again sharply.

It has been like this for a week or couple of days now.

Asked by jerriy 13 hours ago

Last reply by jerriy 10 hours ago

Memory leak in Firefox.

I am a software engineer. I love Firefox but I believe that a memory leak may have developed. The problem goes back a couple of months. I have one instance of Firefox… (read more)

I am a software engineer. I love Firefox but I believe that a memory leak may have developed. The problem goes back a couple of months. I have one instance of Firefox open with three tabs opened but the task manager shows a large number of instances of Firefox being open and using a lot of memory. Currently there are nine instances of Firefox shown in the task manager. Look at the screen shot of the task manager that I uploaded.

I often have a lot of tabs open but I rebooted and opened a new instance of 

Firefox with only 3 tabs. I did open a new private window at the same time as the session I explained above but then I closed the private window. The memory leak might be the private window remaining in memory after it was closed. My OS is Windows 7. Yeah I know MS has stopped supporting it but I hate up dating the OS.

Thanks, Bill Smith

Asked by Bill 12 hours ago

Firefox Home Tab Screen

On the New Tab where you can save top sites to save for later and easy access, well i had a few saved there and then something happened and now they are all gone and i'm … (read more)

On the New Tab where you can save top sites to save for later and easy access, well i had a few saved there and then something happened and now they are all gone and i'm not able to add anymore, i click add site, give it a title and then put in the url and click add and nothing happens. I don't understand.

Asked by chris_stylejunior50 12 hours ago

Firefox Lesezeichen

Hallo, habe ein Problem meine alten Lesezeichen auf meinem neuen Laptop ein zu binden. Kann auf dem alten PC die Sicherung nicht mehr machen, da dieser gecrasht ist. Komm… (read more)

Hallo, habe ein Problem meine alten Lesezeichen auf meinem neuen Laptop ein zu binden. Kann auf dem alten PC die Sicherung nicht mehr machen, da dieser gecrasht ist. Komme aber an die Daten von der Festplatte. Habe mehrmals versucht die places.sqlite, Bookmarks und all die andern Daten, nach Anleitung vom Internet in meinen neuen PC ein zu spielen. Leider ohne Erfolg. Gibt es hier ein Problem mit Win 7 32bit(alt) zu Win10 64bit(neu). Über Tips und Anregungen wäre ich Dankbar.

Asked by peter.decher 13 hours ago