Showing questions tagged: Show all questions

Why does the subscription to Web Push notifications in Firefox disappears after a while? (Web Push API)

Hi, I really need help. I can't understand why Firefox kills properly registered push-subscription!? In my app, I properly register a service Worker, get permission, and … (read more)

Hi, I really need help. I can't understand why Firefox kills properly registered push-subscription!? In my app, I properly register a service Worker, get permission, and subscribe to push notifications. Then I save the subscription in my database and send PUSH notifications. Everything works well, in different browsers (Opera, Chrome, Firefox). But after a while when I send another push notification to Firefox I get a response:

"code": 410, "errno": 106, "error": "", "more_info": "http://autopush.readthedocs.io/en/latest/http.html#error-codes", "message": "Request did not validate No such subscription"

If re-subscribe, it starts working again for a while... This problem is ONLY with Mozilla Firefox, subscriptions for other browsers work ok! I can't understand why the subscription disappears in Firefox? I use same script for all browsers, what is wrong with it in the case of mozilla, I can't understand. Thank you in advance for your help!

Asked by mr.yurka 6 days ago

Reconnect to my Firefox account

My browser shows a triangle in the top right corner of the screen. A click there states "Reconnect to Firefox Account". On attempting this action, after entering my pass… (read more)

My browser shows a triangle in the top right corner of the screen. A click there states "Reconnect to Firefox Account". On attempting this action, after entering my password, I am asked to enter a 6 digit number sent to my email address. Unfortunately this takes more that 30 minutes to arrive at this far corner of the Earth but it states that it expires in 5 minutes. On entering the received 6 digit number, I get a message that it has expired and my attempt at reconnecting is terminated. I have tried this exercise 2 or 3 times, days apart but to no avail. Where do I go from here ?

Asked by dockery 6 days ago

  • Solved

bookmarks

Windows does not come up only DOS! Though DOS, I copied all the files to a USB... Remember, there is no windows only DOS. How can I find my old bookmarks? Thanks … (read more)

Windows does not come up only DOS! Though DOS, I copied all the files to a USB... Remember, there is no windows only DOS. How can I find my old bookmarks?

Thanks

Asked by richarddiaz 5 days ago

Answered by jscher2000 5 days ago

My history is gone and is not registering new either.

The browser seems to have updated, or something, and now all my history is gone from the"recently closed tabs and windows" and it does not seem to be creating new records… (read more)

The browser seems to have updated, or something, and now all my history is gone from the"recently closed tabs and windows" and it does not seem to be creating new records. Also my overall history is incomplete. Any what of getting all that back from wherever it went? How do I make it start creating history again? Thanks

Asked by maria40 5 days ago

Last reply by cor-el 5 days ago

Background on 2nd monitor breaking through Firefox window on mouse over - Linux Mint 20

I'm seeing breakthrough of the background when Firefox is open on my second monitor. This seems to occur when the window on the secondary monitor is minimised, then maxi… (read more)

I'm seeing breakthrough of the background when Firefox is open on my second monitor.

This seems to occur when the window on the secondary monitor is minimised, then maximised and mouse over the image on the secondary monitor (second is right hand side) - see image.

Initially I thought this was a graphics issue but this does not occur when I repeat the steps with other applications. I have also tried it with Chrome and Chrome does not display the same behaviour. I do not see this behaviour on the primary monitor.

I have reduced the refresh rate from 144Hz to 60Hz and reset Firefox which has not cured the issue. It appears to me that the only application that exhibits this behaviour on this machine is Firefox.

I also started to see this occur on my previous machine which was based on Mint 17 and a different Nvidia GPU and monitors and had been stable for many years.

If there is any further information I can provide, please let me know as I'm loathed to change from Firefox as I've been a fan for many years.

Asked by rjy8960 5 days ago

playing videos including html5

Am using Firefox 80.0.1 (newly updated) and Linux Mint 18.3. I have a problem with HTML5 and also codecs problems on at least two other sites (my daily newspaper and The … (read more)

Am using Firefox 80.0.1 (newly updated) and Linux Mint 18.3. I have a problem with HTML5 and also codecs problems on at least two other sites (my daily newspaper and The Register). The problem existed even in the previous Firefox version. If I use Chromium these videos work. The newspaper problems give the message that the browser can't play any of the available formats - code 12. I checked the web console ans there were many messages. I had logging allowed and set to the clipboard (gpaste) but nothing turned up there. I did a screen shot which is a png. I copied the results here. Missing codecs video/mp4; cidecs="avc1.42E01E mpra.40.2". This works in Chromium. As far as I understand HTML5 should work in Firefox. I've seen 2 places where it doesn't: live streaming from World Science Festival and from metopera.com. I've seen the problem once on youtube however I could view the same video later with no problem. As for the missing codecs I can live with using Chromium in the 2 cases the problem has shown up. But I would like some clarification on the HTML problem.

Asked by Seena 5 days ago

I have to verify Google account for some sites for every Firefox session

I use Firefox primarily. On my system, I have dual boot Windows 10 and Ubuntu. On each of these, I have to verify my account using security codes on phone for every time … (read more)

I use Firefox primarily. On my system, I have dual boot Windows 10 and Ubuntu. On each of these, I have to verify my account using security codes on phone for every time I log in using my Google account to sites like Facebook, BandLab and Stackexchange. My Ubuntu system is added to the trusted device list every time I log in from there as if I used a new computer. Can I do something to fix this annoying inconvenience for once?

Asked by supershounak2001 5 days ago

Last reply by cor-el 5 days ago

Firefox version

Many websites tell me my browser is out of date. Firefox checks it out and tells me that 66.0.5 is the most up to date version for my machine (I'm running Windows 7 32bit… (read more)

Many websites tell me my browser is out of date. Firefox checks it out and tells me that 66.0.5 is the most up to date version for my machine (I'm running Windows 7 32bit with 4 GB of ROM). are all of the releases after mine meant for other operating systems?

Asked by boba4 5 days ago

Last reply by FredMcD 5 days ago

When clicking on an email link, it goes into infinite "tabs" loop -- Still!

This has been an ongoing bug with FF; I found search results here that are a decade old! And it's a big bug! Here's why: Unit: Linux Mint 20-C on a Vivobook using FF 80… (read more)

This has been an ongoing bug with FF; I found search results here that are a decade old! And it's a big bug! Here's why: Unit: Linux Mint 20-C on a Vivobook using FF 80.0.1 (64-bit) 1: about:preferences > Applications > mailto > Firefox 2: about:preferences > Startup > Restore previous session 3: I have no other browser on my laptop (which is where this occurred).

In testing by clicking an email link, it went into that new tab open loop (at a rate of about 2 tabs per second), because what is now obvious, is FF browser cannot be an email client; at least, not as it is, and has been. I tried to launch it in a variety of ways (e.g. private; restart with add-ons disabled), but no matter what, the loop would reopen the browser, and continue the loop. I had to restart my laptop in safe mode just to use it.

So, I uninstalled FF and reinstalled it, launched it, and again it immediately looped uncontrolled. So, I again booted in safe mode, uninstalled FF, deleted all FF associated folders on my laptop, then reinstalled it. Fixed! Wow, that's just about as buggy as a computer can get! As the only browser, this created a serious conundrum. Thankfully I'm on Linux so I could install another browser brand if need be.

https://support.mozilla.org/en-US/kb/firefox-repeatedly-opens-empty-tabs-or-windows

I finally found this page, after the fact, but this issue should not be a problem to begin with: Bug! Filing a bug report has been done multiple times over the last decade, with no resolution, so why do it again? Logic dictates that If this bug cannot be fixed, just eliminate this as a choice in the next version. Using FF (synced) on 4 different devices, I had to check them all and undo that setting! Fair warning to all. And most will not be as determined to stay with FF; they'll uninstall it, quietly, and just use another browser. FYI

Asked by Monk of YHVH 5 days ago

Last reply by AliceWyman 5 days ago

Can not disable gmail notification in the background

Hi, I want to disable Firefox gmail notification when receiving a new mail with sound and notification prompt throught dunst. I found out that the gmail notifications run… (read more)

Hi, I want to disable Firefox gmail notification when receiving a new mail with sound and notification prompt throught dunst. I found out that the gmail notifications run in background of firefox.

I tried these ways: - Disable all gmail notification in gmail setting - Block gmail notification in Perefercences - Open gmail tab and mute it - Disable all extensions.

I'm running Arch 5.8.3, dunst 1.5.0, Mozilla Firefox 80.0.1 Any ideas? Thank you.

Asked by dannydyvn 5 days ago

autofill URL

There is a certain website that I have to visit often. I usually type the first few letters of the URL into search bar but, annoyingly, there's another website with almos… (read more)

There is a certain website that I have to visit often. I usually type the first few letters of the URL into search bar but, annoyingly, there's another website with almost exactly the same URL. Firefox always autofills the wrong URL and I always end up getting directed to the wrong site. Is there a way to prevent firefox from autofilling that URL and change it to the correct one?

Asked by odile.a.gotts 5 days ago

Last reply by cor-el 5 days ago

Printing Problems with Firefox

I have a new HP printer and I am using Firefox from a Windows 10 PC. I am plagued with Paper Mismatch errors when printing emails from Firefox. After a lot of trouble sho… (read more)

I have a new HP printer and I am using Firefox from a Windows 10 PC. I am plagued with Paper Mismatch errors when printing emails from Firefox. After a lot of trouble shooting, I have found that this problem seems to be confined to Firefox, as it does not happen when using other browsers, e.g. MS Edge. I have tried resetting all Firefox printer settings and the problem still happens when opening Firefox in Safe Mode.

The print job stops with the error message Paper Size Mismatch after the 1st page, and printing will not continue or even move on to the next job until the error is cancelled from the printer's control panel. This means I have to be working next to the printer and cannot print remotely.

In the printing dialogue box under Printing Preferences, the paper size shows Letter, whereas I am using A4 in the printer, and this is the mismatch causing the problem. I can change the paper size in Printing Preferences from Letter to A4, but I have to do this for every job seperately as the paper size setting always reverts to Letter. This is totally impracticable.

Regretably, I will have to stop using Firefox unless there is a solution. Can anyone help me to change the paper size setting to always default to A4, please? Thanks in anticipation.

Asked by CSH 5 days ago

Firefox Collections

Firefox Collections sucks! I don't want them, I do not want them ever on my Samsung Android phone! Period. Make them optional, or tell me how I can revert to my oft us… (read more)

Firefox Collections sucks! I don't want them, I do not want them ever on my Samsung Android phone! Period. Make them optional, or tell me how I can revert to my oft used Collections-free Firefox. Otherwise, bye-bye to Firefox on my phone. Got it?? Firefox Collections really sucks!

Asked by lp_cohen 5 days ago

Last reply by TyDraniu 3 days ago

  • Solved

I paid $28 to Firefox

I paid Firefox $28 for unmarked videos. Now the mark, the stamp in the corner of the video, is back. I would like my money back or the non-stamped videos back. Who do I s… (read more)

I paid Firefox $28 for unmarked videos. Now the mark, the stamp in the corner of the video, is back. I would like my money back or the non-stamped videos back. Who do I see about that?

Asked by miketimpiz 5 days ago

Answered by FredMcD 5 days ago

  • Solved

All extensions suddently disabled. No option button to re-enable them.

Running Windows 10, FF 80.0.1 64 bit. Windows reports the last update for FF was 9/1. Today is 9/17, so FF has been running for two weeks since the update before this p… (read more)

Running Windows 10, FF 80.0.1 64 bit. Windows reports the last update for FF was 9/1. Today is 9/17, so FF has been running for two weeks since the update before this problem showed up

I booted up this morning and FF and all extensions were working without problems. I then opened an html attachment from an email, which, was sent to FF to open. Instead of opening in a new tab in the already open FF window, I got a pop up saying that FF couldn't open because there was another instance running. I chose the button to close the already running instance, and the new instance launched with the html file. However all my extensions were summarily disabled and there is no option in the Manage Your Extensions window turn any of them back on. I am, as a result, using Chrome to ask this question, since that's the only way I can run my PW manager.

Anybody have any ideas how to fix this?

Asked by mdstone 5 days ago

Answered by mdstone 5 days ago

Automatic Start

17/Sep/2020 11:37 I had **two (2)** Firefox browsers. They both worked fine. Each one had links to web pages that worked fine. There was an automatic start last night - … (read more)

17/Sep/2020 11:37

I had **two (2)** Firefox browsers. They both worked fine.

Each one had links to web pages that worked fine.

There was an automatic start last night - and only one browser returned. The browser had different bookmarks. (**All** of those bookmarks aren't useful.)

How do I get both Firefox browsers back after there is an automatic start?

Asked by bkaras1 5 days ago

Last reply by jscher2000 5 days ago

laptop go to sleep while streaming video on web

i use firefox 79 win 10 enterprise 64bit asus a455 laptop, recently updating from 72/73 (not sure,cant remember) my problem is, my laptop go to sleep while streaming on y… (read more)

i use firefox 79 win 10 enterprise 64bit asus a455 laptop, recently updating from 72/73 (not sure,cant remember) my problem is, my laptop go to sleep while streaming on youtube or streaming football on any site i got this problem from since previous version FF 72/73 (cant remember for sure) i decide to update to 79 till now, and get same problems. disable add-on not help, but other browsers like opera/chrome doesnt have same issue

Asked by egominds 5 days ago