Showing questions tagged: Show all questions
  • Archived

When browsing the add-ons offered on mozilla.com many say "not compatible with Firefox 3.0.2" even though I have 3.6.8; How do I get the add-ons page to recognize that I have a newer version of FF?

When browsing the add-ons offered on mozilla.com many say "not compatible with Firefox 3.0.2" and will not let me install even though when checking the version using the … (read more)

When browsing the add-ons offered on mozilla.com many say "not compatible with Firefox 3.0.2" and will not let me install even though when checking the version using the "About Mozilla Firefox" in the Help menu it says I have 3.6.8; How do I get the add-ons page to recognize that I have a newer version of FF?

Asked by smokeyj 10 years ago

Last reply by cor-el 10 years ago