Showing questions tagged: Show all questions

Firefox - when Windows 7 support will be dropped?

Dear Mozilla Community, I would like to know when Firefox will be dropping Windows 7 support? I readed on some websites that Google Chrome will be dropped support for Win… (read more)

Dear Mozilla Community,

I would like to know when Firefox will be dropping Windows 7 support? I readed on some websites that Google Chrome will be dropped support for Windows 7 in 15 January 2022 year so I would like to know if there are any plans by Mozilla Developers to drop support for Windows 7?

I don't have computers with Windows 7 but my friends asked me about this because they know that I am active community member of Mozilla but I can't answer because I don't know so this is why I asked you today about this.

Yours faithfully, Piotr

Asked by Peter 3 weeks ago

Last reply by TyDraniu 1 week ago

Firefox Google advanced searh : search suggestions hide the input field !

Search suggestions in address bar work fine, showing the list below the input field, but in Advanced search the suggestion list displays on top of the input field and hid… (read more)

Search suggestions in address bar work fine, showing the list below the input field, but in Advanced search the suggestion list displays on top of the input field and hides the field completely as soon as you start typing ! Turning off "Provide search suggestions" in settings does not affect Advanced search. Is there any way to turn off this annoying feature ?

Asked by aarno.korpela 1 week ago

Last reply by 012179 1 week ago

How do I allow third-party cookies for certain websites?

Currently, I have configured my Privacy & Security settings in which all third-party cookies are blocked. This causes certain websites to break and become nonfunction… (read more)

Currently, I have configured my Privacy & Security settings in which all third-party cookies are blocked. This causes certain websites to break and become nonfunctional.

How do I configure my settings to which all third-party cookies are blocked by default, but for specific websites I choose they are not blocked?

I do not want to change my settings in which cookies are blocked only from websites I have not visited; because there are some websites I frequent that I still wish to block third-party cookies.

Thank you

Asked by zachsparks 1 week ago

Last reply by cor-el 1 week ago

bad update

hello since update of newtest version of firefox 89.0 (64-Bit) the browser is freeze and i receive message "do you will wait or close the browser". When i press wait so t… (read more)

hello since update of newtest version of firefox 89.0 (64-Bit) the browser is freeze and i receive message "do you will wait or close the browser". When i press wait so the windows is reload and ask if i will do wait or close firefox. I have only possibility to close firefox. The problem is all time. When i have chance i can use firefox 2-3 hours without problems. Many time i open Firefox after 5 minutes its freeze.

Whats happen? before i have do make update not problems....

My System: Ubuntu 18.04.5 LTS with 89.0 (64-Bit) Firefox.

Asked by nicolas9 1 week ago

Last reply by cor-el 1 week ago

Firefox will not use KDE dialogs and system applications and instead only uses GTK applications

I am running RHEL 7 and KDE4 with Firefox Nightly. Firefox will not use KDE/Qt dialog boxes or system applications. For example: when showing the downloaded file list (Ct… (read more)

I am running RHEL 7 and KDE4 with Firefox Nightly.

Firefox will not use KDE/Qt dialog boxes or system applications. For example: when showing the downloaded file list (Ctrl + Shift + y) and clicking the folder icon to show the file's location, firefox will freeze for several seconds before opening a window in Nautilus.

I have found discussions of this problem that span seemingly a decade without a simple step-by-step guide or an updated solution. Answers range from: editing =mimeinfo.cache= file for the =inode.directory= line, editing items in =defaults.list= file; setting the =GTK_USE_PORTAL=1= variable (somewhere) and then changing various =about:config= settings.

It's just confusing and exhausting tracking this down. Is it possible to get firefox to play nicely with KDE? Nothing that I have tried so far seems to have worked, but I'm honestly not sure where this setting would live, or magic bash incantation I need to run.

I know this seems minor, but having just switched back over to firefox to chrome, it seems very jarring seeing the GTK dialogs that do not play nicely with the rest of my desktop/workflow (i.e., I do not want to start a Gnome vs KDE flamewar, but rather: I'm used to dolphin and how it works and make heavy use of the embedded terminal within dolphin windows or drag&drop files into the Qt open dialog box which "drops" as a file path ... I have no idea what happens if I drag something into the GTK open dialog box)

Asked by stewart.t 1 week ago

Last reply by Danny Colin 1 week ago

May need to install the required video codecs

# My problem When i go to some site with video (for example https://www.openproject.org/ ) i have the following message : "To play video, you may need to install the requ… (read more)

# My problem

When i go to some site with video (for example https://www.openproject.org/ ) i have the following message : "To play video, you may need to install the required video codecs".

# Spec

I run Firefox Beta in Fedora, it's installed in /opt/ folder. I have the "normal" version of firefox too and the video works well.

# Some other infos

The video seem to be a mp4 video and i have the following package installed in my fedora GStreamer Multimedia Codecs (Multimedia plauback for APE, AVI, DV, FLAC, FLX, Flash, MKV, MP4, Speex, VP8, VP9 and WAV).

Asked by bouteiller.alan 1 month ago

Last reply by cor-el 2 weeks ago

disable history firefox in security param deactivate add-on from working on tool bar

I discover that when I disable history in security param and reboot firefox it deactivate all add-on from working on tool bar. Firefox Ubuntu 88.0.1 (64 bits) Ubuntu 21.0… (read more)

I discover that when I disable history in security param and reboot firefox it deactivate all add-on from working on tool bar. Firefox Ubuntu 88.0.1 (64 bits) Ubuntu 21.04

Asked by Sebu 2 weeks ago

Last reply by jscher2000 2 weeks ago

address bar autocompletes to depreciated url; how to stop?

Hello, I recently was forced to change the address of my blog from "universalism.com.au" to "universalism-au.com" (due to silly legal requirements introduced a few months… (read more)

Hello,

I recently was forced to change the address of my blog from "universalism.com.au" to "universalism-au.com" (due to silly legal requirements introduced a few months back about requiring an ABN if you want to use the .au suffix).

"universalism.com.au" is now a dead link, but when I start typing "uni..." in the address bar, it always autocompletes to this old and depreciated url rather than my new one. I would like to be able to type "uni..." and have it autocomplete to the new address, "universalism-au.com"

I have cleared what seems relevant from my browsing history, but no luck. Is this perhaps being caused by my default search engine (duckduckgo) recommending the wrong address?

I have attached a screenshot if this helps.

Asked by tikajr 3 weeks ago

Last reply by cor-el 2 weeks ago

FireFox completely transparent after update (89 Linux 64bit)

I thought I'd post it here for other people to find. I run Linux Mint (64 bit) so this may effect Ubuntu as well and potentially other distributions. After the update to … (read more)

I thought I'd post it here for other people to find. I run Linux Mint (64 bit) so this may effect Ubuntu as well and potentially other distributions. After the update to version 89 Firefox was COMPLETELY transparent. I saw more of the background than I did of the browser or the websites. After doing some digging around I found I had to enable layers.acceleration.disabled in config:about.

To do this open Firefox and in the address bar type config:about Do a search for layers.acceleration.disabled Double click it to enable it Close firefox and re-open it to verify your transparency is gone.

I hope this helps someone.

Asked by Patrick 2 weeks ago

Last reply by john 2 weeks ago

How to make tabs look like tabs again?

I've just upgraded to Firefox 89 on Linux. Tabs now appear with an icon and some text, a top and bottom border, but no side border, except for the active tab which has a… (read more)

I've just upgraded to Firefox 89 on Linux. Tabs now appear with an icon and some text, a top and bottom border, but no side border, except for the active tab which has a box around it.

I don't like this. I want a tab to look like a tab in a card index - A border at the left and right and top, and preferably rounded top corners. I get that this is one of the new features of this version....

but I hate it already.

In the attached screenshot, you can see how Palemoon does it (how Firefox used to do it). Without borders, there is no distinction between my bookmarks bar and my tabs bar.

How do I get it back to the old way. If there is no way of doing this, please fix it so that there is.

Rationale: I hate "flat" UIs. I want Radio buttons to look like buttons on a radio. I want buttons to look like buttons that you press; tabs to look like tabs. Scroll bars to be there all the time and big enough to grab and scroll etc.

Asked by steve-firefox1 2 weeks ago

Last reply by jscher2000 2 weeks ago

  • Archived

Search with ctrl-k no longer works when keyword.enabled = false

For quite some time now I've had keyword.enabled set to false in my about:config because I don't like having the address bar try to autocomplete or turn things into searc… (read more)

For quite some time now I've had keyword.enabled set to false in my about:config because I don't like having the address bar try to autocomplete or turn things into search, when I do a ctrl-l.

I do like that I am still able to use ctrl-k to do a search when I need to. This would place a ? at the start of the field and whatever I type gets sent to search.

In a recent upgrade, ctrl-k still places the ? at the start of the address bar but doesn't send things to search. Instead, it now behaves as if I did a ctrl-l and typed in a bad URL.

I'm on Firefox 80 (on Fedora 32) but I can't be exactly sure which upgrade brought this change in behavior.

Is there a way to get the old behavior back? ctrl-l to enter a URL, ctrl-k to search.

Asked by Ed 9 months ago

Last reply by Mike Kaply 2 weeks ago

Ctrl + D Add bookmark

Hi Is there some way to get the Ctrl + D window resizable? I find it a pain trying to scroll through my bookmarks to find a location to save to through a very small windo… (read more)

Hi

Is there some way to get the Ctrl + D window resizable? I find it a pain trying to scroll through my bookmarks to find a location to save to through a very small window.

Thanks!

Asked by Iron-Duke 2 weeks ago

Last reply by rogerwilco75 2 weeks ago

How to delete old username/passwords

I am suffering from slow load times -- especially the first time when the firefox is loaded for that day. Likewise there is a big pause when I go into settings -- saved … (read more)

I am suffering from slow load times -- especially the first time when the firefox is loaded for that day. Likewise there is a big pause when I go into settings -- saved usernames/passwords. Over the years I built up thousands of these pairings..

How can I easily remove all the old ones - say a year or older?

Please don't say, select the one, click delete, answer to are you sure prompt etc, as these actions take ages to do one at a time.

Asked by turgut kalfaoglu 3 weeks ago

Last reply by cor-el 2 weeks ago

Event hashchange and document.title

I have a problem with some JavaScript code that is run on a hashchange event. The code updates the web document, and also the document.title. The document.title is modifi… (read more)

I have a problem with some JavaScript code that is run on a hashchange event.

The code updates the web document, and also the document.title. The document.title is modified last.

If not modifying document.title, everything works fine. If updating document.title, the code sometimes fails, but not always. The symptoms are as follows.

  • The document.title is updated correctly, according to the A-tag with the hash URL that was clicked.
  • The URL field in the browser is not updated to the new value.
  • Non of the other document updates are done, even if they are performed on the code lines before changing document.title.

If a move the mouse outside Firefox and click in another window, the browser URL field is updated and the rest of the document is updated.

I then tried the code in google-chrome. There everything works fine.

If I add a console.log() in the hashchange eventhandler, everything works fine. Another work-around is to use window.setTimeout and delay modification of document.title by e.g. 10ms.

Is this a problem in Firefox, or am I not supposed to modify document.title on the hashchange event?

I am using Firefox 88.01 for Fedora 33.

I guess I should not include HTML and JavaScript in this editor?

Asked by bj_t60 3 weeks ago

Last reply by Seburo 2 weeks ago

Connection not secure on well-known sites

I have noticed that recently a lot of well-known and trusted sites(eg- youtube) are showing connection not secure (Parts of page are not secure such as images and any inf… (read more)

I have noticed that recently a lot of well-known and trusted sites(eg- youtube) are showing connection not secure (Parts of page are not secure such as images and any information that you share may be leaked -passwords etc) . Sometimes when I reload the site, it again shows connection secure.

Is this a glitch or something to be worried about and is there a solution?

Firefox Version - 88.0.1 (64-bit) OS- Ubuntu 20.04.2 LTS

Asked by prkandmap23 3 weeks ago

Last reply by FredMcD 3 weeks ago

Just One Small Step, please make sure JavaScript is enabled on your browser.

Hi there, Good Day! I don't know what's the reason but facing this problem (Just One Small Step, please make sure JavaScript is enabled on your browser.). I don't use an… (read more)

Hi there, Good Day!

I don't know what's the reason but facing this problem (Just One Small Step, please make sure JavaScript is enabled on your browser.).

I don't use any adblocker. I've tried about:config. javascript is enabled there also.

May I know what is causing the problem and how to fix.

Thanks.

Asked by jahiralamaumi 3 weeks ago

Last reply by cor-el 3 weeks ago

randomly crashes without exiting firefox (must kill)

hello context : Im using 78.10.0esr on debian 10 symptoms : randomly while changing tab or opening a new one, all the firefox window content disappear but edges (all e… (read more)

hello

context :

Im using 78.10.0esr on debian 10

symptoms :

randomly while changing tab or opening a new one, all the firefox window content disappear but edges (all even tabs or scroll bars). but firefox do not crash - it doesn't exit but becomes unusable.

first investigations reveal it is always the same kind of errors in terminal :

https://pastebin.com/GV7WVnuF https://pastebin.com/GV7WVnuF

I don't understand how to fix that.

Asked by fpussault 3 weeks ago

Last reply by jonzn4SUSE 3 weeks ago