Showing questions tagged: Show all questions

How to restore folder sessionstore-backups in folder .mozilla

I am a Linux user. So I have a folder called .moziila. Firefox use this folder to save settings and so on. If you are a Windows user you also have this folder C:\Users\&l… (read more)

I am a Linux user. So I have a folder called .moziila. Firefox use this folder to save settings and so on. If you are a Windows user you also have this folder C:\Users\<username>\AppData\Roaming\Mozilla.

So I have a folder (Linux) /home/name/.mozilla/firefox/rt7gtt8p.default/ (I will call it System Folder later)

If I would be a Windows user I would have this folder here: C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default (I will call it System Folder later)

But I want to have a folder called "sessionstore-backups" in System Folder. I had it and I want enable it folder again.

How can I enable "sessionstore-backups" in System Folder? My goal is to have a file called recovery.jsonlz4. Without this folder Firefox will not create recovery.jsonlz4 for me. So I don't have a folder "sessionstore-backups" and I don't have a file called "recovery.jsonlz4" but I want to have it, but how? Maybe I need to add something to about:config?

Asked by ddd.18et 2 hours ago

Last reply by ddd.18et 1 hour ago

« Sorry. We’ve locked your account. »

Hello, I'm getting the following message: « Sorry. We’ve locked your account. The confirmation email we sent to XXX@XXX.org was returned and we’ve locked your account to … (read more)

Hello,

I'm getting the following message:

« Sorry. We’ve locked your account.

The confirmation email we sent to XXX@XXX.org was returned and we’ve locked your account to protect your Firefox data.

If this is a valid email address, let us know and we can help unlock your account. No longer own that email? Create a new account »

I can connect to this support using the account, but not using sync on my devices.

My mail is a valid email address, and there was some temporary problem with the mail server which explains why the mail was returned.

What can I do to get back my account? The « let us know » link leads me here.

Thanks,

Asked by firefox995 3 hours ago

Re:adPleaseThanks!

bold text'I forgot my Password. How do I find it? I want too purchase your plan for one person. Thanks! Charles Peek k edit: removed personal information for your pr… (read more)

bold text'I forgot my Password. How do I find it? I want too purchase your plan for one person. Thanks!

Charles Peek


k

edit: removed personal information for your protection. (philipp)

Asked by charlesapeek 5 hours ago

h1.am live stream is not working

i cannot watch live streams on h1.am other streams like youtube live or netflix works fine. the stream on h1.am plays on chrome. this problem is tested on ubuntu and arch… (read more)

i cannot watch live streams on h1.am other streams like youtube live or netflix works fine. the stream on h1.am plays on chrome. this problem is tested on ubuntu and archlinux.

Asked by Arman Kocayan 16 hours ago

Cannot update self-hosted add-on due to "Certificate issuer is not built-in" error

I have a custom add-on that I'm working on for my team. It's hosted internally on a server signed by our company's internal CA. The add-on is signed by Mozilla, but not h… (read more)

I have a custom add-on that I'm working on for my team. It's hosted internally on a server signed by our company's internal CA. The add-on is signed by Mozilla, but not hosted on AMO.

I am on the latest version of Fedora running Firefox 81.0. In the browser console I get this error relating to the URL for the addon when I tell Firefox to check for updates: "Certificate issuer is not built-in".

I have the company CA installed and when I navigate to the site in the browser, Firefox recognizes the cert. I've done some reading on the subject and seen several threads about it. I've tried a few things already, but most of the threads where a couple of years old.

I'm asking the question here hoping to figure out what the current state of the problem is and which settings I should tweak to have it trust the company CA or what my options are.

Thank you in advance for any support on the issue.

Asked by bplaxco 18 hours ago

Last reply by bplaxco 16 hours ago

How do I change/customize key commands (hotkeys) in Firefox?

I'd like to be able to remap most of the key commands in Firefox to be more ergonomic such as Ctrl-h: select tab left instead of Ctrl-tab Ctrl-l: select tab right inst… (read more)

I'd like to be able to remap most of the key commands in Firefox to be more ergonomic such as

  • Ctrl-h: select tab left instead of Ctrl-tab
  • Ctrl-l: select tab right instead of Ctrl-shift-tab
  • Ctrl-j: scroll down half a page instead of Space
  • Ctrl-k: scroll up half a page instead of Shift-space
  • etc

Is it possible to change these key commands by configuring Firefox or modifying its configuration files? I've considered setting up an external program to remap keys when the Firefox window is focused, and compiling Firefox from source, but I'd like to know if it's possible without doing this.

Asked by vortico 1 day ago

Mots de passe et identifiants

Bonjour, je viens de me rendre compte que je n' ai plus aucun mots de passe et identifiants dans Firefox d' enregistrés, je ne me souviens pas avoir tout effacé, je suis … (read more)

Bonjour, je viens de me rendre compte que je n' ai plus aucun mots de passe et identifiants dans Firefox d' enregistrés, je ne me souviens pas avoir tout effacé, je suis sous emmabuntus, je n'écarte aucune éventualité, mais je préfére en informé votre équipe car cela est extrement surprenant, par avance merci.

Asked by ButaDreams 1 day ago

In "firefox pdf viewer" no button to save pdf (I can only print it)

I use version 81 of firefox. A new update of a website has disallow download of pdf. As the attachment I can only print pdf (or print to virtual printer) but I'd like no… (read more)

I use version 81 of firefox.

A new update of a website has disallow download of pdf. As the attachment I can only print pdf (or print to virtual printer) but I'd like normally save this pdf.

If I click with right key I can only save html (no pdf) and also use an external viewer I have same problem.

Any idea please?

thanks

Pol

Asked by Pol Hallen 1 day ago

opening url in specified firefox profile from command line

Hi, is there a way how i can let firefox open a link in new tab from command line for specified profile? Ideally in a way in which it doesn't matter, whether firefox is a… (read more)

Hi,

is there a way how i can let firefox open a link in new tab from command line for specified profile? Ideally in a way in which it doesn't matter, whether firefox is already running or not

I know I can do something like: firefox --new-tab 'https://www.google.com' this works no matter whether firefox is already running (just add new tab) or it's not (open firefox and add tab)

But what I want to achieve is something like this: firefox -P myProfile --new-tab 'https://www.google.com where myProfile is existing profile.

This works unless firefox is running with that profile (opens new instance). But if it's already running i get the error message (Firefox is already running but it's not responding. To use firefox you must first close the existing firefox process, restart your device, or use a different profile). I tried it with/without --no-remote options but it didn't help

I want this for a script that should open pages automatically but not in the default profile. And it should be able to work even if the profile is already running.

Thanks for any advice, Jaymes

Asked by jaymes.ramona81 1 day ago

Persistent performance problems starting ~6 weeks ago

Hey there, I and my colleagues who use Linux have all started seeing massive performance decrease & tabs frequently reporting "a web page is slowing down your browser… (read more)

Hey there, I and my colleagues who use Linux have all started seeing massive performance decrease & tabs frequently reporting "a web page is slowing down your browser" issues starting around August 5 or 6 of this year. I started a complaint thread in my company slack about this on August 6, and unrelated to that, someone else started a similar thread on august 18.

At first I thought it was just me, or just some quirk of my linux distribution, or a pattern of using the software. But I actually switched Linux distros from Ubuntu to Arch to see if it would help (it didn't) and now that I've seen the behavior consistently across a whole bunch of different apps, I think it's a bug. It seems to affect heavier webapps like Quip and Slack, much more so than lighter webpages. Again, nothing was wrong before August of this year and now, depending on how I use my computer, I frequently get "a web page is slowing down your browser", cpus pegged to 100%, which ends up with me closing tabs/ sometimes restarting firefox multiple times per day.

Nobody on Chrome is complaining about similar issues.

I did run the profiler for a bit while such an issue was going on, and am happy to share it, although it has slightly-private information from one of our company slacks and I don't know if this forum is public.

Asked by lincolnq 1 day ago

disabling private browsing using `policies.json` seems not work

I followed https://support.mozilla.org/en-US/questions/1229792#question-reply about, disabling private browsing using `policies.json`, but that seems not work. PS: am usi… (read more)

I followed https://support.mozilla.org/en-US/questions/1229792#question-reply about, disabling private browsing using `policies.json`, but that seems not work.

PS: am using ubuntu 18.04

Asked by lubegasimon 1 week ago

Last reply by lubegasimon 1 day ago

Problem with @ sign in forms

Hello, I have the problem that when filling out "email" in a form on a website everytime I write the @-sign everything written in front of it get's deleted. I found out t… (read more)

Hello, I have the problem that when filling out "email" in a form on a website everytime I write the @-sign everything written in front of it get's deleted. I found out that when I press the "Alt-Gr"-key the word I wrote get's marked and of course then the @ deletes the marked word. How can I keep "Alt-Gr" from marking the active word? :-) Also the same word marking happens when pressing the "Alt"-key. The same happens in Thunderbird when trying to write a new email. I'm working with Ubuntu, but I doubt it has to do with Ubuntu, because when filling out a form in Opera it works just fine. Any help appreciated! Cheers! Formicula

Asked by formicula 1 day ago

Previous Sessions disappear often

I am having this issue for about a year now. It happens once a month that my Firefox does not restore the previous session and I lose all the tabs in the process. This ha… (read more)

I am having this issue for about a year now. It happens once a month that my Firefox does not restore the previous session and I lose all the tabs in the process. This has happened enough times that it has become a major issue. I want to know how I can fix this problem.

Asked by tanveerakarim 1 day ago

How to transfer tabs from firefox to another firefox on the same dual boot laptop

How to transfer tabs from Firefox to another Firefox on the same dual boot laptop going from Window 10 to Linux MInt 20. And the history of those tabs also, if possible.… (read more)

How to transfer tabs from Firefox to another Firefox on the same dual boot laptop going from Window 10 to Linux MInt 20. And the history of those tabs also, if possible.

Asked by jbsmwd 2 days ago

Firefox 81 on Linux and hardware acceleration supposedly on by default

Even though Firefox 80 and 81 release notes doesn't say anything, many websites stated that hardware acceleration on Linux X11 was introduced in Firefox 80, but disabled … (read more)

Even though Firefox 80 and 81 release notes doesn't say anything, many websites stated that hardware acceleration on Linux X11 was introduced in Firefox 80, but disabled by default, while it was enabled by default in Firefox 81.

This is what I see in my about:config and, honestly, it's definitely unclear (using Firefox 81, of course):

HW_COMPOSITING available by default / blocked by env: Acceleration blocked by platform OPENGL_COMPOSITING unavailable by default: Hardware compositing is disabled WEBRENDER opt-in by default: WebRender is an opt-in feature WEBRENDER_QUALIFIED available by default / denied by env: Not on allowlist WEBRENDER_COMPOSITOR disabled by default: Disabled by default WEBRENDER_ANGLE opt-in by default: WebRender ANGLE is an opt-in feature WEBRENDER_DCOMP_PRESENT opt-in by default: WebRender DirectComposition is an opt-in feature OMTP available by default WEBGPU disabled by default: Disabled by default / blocked by runtime: WebGPU can only be enabled in nightly

What should I understand from this? Sounds like it's all DISABLED on my system (Linux Mint 18.3, based on Ubuntu 16.04, Intel Haswell integrated GPU). Why!?

Also, what is the right way to enable some hardware acceleration now? OpenGL, WebRender, FFMPEG/VAAPI... it's a real mess. Until some versions ago, I simply used layers.acceleration.force-enabled=true and this enabled OpenGL hardware compositing. But what is the right way to do it now?

Why can't Firefox developers simply add an option in Preferences to enable or disable hardware acceleration!? The only current option "use hardware acceleration when available" doesn't mean anything. I have been using OpenGL hardware compositing with layers.acceleration.force-enabled=true for years with no issues at all, yet Firefox always decided that I should not use any kind of hardware acceleration on my system... Quite disappointing.

Asked by mauromol 2 days ago

Firefox relay isn't working

Firefox relay isn't working at all. I wanted to test the service, so I created a ProtonMail and PayPal account to give it a shot. I set up my newly created ProtonMail as … (read more)

Firefox relay isn't working at all. I wanted to test the service, so I created a ProtonMail and PayPal account to give it a shot. I set up my newly created ProtonMail as my primary e-mail address on my Firefox account, so that relay forwards e-mails to that address. I then created a PayPal account using one of relay's e-mails. That went no issues. Then when PayPal asked me to confirm my e-mail address, things went south. Despite relay's counter of "forwarded e-mails" going up, nothing was showing up on my ProtonMail inbox. I checked on my previous e-mail and still nothing. I saw in the details of the relay e-mail that it was indeed supposed to be forwarding mails to the ProtonMail address, but it wasn't working at all. This isn't a problem with PayPal nor ProtonMail. I received Firefox's e-mails asking me to confirm the primary e-mail change, so ProtonMail is working. Furthermore, when PayPal sends me confirmation e-mails, the counter in relay goes up, so PayPal is sending them and relay is receiving them, but they ain't coming into my ProtonMail inbox... nor spam. Solutions?

Asked by tralph3 3 days ago

Facebook formatting on group posts vanishes

In the list two weeks, Fire 80.01 for Linux (ubuntu Mate) suddenly stopped being able to format group posts on Facebok. I write a post in the text box and I format it an… (read more)

In the list two weeks, Fire 80.01 for Linux (ubuntu Mate) suddenly stopped being able to format group posts on Facebok. I write a post in the text box and I format it and it appears to have the H1 or bold or italic formatting. Then I press OK and the formatting doesn't appear and it gone when chose edit and I can't add it with edit either.

Asked by joesolbrig 3 days ago

Disabling title bar makes Firefox slow

Hello! I have recently installed Xubuntu Focal Fossa, and noticed that Firefox became slow along the way. At first, I didn't know what was the reason, but now, after havi… (read more)

Hello! I have recently installed Xubuntu Focal Fossa, and noticed that Firefox became slow along the way. At first, I didn't know what was the reason, but now, after having purged it and reinstalled it again for the second time, I am pretty sure that it is disabling the title bar which is causing the problem. Enabling it again and restarting the browser makes everything smooth once more. Is there a solution to this? Thank you very much!

Asked by realnameperson 3 days ago

no sound on Blitzortung.org

When I view the blitzortung.org (live lightning map) website I do not hear any sounds associated with the lightning strikes. The normal sound is a very short duration "cl… (read more)

When I view the blitzortung.org (live lightning map) website I do not hear any sounds associated with the lightning strikes. The normal sound is a very short duration "click". The sound is present when using other browsers but I really hate using Chromium (don't like Google). I am running Debian Linus 10 and I nominally use Firefox ESR. I have downloaded the regular Firefox and the problem occurs with Firefox 80 as well as with ESR 68.12.0.

By opening the PulseAudio mixer while the blitzortung site is opened I have observed that there is a brief flash of the AudioIPC server that coincides with the lightning strike "clicks". My guess is that the AudioIPC server response time is the issue.

Is there any way to get around this issue.

Sound works fine for every other web site.

Asked by jsamcr 3 days ago

Last reply by jsamcr 3 days ago