Showing questions tagged: Show all questions
  • Solved

Error message will not let me open Firefox

When I try to open Firefox I am getting this error message: Error: platform version '124.0.1' is not compatible with minVersion >= 124.0 maxVersion <= 124.0. Do… (read more)

When I try to open Firefox I am getting this error message: Error: platform version '124.0.1' is not compatible with minVersion >= 124.0 maxVersion <= 124.0. Does anyone know how I can fix this? Deb PS I need simple instructions, I'm not terrible techy.

Asked by Deborah Lief 4 weeks ago

Answered by TyDraniu 4 weeks ago

  • Solved

"Failed to check for updates" et al

Hey, so, I've seen this question a couple times when I searched, but (a) there didn't seem to be any solution and (b) they were all regarding Macs and I'm on Windows 11 v… (read more)

Hey, so, I've seen this question a couple times when I searched, but (a) there didn't seem to be any solution and (b) they were all regarding Macs and I'm on Windows 11 v 23H2. I keep getting bubbles saying that Firefox wasn't able to check for updates- not that it couldn't download or install updates, but it couldn't search for one. I also did the "about Firefox" thing and it gives me the same message. Both of these have been going on for a couple days and I have attempted restarting Firefox multiple times and did a manual update [125.0.1 (64-bit)] just in case there was a problem there. Now, I've tried the tips from the other threads (turning off the proxy, checking any anti-update policies, and checking the add.update.url in the config settings) with no luck. So in an effort to either bump the question or get any Windows oriented answers... Thanks muchly

Asked by xheavenlybodiesx 6 days ago

Answered by NoahSUMO 4 days ago

  • Solved

Choppy 4K YouTube playback

I have a very good PC (5800X3D, 7900XT, 32GB DDR4 3600), but Firefox (either the normal, canary and nightly version) can't play smoothly any 4K video (like the Borderland… (read more)

I have a very good PC (5800X3D, 7900XT, 32GB DDR4 3600), but Firefox (either the normal, canary and nightly version) can't play smoothly any 4K video (like the Borderlands trailer: https://www.youtube.com/watch?v=lU_NKNZljoQ ). 1440 and lower resolutions are fine, as are 4K videos on Chrome and Edge. FWIW, my CPU during 4K playback is barely used (1-2%), and my GPU's video codec (VCE) is used by around a third. Disabling HW accel makes things better, as it still stutters but it's (barely) passable. I already tried creating a new profile, but still it's the same.

Asked by Federico Barutto 1 month ago

Answered by zeroknight 1 month ago

  • Solved

Youtube very laggy recently?

basically just the title. In the last couple days youtube.com specifically has been borderline unusable for me on firefox. All other websites work fine for me on firesfox… (read more)

basically just the title. In the last couple days youtube.com specifically has been borderline unusable for me on firefox. All other websites work fine for me on firesfox and youtube has no issues on other browsers.

Asked by Dartagnan Rozycki 3 months ago

Answered by TyDraniu 3 months ago

  • Solved

Google Search on Firefox not working

Google search no longer works on Firefox. Other browsers have no problems. Changing the default search engine on Firefox works (eg Bing), BUT. It can now find Google M… (read more)

Google search no longer works on Firefox. Other browsers have no problems. Changing the default search engine on Firefox works (eg Bing), BUT. It can now find Google Maps, but Google Maps cannot find a location, because it uses a Google search. I tried the fix in about:config, but it had no effect.

Asked by grahamppink 2 months ago

Answered by grahamppink 2 months ago

  • Solved

Youtube low FPS when put to fullscreen.

I am having an issue where youtube videos played at higher quality stutter when put to fullscreen. Up till about 720p60 works fine, at 1080p60 and above the framerate bec… (read more)

I am having an issue where youtube videos played at higher quality stutter when put to fullscreen. Up till about 720p60 works fine, at 1080p60 and above the framerate becomes unstable.

Things I have tried: - I have tried going into media.media-capabilities.enabled and changing it from false to true - I have set network.buffer.cache.size to 262144 - I have disabled all my plugins - I have tried changing my user agent to windows/chrome

My current setup: Firefox 122.0, Macbook pro Sonoma 14.1, Apple M1 Pro chip

Curiously, if I make a new firefox profile and play a video there, there is no stutter. Does anyone have ideas on how I can fix my current profile?

Asked by markus.maomao.ang 2 months ago

Answered by zeroknight 2 months ago

  • Solved

Firefox displays html code on .xml page instead of rendering text

Firefox displays text on the .xml page as html code instead of rendering is as normal text. The layout and images on the page look as they should. There is nothing wrong… (read more)

Firefox displays text on the .xml page as html code instead of rendering is as normal text. The layout and images on the page look as they should.

There is nothing wrong with the page, as it is rendered perfectly in Chrome.

In addition, this page doesn't display at all on the phone. When I click on the link it asks me to download it and then asks me which app I want to open it with - instead of simply rendering the page.

I have seen some old threads on this topic, it looks like this issue haven't been resolved for few years.

My question is not just about fixing it in my browser but at the root cause. This page is the RSS feed of my podcast which many people want to access and many use Firefox as their browser. Unless I tell everyone to use Chrome instead.

Can someone help? thanks.

Asked by etcetera777 3 months ago

Answered by etcetera777 3 months ago

  • Solved

Firefox Freezing PC

Hello, I am running Ubuntu 22.04 (Firefox v 121.0) on a custom PC. Ryzen 5700G, 32GB Ram, 2TB Storage, and a Radeon RX 580 (just to give some insight into the system in … (read more)

Hello, I am running Ubuntu 22.04 (Firefox v 121.0) on a custom PC. Ryzen 5700G, 32GB Ram, 2TB Storage, and a Radeon RX 580 (just to give some insight into the system in case it is useful). I use multiple mozilla services and haven't had many issues up until now. Everytime I open Firefox it immediately it fires right up, the moment I try to open a tab, search, etc.. it begins to lag. It will then freeze the browser and my entire PC soon follows suit. I have had to hard reset the PC about 3 times now. I originally had the snap version installed and thought that installing the deb package would fix the issue. I completely uninstalled the snap version and turned off unattended installations in case the system tried to reinstall the snap. I then installed the deb package and fired it up again, only to have the same issue. I have ruled out a couple of things on my end. I entered Firefox Safe Mode and unchecked all of my extensions (the only ones I run are Ublock, Bitwarden, and Relay). I ran a mem test and have been monitoring Psensor to ensure the CPU wasn't overheating (both of these tests were fine). I also scanned my entire PC to ensure I did not have any viruses (clamscan reported no viruses). I have been running my PC for about an hour now without starting Firefox and using Chrome, and I have had no issues with freezing or anything similar to what happened with Firefox. Not sure where to go from here. I love using Firefox and would love to get back to surfing as soon as possible! Any tips/help would be greatly appreciated! PS I could not find any logs about the session. I looked in ~/.mozilla/firefox/Crash Reports/events and couldn't find anything. If there is another place they are stored let me know and I would be happy to send them. I just don't want to open Firefox until I feel it is safe for my PC.



I forgot to add: I disabled hardware acceleration as well, did not fix the issue.

Asked by aaronlnewman 3 months ago

Answered by aaronlnewman 3 months ago

  • Solved

New Tab: no cursor in the address bar

I frequently open new tabs by right-clicking the current tab and choosing "New Tab" from the context menu. Naturally, I want to start typing a URL or search term. But th… (read more)

I frequently open new tabs by right-clicking the current tab and choosing "New Tab" from the context menu. Naturally, I want to start typing a URL or search term.

But the focus/cursor/caret is nowhere and typing does nothing. I have to click on the address bar, and then I can type.

I'm not using New Tab Override and I have Firefox's new tab set to a blank page.

I tried disabling all my add-ons, but I still had the problem.

I tried setting new tab to the Firefox home page and for a short while I got a cursor in the address bar. But the problem returned after a few hours

Any clues on what might be wrong? Firefox version 120.0.1 (64-bit) on MacOS Ventura 13.5.1. Thanks!

(A similar problem is described here: https://support.mozilla.org/en-US/questions/1420220 -- but in my case this is not a container tab.)

Asked by jeremy76 3 months ago

Answered by jeremy76 3 months ago

Firefox 120.0.1 Memory Leaks, Windows 11 & 10, not a new issue

Firefox uses too much memory, sometimes 20GB on a 32GB Windows machine. It's usually one or two threads which are hogging incredible amounts of memory. This time I had … (read more)

Firefox uses too much memory, sometimes 20GB on a 32GB Windows machine. It's usually one or two threads which are hogging incredible amounts of memory. This time I had about 30 tabs open.

Today I tried Firefox about:memory "Minimize Memory Usage" several times, and it was largely ineffective.

I did a "create memory dump file" of one 5+GB bloated thread using task manager, but can't find a way to upload the compressed archive with this report for analysis. Finding a way to report this issue was quite a challenge. It seems most help avenues are now missing/moved, and other reports of this type of issue are "Archived".

I tried killing the 2 bloated Firefox threads and checked for tabs which might be missing or malfunctioning. Everything continued to run normally while more than 10GB of memory was returned to system use. Leaving these bloated threads overnight doesn't improve anything, in fact I can often get up and find my machine is completely out of memory because Firefox consumed it all. My smallest machines have 16GB RAM.

These memory issues aren't new. I've been reporting them off and on for more than a decade. They get better for a few months after reporting, then they get bad again in a few more months. The battle to get memory leaks fixed is continuous while Firefox springs more leaks.

I'd like to give you the memory image I generated so you'll at least have some real data to look at and analyze for this report.

The attached task manager snapshot image is a very minor example of this issue. The numbers keep increasing like there are one or more large memory leaks.

Asked by Craiga 4 months ago

Last reply by cor-el 4 months ago

Firefox draining battery life 41% usage

I am having a significant issue with firefox draining my battery. I used chrome up until the new year and then switched over to firefox from chrome. Overall I love firefo… (read more)

I am having a significant issue with firefox draining my battery. I used chrome up until the new year and then switched over to firefox from chrome. Overall I love firefox so much more. The format is way more pleasing. I love how it easily signs me back into everything, BUT IT DRAINS MY COMPUTER SO MUCH. Like i used to have an 8hour + battery span my laptop neverrr died. Now I get through MAX 2 hours of full use before needing to charge, and maybe 4 hours just having it at school but not using it.

I thought my dell suddenly started crashing, ran all these tests, and then I realized the only change was that I had started using Firefox... So sad I think I am going to have to leave it.

I read a lot of articles and did everything suggested. my graphics is webreader , i turned on all the suggested features, i have 2 extensions , the only thing I could maybe think of was that I use an animated theme so maybe that was killing the battery, but like if I can't use my theme than whats the point.

Asked by nebs9921 3 months ago

Last reply by zeroknight 2 months ago

  • Solved

ChatGPT no longer gives any response in firefox

I tried clearing cache and temp files. I tried a new profile. I tried a fresh install without logging in on account. Tried disabling all addons, running in safemode and i… (read more)

I tried clearing cache and temp files. I tried a new profile. I tried a fresh install without logging in on account. Tried disabling all addons, running in safemode and incognito. Nothing works.

When opening in Chrome, it works as always. Same computer.

Asked by alyndra 2 months ago

Answered by zeroknight 2 months ago

  • Solved

Can't Copy to clipboard anymore

Since a couple days ago I cannot Copy anything in Firefox. Be it with CTRL+C or RightClick>copy. I can paste juste fine, and it works on any other app and browser I ow… (read more)

Since a couple days ago I cannot Copy anything in Firefox. Be it with CTRL+C or RightClick>copy. I can paste juste fine, and it works on any other app and browser I own. I tried to restart in safe mode (no add-on) but the issue persists. I ended up resetting firefox and it solved the issue... For a couple hours.. then it came back and I can't copy anymore. I did check that I was using the latest version of Firefox windows. I only have two add-ons, but since in safe mode it still doesn't work I'm not sure it's related to that. I also checked that Firefox was allowed in the firewall (I don't know why that would help but a forum said to check that).

Thank you for your assistance:)

Asked by tristan.riviere 5 months ago

Answered by tristan.riviere 5 months ago

  • Archived

Time to say goodbye?

I have used Firefox since forever, was a Netscape user in the past But for about 3 months Firefox simply is no good anymore\ It is more and more sites I can not access … (read more)

I have used Firefox since forever, was a Netscape user in the past

But for about 3 months Firefox simply is no good anymore\

It is more and more sites I can not access with Firefox and have to use Edge instead.

Last example, just now

https://www.cibc.com/en/journeys/new-to-canada.html

See screens attached

This is just one example, many other sites simply do not open, or open properly, in Firefox

WHAT IS HAPPENING?

Thank you

Asked by Marcelo 6 months ago

Last reply by pamclark1 3 months ago

Gah. Your tab crashed - Error with no Crashlogs - even in new install

It started today, with no new software, or addons installed. Version is 119.0 64bit. I tried: - troubleshooting mode - disabling all Addons - uninstalling and re-install… (read more)

It started today, with no new software, or addons installed. Version is 119.0 64bit.

I tried: - troubleshooting mode - disabling all Addons - uninstalling and re-installing Firefox - setting both browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 to "false" - uninstalling Firefox, manually deleting everything Mozilla related in the App-Data, and Programs folders and finally re-installing Firefox

At least the last one should have worked? I am at a complete loss and rather frustrated.

about:crashes claims that there are no submitted crash-reports.

Asked by aufisch 5 months ago

Last reply by aufisch 5 months ago

  • Solved

Taskbar icon appearing blank

Hello, today firefox has been appearing as a blank icon on my taskbar. I have tried solutions suggested in older posts but it did not help unfortunately. if i try to 1-… (read more)

Hello, today firefox has been appearing as a blank icon on my taskbar. I have tried solutions suggested in older posts but it did not help unfortunately. if i try to

1- right click unpin from taskbar the icon shows once more. 2- right click, the icon disappears/becomes blank. 3- click pin to taskbar, the icon remains blank.

attached is the image showing the steps i described above

Asked by manysmiles 5 months ago

Answered by manysmiles 5 months ago

YouTube videos freezing, still playing audio if multiple tabs open with multimedia available

I like to split windows so I can have running YouTube videos on the left half of the screen and browsing the web on the right. If I open another site on the right side o… (read more)

I like to split windows so I can have running YouTube videos on the left half of the screen and browsing the web on the right. If I open another site on the right side of the screen that has multimedia (ESPN, CNN, IMDB), the video freezes on the YouTube window but audio continues to play without issue.

I have done the following troubleshooting steps:

  • Hardware acceleration turned off/on
  • cleared cookies/cache
  • A few About:config fixes

Videos don't have a problem running if I open YouTube with Chrome and continue to use Firefox for surfing.

i9-12900hk 64GB RAM 2TB m.2 SSD (lots of free space)

Asked by stevenmfarmer 4 months ago

Last reply by stevenmfarmer 4 months ago

  • Solved

Accessing Youtube.com causes immediate unlogged tab crash

Hey, I've been having an odd issue with Firefox where tabs where I attempt to access youtube.com will immediately crash. This issue first arose when I attempted to log i… (read more)

Hey,

I've been having an odd issue with Firefox where tabs where I attempt to access youtube.com will immediately crash. This issue first arose when I attempted to log in to Youtube, and had never occurred before. When I did that login, the tab crashed, and I have been unable to access the website since (100% crash rate).

Basic details: The website does not visually load at all. However, the URL bar icons for the website do briefly appear prior to tab crash. (Autoplay button, etc). The crash is never reported in about:crashes.

I've tried the following tests, unsuccessfully: - Logging out of all Google accounts separately - Disabling all extensions - Transferring all of my data to a new computer - Reinstalling Firefox - Rebooting Firefox in troubleshooting mode

This problem does not occur on my Windows machine but occurred on my previous intel-based Mac and now on my current Apple Silicon Mac.

The only success I have had is in creating an entirely new Firefox profile. However, I would prefer to fix the issue, as I assume that porting all my settings to the new profile would... also probably bring the bug along.

Thanks for reading & any advice is appreciated.

Asked by Michael 4 months ago

Answered by zeroknight 4 months ago