Showing questions tagged: Show all questions
  • Solved

Is there a way to turn off tracking URL fragment insertion from the release notes page when clicking "What's New" in the Firefox update modal?

Is there a way to turn off tracking URL fragment insertion from the release notes page when clicking "What's New" in the Firefox update modal? When I click "What's New" … (read more)

Is there a way to turn off tracking URL fragment insertion from the release notes page when clicking "What's New" in the Firefox update modal?

When I click "What's New" in this modal (see Screenshot 1), it loads the release notes page for my current version (although it really should load the release notes page for the version it wants me to upgrade to, but that's another issue altogether), and inserts a bunch of tracking URI fragments onto the URL (see Screenshot 2).

Is there a way (in Settings, about:config, Windows Registry, etc.) to disable that fragment insertion?

Asked by Tyler 1 month ago

Answered by jscher2000 - Support Volunteer 1 month ago

  • Solved

Dead keys not working only in a specific profile

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the… (read more)

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the letter itself. It can render them just fine and I can paste them from another app normally too, but actually typing them is impossible from firefox.

After trying to troubleshoot, I eventually found out a few things: - iBus is not at fault, since it works in every other app and I even restarted it, but the problem persists - This only happens in my main profile, newly created profiles don't have that problem - The problem still happens on troubleshoot mode (as long as it is my main profile) - Compose key also doesn't work (I don't want to use compose key anyway, because my keyboard has specialized dead keys, but I at least tried it)

I suspect the problem lies in a setting on about:config that's different from newly created profiles, but I have no idea which and Ctrl+F searching this site doesn't show any relevant configuration that might be the culprit.

Asked by Kazuma 1 month ago

Answered by Kazuma 1 month ago

  • Solved

WebGL creation failed after reinstalling lbgl1* libegl*

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02… (read more)

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02).

I used to play this game named narrow.one, which before I reinstalled the mentioned libraries, was working fine except for crashing a few times. I thought these libraries were causing some issue, so I tried reinstalling them.

I reinstalled the libraries using: `sudo apt install --reinstall --fix-missing libgl1* libegl*`

After installation, I start getting that error. So, I tried reinstalling firefox (using the same command), and then restarting the laptop - but of no use. Chrome seems to be running WebGL, including the game.

In firefox, on the https://get.webgl.org/ page, I see Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

After that, I also tried reinstalling `libopengl0` and `libglu1-mesa` and `intel-microcode`, but of no use. Running although, `sudo intel_gpu_top` and then chrome, it seems that the GPU is in use by chrome as well.

I then go to about:support. It shows me the images I have attached. Reading the logs, there several `blocklisted` values in `Decision Log` section. I suspect that's the cause of this issue, but then I don't know how can I un-blocklist the blocklisted things, and even after that, why does Chrome runs webgl if these are blocklisted?

Running `glxinfo -B`, I get the following: `name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer):

   Vendor: Intel (0x8086)
   Device: Mesa Intel(R) HD Graphics 620 (KBL GT2) (0x5916)
   Version: 23.2.1
   Accelerated: yes
   Video memory: 7697MB
   Unified memory: yes
   Preferred profile: core (0x1)
   Max core profile version: 4.6
   Max compat profile version: 4.6
   Max GLES1 profile version: 1.1
   Max GLES[23] profile version: 3.2

OpenGL vendor string: Intel OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2) OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL core profile shading language version string: 4.60 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL shading language version string: 4.60 OpenGL context flags: (none) OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-1ubuntu3.1 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20`

I do not know much about OpenGL, but reading the above stuff, I suppose my GPU is in use and also has a compatible driver (although I am not sure).

Also, running `glxdemo`, `glxheads`, and `glxgears` seems to be rendering stuff.

Should I reinstall firefox after purging it first? Please help.

Thanks!

Asked by Lakshay Rohila 1 month ago

Answered by zeroknight 1 month ago

  • Solved

Save one autofill entry for usernames across all sites?

I have a unique annoyance wherein I use a considerably long email address for many sites. I've gotten tired of typing it out whenever it comes up and wish for it to be pr… (read more)

I have a unique annoyance wherein I use a considerably long email address for many sites. I've gotten tired of typing it out whenever it comes up and wish for it to be preserved as an autofill across all sites so I no longer have to, similar to how your phone may suggest your email address in autocomplete.

Unfortunately, as far as I can tell, you can only manually add autofills for specific sites and with password attached. So my question is, is there a way to make the address be a suggested autofill on username/email address boxes across all sites?

(not interested in having form history saved, just want this one specific form entry)

Asked by ballakoala 1 month ago

Answered by cor-el 1 month ago

  • Solved

Hotmail through Firefox breaks my network card

I had a few issues with Hotmail and Firefox in the past as described in other posts. Now it has stepped up a gear. I can use the internet for anything, but the moment I o… (read more)

I had a few issues with Hotmail and Firefox in the past as described in other posts. Now it has stepped up a gear. I can use the internet for anything, but the moment I open my Hotmail account in Firefox my Lan card stops working. At first I had no idea it was Hotmail, I tried everything from switching cables to using wifi only. When it happened on wifi I realised every time I went into Hotmail on Firefox my network card stopped functioning and I had to restart the computer. The thing is, when I use Hotmail through Microsoft Edge nothing happens and all is well with the world!!! No network card shutdown. I could read between the lines but I'm no conspiracy theorist, however, I don't think the problem is with Firefox. Is there any solution? I don't use Edge and I don't want to start.

Asked by M Donaldson 1 month ago

Answered by zeroknight 1 month ago

  • Solved

Firefox displays the same name in the title bar for different profiles

In Linux Ubuntu I created 4 different launchers for 4 profiles. Firefox opens the different profiles correctly, but the name of Profile 4 is displayed in the title bar f… (read more)

In Linux Ubuntu I created 4 different launchers for 4 profiles.

Firefox opens the different profiles correctly, but the name of Profile 4 is displayed in the title bar for all windows. This causes confusion when I'm using the different profiles. Furthermore, the icon displayed in the icon bar is also the same for the 4 profiles, although I have configured a different icon for each profile. I ask for help as I need each instance to have its own name and icon displayed correctly.

The launchers look like this:

firefox-profile1.desktop: Name= Profile 1 Exec=firefox -P profile1 --no-remote Icon=~/.local/share/icons/profile1.png

firefox-profile2.desktop Name=Profile 2 Exec=firefox -P profile2 --no-remote Icon=~/.local/share/icons/profile2.png

firefox-profile3.desktop Name=Profile 3 Exec=firefox -P profile3 --no-remote Icon=~/.local/share/icons/profile3.png

firefox-profile4.desktop Name=Profile 4 Exec=firefox -P profile4 --no-remote Icon=~/.local/share/icons/profile4.png

Asked by Alex 1 month ago

Answered by Alex 1 month ago

  • Solved

Dark mode for iCloud Notes in Firefox

Hi, I have Windows OS and use Firefox as my main browser. Firefox settings are set for dark mode and it works in google.com etc, but when I open iCloud Notes, it's full … (read more)

Hi,

I have Windows OS and use Firefox as my main browser. Firefox settings are set for dark mode and it works in google.com etc, but when I open iCloud Notes, it's full white and not in dark mode. Can someone advise how to change iCloud Notes also to dark mode? I have cleared cache etc, not helping.

Asked by Lauri 1 month ago

Answered by zeroknight 1 month ago