• Solved

Most sites will not connect due to security issues

I am running Firefox 126.0-1 on an Arch Linux system. Most websites are failing to connect for security reasons. Some sites, including google.com and nytimes.com, fail w… (read more)

I am running Firefox 126.0-1 on an Arch Linux system. Most websites are failing to connect for security reasons.

Some sites, including google.com and nytimes.com, fail with an "SEC_ERROR_UNKNOWN_ISSUER" error, and their certificates confirm that they are respectively issued by Google Trust Services LLC and DigiCert Inc.

The website archlinux.org errors with "MOZILLA_PKIX_ERROR_MITM_DETECTED", stating that "Software is Preventing Firefox From Safely Connecting to This Site", citing in particular ISRG Root X1 as the problem. The certificate confirms that it is issued by Let's Encrypt.

The website duckduckgo.com simply errors with "SEC_ERROR_PATH_LEN_CONSTRAINT_INVALID" and states "Secure Connection Failed"

I have confirmed in preferences that my proxy settings are set to "No proxy" and the problem persists across troubleshooting mode and making a new profile. I have also tried removing the cert9.db file in a given profile folder.

Asked by david.carlip 1 week ago

Answered by david.carlip 1 week ago

  • Solved

Dead keys not working only in a specific profile

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the… (read more)

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the letter itself. It can render them just fine and I can paste them from another app normally too, but actually typing them is impossible from firefox.

After trying to troubleshoot, I eventually found out a few things: - iBus is not at fault, since it works in every other app and I even restarted it, but the problem persists - This only happens in my main profile, newly created profiles don't have that problem - The problem still happens on troubleshoot mode (as long as it is my main profile) - Compose key also doesn't work (I don't want to use compose key anyway, because my keyboard has specialized dead keys, but I at least tried it)

I suspect the problem lies in a setting on about:config that's different from newly created profiles, but I have no idea which and Ctrl+F searching this site doesn't show any relevant configuration that might be the culprit.

Asked by Kazuma 1 week ago

Answered by Kazuma 1 week ago

  • Solved

Issues With Websites Loading/Re-Directing - Firefox Browser Only PC and Mac OS

When attempting to load a number of different web pages such as Quickbooks Online Apps, the page displays "Loading Apps..." with a spinning wheel, but never redirects to … (read more)

When attempting to load a number of different web pages such as Quickbooks Online Apps, the page displays "Loading Apps..." with a spinning wheel, but never redirects to the Apps page; the site hangs forever. On other browsers there are no issues; it eventually switches to the correct page. In Firefox Browser I have tried adding exceptions in Settings --> Privacy & Security --> Manage Exceptions. No change. Thoughts?

Asked by jransom18 3 weeks ago

Answered by jransom18 2 weeks ago

  • Solved

New tab requires a click into search bar to type

Hello, When i create a new tab (cntrl + T) I can no longer just start typing and have that be a google search. Now I need to manually click in the search bar. Is there a … (read more)

Hello, When i create a new tab (cntrl + T) I can no longer just start typing and have that be a google search. Now I need to manually click in the search bar. Is there a way to enable it so creating a new tab automatically puts the text into the search bar field?

Not sure why this stopped working, maybe a recent update. Thanks for your help.

Asked by Evan Griffith 1 month ago

Answered by jscher2000 - Support Volunteer 1 month ago

  • Solved

Corrupted PDF Downloads from Intranet sites after 125.0.1 Update

Prior to update 125.0.1 corporate intranet users could download PDF files from our Line of Business applications / Webpages. Today after the latest update the PDF files … (read more)

Prior to update 125.0.1 corporate intranet users could download PDF files from our Line of Business applications / Webpages. Today after the latest update the PDF files download but are corrupted. The site was added to the trusted webpage without improvement.

Adobe Acrobat Reader could not open ********.pdf because it is either not a supported file or because the file has been damaged

Asked by Jeff@work 1 month ago

Answered by NoahSUMO 1 month ago

  • Solved

Unable to interact with many of the buttons on the roblox website

Nothing happens when I press the play, like, dislike, notifications, favorite, or join server buttons. On top of this, when I try to open the catalogue it's just a grey s… (read more)

Nothing happens when I press the play, like, dislike, notifications, favorite, or join server buttons. On top of this, when I try to open the catalogue it's just a grey screen with nothing in it. In the attached GIF I am clicking rapidly. I don't believe this is an issue with roblox itself, as when I open chrome everything works perfectly. The only extensions I am using for the site are RoPro and BTRoblox. I have tried to turn the extensions off and have even uninstalled them, however the problem was still not fixed.

Asked by ushaaaaa 1 month ago

Answered by zeroknight 1 month ago

  • Solved

Fifefox does not save a new payment method, clicking on save does nothing

Hi, it seems that my Firefox browser does not want to save a new payment method. I'm trying to access "Settings -> Privacy & Security -> Autofill" and then clic… (read more)

Hi, it seems that my Firefox browser does not want to save a new payment method. I'm trying to access "Settings -> Privacy & Security -> Autofill" and then click on "Saved payment methods", which opens a dialog with the existing payment methods and options to remove/add/edit. I'm clicking on Add, filling-in the card details and then clicking Save, nothing happens....

I previously had a working saved payment method, but it stopped working (I think more than 6 months ago). I tried to re-enable the credit cards by setting the following configs on about:config page:

- extensions.formautofill.creditCards.available: true
- extensions.formautofill.creditCards.supportedCountries: '...,RO' -> (I was adding my country to the existing list)

After the browser restart with those new settings when I'm on a payment page, clicking on a credit card field will show the saved credit card but if I click on it, it will not fill the details. And also trying to save a new card, manually as described previously in this message, or by the automatically prompt to save a new card after a successful payment was done. Both methods failed on me but with no error (I cannot see the saved payment on the list).

I tried removing the existing saved card, it worked removing it, but the add is still not working.

I also tried restarting in save mode, launching Firefox in a separate profile and added my country on the creditCards config for supportedCountries to show the "Saved payment methods" button on new profile, and it did not change anything.

I'm thinking there is a missing permission somewhere on the disk but I don't know where is the payment data stored on disk.

I would really appreciate any help on this.

PS: Check the attached pic to see the payment add and clicking the save button does nothing (also there are no validation errors). And the other: FF version, OS, troubleshooting info.

Asked by Mike S 3 days ago

Answered by Mike S 3 days ago

  • Locked

Unable to update Firefox browser

I have Windows 11 and the Firefox 124.0.2 browser. I cannot update to the latest version of Firefox. I receive an error message "Failed to update". I've uninstalled an… (read more)

I have Windows 11 and the Firefox 124.0.2 browser. I cannot update to the latest version of Firefox. I receive an error message "Failed to update". I've uninstalled and reinstalled the browser, ran the install utility selecting update, nothing seems to work. Please help

Duplicate question, please continue in your 2nd thread: /questions/1445013

Asked by rpm3110 1 month ago

  • Solved

Change in Tab Behavior

It seems firefox has changed the behavior of tabs. When I go to open a closed tab, I see a list of all the tabs that have been closed from every window. I want to restore… (read more)

It seems firefox has changed the behavior of tabs. When I go to open a closed tab, I see a list of all the tabs that have been closed from every window. I want to restore the previous behavior where "recently closed tabs" only shows the tabs that were closed in the current window. I saw some about:config settings, but I'm not sure what they do and I don't want to end up losing the tab history all together.

Thanks

Asked by sugarcookie 5 days ago

Answered by cor-el 5 days ago

  • Solved

How do I hide the top menu bar in Fullscreen view in Mac OS 14.4.1 on MacBook Air?

When I'm in full screen mode, The Apple, "Firefox" "File" "Edit" "View" "History" "Bookmarks" "Tools" etc menu bar shows up at the top and won't disappear. On my iMac Pro… (read more)

When I'm in full screen mode, The Apple, "Firefox" "File" "Edit" "View" "History" "Bookmarks" "Tools" etc menu bar shows up at the top and won't disappear. On my iMac Pro, it doesn't show up. i.e. Off.

I can't figure out what is the setting to make sure it does not appear. I went digging everywhere and can't figure it out. If you could tell me what config, etc I'm missing I'd appreciate it.

Screen shot attached to show which menu bar I mean.

My firefox is up to date: 126.0 (64-bit)

Asked by Kim Yoonmi 김윤미 1 week ago

Answered by cor-el 1 week ago

  • Solved

The new apostrophe quicksearch-function is a problem for me

Hello There seems to be a new function that opens a quick search window when I press the apostrophe key. This function is active on many websites, and I am using Firefo… (read more)

Hello

There seems to be a new function that opens a quick search window when I press the apostrophe key. This function is active on many websites, and I am using Firefox 125.0.3 on a Macbook Air.

This new function makes it very difficult for me to practice touch typing in Firefox, and I would like to turn this function of.

Best regards Max Andersson

Asked by Max Andersson 1 week ago

Answered by TyDraniu 1 week ago

  • Solved

WP Site on Firefox continues to display recovery mode message in error

Hello, I run a WP elearning site (cd-dojo.com) and I prefer to use Firefox for everything. Recently I added a plugin and experienced an error and WP went into recovery … (read more)

Hello,

I run a WP elearning site (cd-dojo.com) and I prefer to use Firefox for everything.

Recently I added a plugin and experienced an error and WP went into recovery mode - displaying a message and an exit recovery mode button.

I have since resolved the error, but was perplexed because I could click the exit button but the messaging was persistent. I did everything I could think of - including the recommendations of tech support - until I was ready to reinstall a backup. Then I thought maybe it's a browser issue, so I logged in as admin in Safari and the message is gone. See screenshots below.

Since then I have tried everything I can to remedy with your support information including restarting the computer, clearing the cookies and cache, restarting in troubleshoot mode, and reinstalling firefox. Nothing has resulted in any resolution.

So, I'm presenting this to you. I can continue to work on the site using other browsers but I prefer to use Firefox. Can you help?

Asked by David Lambert 1 month ago

Answered by jscher2000 - Support Volunteer 1 month ago

  • Solved

how to remove the "how to set your home page" tab that opens every time

I use google as my default firefox home page on my HP laptop. recently a second tab opens at the same time. "how to set the home page" --I've tried closing it and resta… (read more)

I use google as my default firefox home page on my HP laptop. recently a second tab opens at the same time. "how to set the home page" --I've tried closing it and restarting the laptop, but it continues to pop up every time I open firefox as a 2nd tab. I am/was happy with my homepage opening to google. How can I get rid of this second tab. thanks

Asked by mmzz02468 3 weeks ago

Answered by cor-el 3 weeks ago

  • Solved

Missing Window?

Hey there, I had two windows in firefox open, one of which had a lot of tabs. I was using firefox on my surface pro, and then got up to get a snack. I came back, and the … (read more)

Hey there, I had two windows in firefox open, one of which had a lot of tabs. I was using firefox on my surface pro, and then got up to get a snack. I came back, and the window, which I had been using for some time, was gone. The other window was still open, and firefox had not been closed. I thought I would just open it up by restoring recently closed window, but it was gone. I routinely clear my history, but even tabs that I just had open 5 minutes ago are missing from my history, like I never opened them in the first place. What is going on?

Asked by Carina Elliott 2 weeks ago

Answered by jscher2000 - Support Volunteer 2 weeks ago

  • Solved

Can no longer login to webmail on firefox, but I can login using MS Edge.

I can no longer login to my webmail account using firefox, but I CAN login using MS Edge. I obtained a new ISP and set up a new email account. I was able to access the we… (read more)

I can no longer login to my webmail account using firefox, but I CAN login using MS Edge. I obtained a new ISP and set up a new email account. I was able to access the webmail account for about a month with Firefox. Then a few days a age, it just stopped: When entering valid credentials, the login page just refreshes (without errors) and doesn't continue to the webmail inbox any longer. So I thought I'd try a different browser and I used MS Edge. The valid credentials get me into the webmail inbox using Edge, but no longer works in Firefox. Any ideas what happened?

Asked by rg.powers 3 weeks ago

Answered by rg.powers 3 weeks ago