Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get an empty toolbar for buttons to disappear? Link to picture in description.

more options

Chosen solution

It looks like you somehow moved the location bar onto the tabs toolbar, which left you with an empty navigation toolbar. If you've installed the Classic Theme Restorer add-on,

  1. Open the Add-ons Manager (Ctrl+Shift+A; Mac: Command+Shift+A), then the Extensions category.
  2. Next to Classic Theme Restorer, click the Options button.
  3. On the Main tab, check "Hide navigation toolbar".

If you used some other method instead, put the following style in the userChrome.css file and restart Firefox. You can use the Stylish add-on instead, if you have it installed.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* The above line should appear only once in the file */

#nav-bar { display: none !important; }

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

It looks like you somehow moved the location bar onto the tabs toolbar, which left you with an empty navigation toolbar. If you've installed the Classic Theme Restorer add-on,

  1. Open the Add-ons Manager (Ctrl+Shift+A; Mac: Command+Shift+A), then the Extensions category.
  2. Next to Classic Theme Restorer, click the Options button.
  3. On the Main tab, check "Hide navigation toolbar".

If you used some other method instead, put the following style in the userChrome.css file and restart Firefox. You can use the Stylish add-on instead, if you have it installed.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* The above line should appear only once in the file */

#nav-bar { display: none !important; }