X
Tap here to go to the mobile version of the site.

Support Forum

sites like yahoo, google, facebook show https and the padlock, but sites like amazon, ebay where I need to input my credit card details show the gray globe?

Posted

I've recently noticed that some sites like yahoo, google, facebook, bing still show the https and the padlock which indicates a secure connection/site. However, sites like amazon, ebay where I need to input personal and financial info shows the gray globe, which I understand is not secure. How do I fix this? I've read related posts about this, but none of the suggestions solve my problem. Thanks!

I've recently noticed that some sites like yahoo, google, facebook, bing still show the https and the padlock which indicates a secure connection/site. However, sites like amazon, ebay where I need to input personal and financial info shows the gray globe, which I understand is not secure. How do I fix this? I've read related posts about this, but none of the suggestions solve my problem. Thanks!

Chosen solution

Hi lisa14, the gray globe is correct for HTTP, because HTTP is not secure. You should only see a padlock for HTTPS pages.

For Amazon, I do think they flip back to HTTP on product pages, and only use a secure connection on payment and account pages.

I don't know about eBay, sorry.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • 5.1.30214.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • NPWLPG
  • Office Live Update v1.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

This is going to sound old school, but try editing the address from http:// to https:// and then press Enter to reload the page as a secure page.

To make that easier, you can switch Firefox back to always showing http:// in the address bar. That's a hidden setting so:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste trim and pause while the list is filtered.

(3) Double-click the browser.urlbar.trimURLs preference to switch it from true to false.

Your work is done here.


There are extensions such as HTTPS Everywhere that can handle this for you, but they can cause problems on some sites not designed for a secure connection, so if you can handle the manual method, that probably will be the least troublesome.

This is going to sound old school, but try editing the address from http:// to http'''s''':// and then press Enter to reload the page as a secure page. To make that easier, you can switch Firefox back to always showing http:// in the address bar. That's a hidden setting so: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''trim''' and pause while the list is filtered. (3) Double-click the '''browser.urlbar.trimURLs''' preference to switch it from true to false. Your work is done here. ---- There are extensions such as HTTPS Everywhere that can handle this for you, but they can cause problems on some sites not designed for a secure connection, so if you can handle the manual method, that probably will be the least troublesome.

Question owner

Thanks for your suggestions. I tried editing from http:// to https:// and then press Enter to reload the page as a secure page, but it was unsuccessful, the gray globe is still there (not padlock) nor did it show the http or https. Also, what I noticed is that when I go into amazon, ebay, and a few other sites, it does not even show http://.

I did not notice this problem until a week or two ago. I always saw the padlock and https:// on all the sites I went into...

any other suggestions or thoughts?

Thanks for your suggestions. I tried editing from http:// to https:// and then press Enter to reload the page as a secure page, but it was unsuccessful, the gray globe is still there (not padlock) nor did it show the http or https. Also, what I noticed is that when I go into amazon, ebay, and a few other sites, it does not even show http://. I did not notice this problem until a week or two ago. I always saw the padlock and https:// on all the sites I went into... any other suggestions or thoughts?
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

So strange... In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

So strange... In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled ''(Flash and other plugins still run)'' In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
cor-el
  • Top 10 Contributor
  • Moderator
17575 solutions 158975 answers

Firefox wouldn't hide the https protocol, only the http protocol is hidden by default unless the above mentioned browser.urlbar.trimURLs pref is false.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps in case your security software is causing this issue.

Firefox wouldn't hide the https protocol, only the http protocol is hidden by default unless the above mentioned browser.urlbar.trimURLs pref is false. Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps in case your security software is causing this issue. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Question owner

restarted with add-on disabled, no change... rebooted the computer in safe mode, no change...

restarted with add-on disabled, no change... rebooted the computer in safe mode, no change...
user669794 59 solutions 672 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back to us! Thank you.
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Helpful Reply

Amazon seems to prefer HTTP for product pages, but the address definitely should switch to HTTPS and show a padlock when you need to log in. They always ask me for my password to check out or access historical information. (I do not use Firefox's password manager or any other automated password filler.)

If you try this link, does the page switch back to HTTP?

https://www.amazon.com/gp/css/order-history/

That would be very troubling. I would suspect a hijacker. If it's not an extension, you could check the following:

Connection Settings

By default, Firefox will connect using IE's settings, which I think are the same as Windows' settings. Please check both of the following:

(A) Firefox

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default is "Use system proxy settings" but try "No proxy"

(B) Windows

Either in IE or the Windows Control Panel, call up the Internet Options dialog. On the Connections tab, click LAN Settings. If anything is checked here, make a note of it, then try unchecking everything.

Any difference?

Amazon seems to prefer HTTP for product pages, but the address definitely should switch to HTTPS and show a padlock when you need to log in. They always ask me for my password to check out or access historical information. (I do not use Firefox's password manager or any other automated password filler.) If you try this link, does the page switch back to HTTP? https://www.amazon.com/gp/css/order-history/ That would be very troubling. I would suspect a hijacker. If it's not an extension, you could check the following: * Firefox connection/proxy setting (see below) * Possible malware ([[Troubleshoot Firefox issues caused by malware]]) * DNS settings in Windows or your wireless router or your broadband modem '''Connection Settings''' By default, Firefox will connect using IE's settings, which I think are the same as Windows' settings. Please check both of the following: (A) Firefox orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button The default is "Use system proxy settings" but try "No proxy" (B) Windows Either in IE or the Windows Control Panel, call up the Internet Options dialog. On the Connections tab, click LAN Settings. If anything is checked here, make a note of it, then try unchecking everything. Any difference?

Question owner

did as you suggested by clearing the cache and cookies, but no changes. I generall have it set to never save history, including the cashe and cookies

did as you suggested by clearing the cache and cookies, but no changes. I generall have it set to never save history, including the cashe and cookies

Question owner

cleared cashe and cookies, no change.

I cut and pasted https://www.amazon.com/gp/css/order-history/ and it DID show the gray padlock and https://, so what does this mean? Does it mean someone hijacked my computer?

Should I continue to check the following? •Firefox connection/proxy setting (see below) •Possible malware (Troubleshoot Firefox issues caused by malware) •DNS settings in Windows or your wireless router or your broadband modem

cleared cashe and cookies, no change. I cut and pasted https://www.amazon.com/gp/css/order-history/ and it DID show the gray padlock and https://, so what does this mean? Does it mean someone hijacked my computer? Should I continue to check the following? •Firefox connection/proxy setting (see below) •Possible malware (Troubleshoot Firefox issues caused by malware) •DNS settings in Windows or your wireless router or your broadband modem

Question owner

On IE, I always see http:// when I go into amazon, but not in Firefox (this just started recently after Firefox downloaded updates). But you are right, when I click 'sign in' to my Amazon account, it does show https://, and the gray padlock shows up. But while I am surfing the contents on Amazon, I don't see the http on firefox's brower, but do see it on IE.

I changed the proxy setting to 'no proxy,' but no change in showing the padlock and the http or https in Amazon, e-bay homepage.

In the past, I recall always seeing the gray padlock and always see https not just http

I scan my computer daily with Microsoft essentials, and no viruses have shown up....

On IE, I always see http:// when I go into amazon, but not in Firefox (this just started recently after Firefox downloaded updates). But you are right, when I click 'sign in' to my Amazon account, it does show https://, and the gray padlock shows up. But while I am surfing the contents on Amazon, I don't see the http on firefox's brower, but do see it on IE. I changed the proxy setting to 'no proxy,' but no change in showing the padlock and the http or https in Amazon, e-bay homepage. In the past, I recall always seeing the gray padlock and always see https not just http I scan my computer daily with Microsoft essentials, and no viruses have shown up....
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Yes, the http (but not https) is hidden by Firefox to declutter the address area. You can make it display using the steps in my first reply. Probably it wasn't clear that's what those steps were for: https://support.mozilla.org/questions/996242#answer-561347

If it works for your current session but reverts back to not showing http after you exit and start Firefox up again, you may want to check out this article: How to fix preferences that won't save. Another common reason for this problem is a feature of your security/utility software (such as Advanced SystemCare's Surfing Protection feature) that protects you from unwanted browser changes. Unfortunately, this feature often blocks you from making changes you want to make.

Yes, the http (but not https) is hidden by Firefox to declutter the address area. You can make it display using the steps in my first reply. Probably it wasn't clear that's what those steps were for: https://support.mozilla.org/questions/996242#answer-561347 If it works for your current session but reverts back to not showing http after you exit and start Firefox up again, you may want to check out this article: [[How to fix preferences that won't save]]. Another common reason for this problem is a feature of your security/utility software (such as Advanced SystemCare's Surfing Protection feature) that protects you from unwanted browser changes. Unfortunately, this feature often blocks you from making changes you want to make.

Modified by jscher2000

Question owner

okay, I changed the trim URLs from true to false, and it's showing successfully show http. When I manually tried changing from http to https, it automatically goes back to http. But this mainly has to do with Amazon or ebay's own settings?

But there is still a gray globe rather than a padlock, why?

okay, I changed the trim URLs from true to false, and it's showing successfully show http. When I manually tried changing from http to https, it automatically goes back to http. But this mainly has to do with Amazon or ebay's own settings? But there is still a gray globe rather than a padlock, why?
jscher2000
  • Top 10 Contributor
8792 solutions 71899 answers

Chosen Solution

Hi lisa14, the gray globe is correct for HTTP, because HTTP is not secure. You should only see a padlock for HTTPS pages.

For Amazon, I do think they flip back to HTTP on product pages, and only use a secure connection on payment and account pages.

I don't know about eBay, sorry.

Hi lisa14, the gray globe is correct for HTTP, because HTTP is not secure. You should only see a padlock for HTTPS pages. For Amazon, I do think they flip back to HTTP on product pages, and only use a secure connection on payment and account pages. I don't know about eBay, sorry.

Helpful Reply

Thanks so much for all your help!!!

Thanks so much for all your help!!!