Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

flashblock won't work

  • 5 replies
  • 5 have this problem
  • 178 views
  • Last reply by Sether82

more options

A few days ago I noticed that flashblock no longer worked, so I search on google for a solution. I have tried disabling then uninstalling then restarting firefox then reinstalling flashblock and videos still play without clicking on the flash icon. I have firefox 28 and flashblock 1.5.17 if that makes a difference. I have added some new add-ons and don't know if any of them are disabling flashblock or what. Also Last week I tried to get a song from a site and a new window popped up and 30 download tabs in it don't know if this could have caused the problem. Any help would be much appreciated. Thanks

All Replies (5)

more options

You have a lot of video-related extensions. It wouldn't surprise me if some combination of them might create a conflict. Maybe try disabling all but the most essential ones on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then turn off everything you can live without for a day and see whether that resolves it.

(Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.)

If not, you might post the question on Flashblock's support site in case it is a known conflict with a particular extension.

more options

Regarding the window with 30 tabs, in some cases this can be caused by instructing Firefox to use itself to handle a certain kind of file in the download dialog (Open/Save/Cancel) dialog that it can't actually handle. See: Firefox repeatedly opens empty tabs or windows after you click on a link.

But if it's not repeatable, and the tabs weren't blank, maybe it's not a setting and was just a particularly annoying website.

more options

I just tried what you have suggested. I left on video related add-on going and went to youtube to try it and flashblock still isn't working.

more options

I don't use Flashblock, so I don't know what might cause it to fail.

Have you considered using Firefox's click-to-play option for Flash? This will delay Flash from starting on a page until you approve it, which will help distinguish Flash-generated issues from page load and layout issues.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

Once you approve Flash, all Flash players on the page will reload. If you want player-by-player control, there is a different extension designed to work with Firefox's click-to-play feature: https://addons.mozilla.org/firefox/addon/click-to-play-per-element/

more options

Thank you for your help. I will try the click-to-play option and see if that works.