X
Tap here to go to the mobile version of the site.

Support Forum

Is the website myfitnesspal no longer compatible with you? It won't allow me to log in but works with ALL other browsers. I've done troubleshoot. Didn't work.

Posted

Yesterday I had problems with the website Myfitnesspal.com. I have a tab set to automatically open when I start the browser every day. I could not log any information into the site, so I tried a log off and log on. It won't let me log on to the site. I contacted, myfitnesspal and we worked through many trouble shooting steps. I also tried all the troubleshooting steps from your site. I even did a complete shutdown and start up of my computer. Nothing has fixed this problem. I had the same issue with a couple of store I like to browse. The store site are finally working after more than 6 months of frustration. Myfitnesspal works on ALL other browsers. So with everything that has been tried and done, the problem seems to be on your end somewhere. I am running Windows 7 Professional, 32 bit.

I really hope that this can be fixed because the website displays best on your browser. Should you have any questions, please don't hesitate to email me.

Thank you for anything you can do to fix this and for your time.

Yesterday I had problems with the website Myfitnesspal.com. I have a tab set to automatically open when I start the browser every day. I could not log any information into the site, so I tried a log off and log on. It won't let me log on to the site. I contacted, myfitnesspal and we worked through many trouble shooting steps. I also tried all the troubleshooting steps from your site. I even did a complete shutdown and start up of my computer. Nothing has fixed this problem. I had the same issue with a couple of store I like to browse. The store site are finally working after more than 6 months of frustration. Myfitnesspal works on ALL other browsers. So with everything that has been tried and done, the problem seems to be on your end somewhere. I am running Windows 7 Professional, 32 bit. I really hope that this can be fixed because the website displays best on your browser. Should you have any questions, please don't hesitate to email me. Thank you for anything you can do to fix this and for your time.

Chosen solution

Hello.

I used to have this problem with only Firefox for quite some time. I was beyond frustrated. MyFitnessPal is 100% compatible with Firefox, however, a certain [type of] extension can cause major headaches. I hope this fix helps you too.

Do you by chance have the https-everywhere extension installed? It's a great add-on and I highly recommend using it, however, unless you "disable" it's usage with MyFitnessPal, you won't be able to login to your account, add food, update weight, see graphs, etc.

So don't panic. Your issue is likely to be what I had as well. I just went into the https-everywhere extension and where it said "MyFitnessPal" with a checkmark (saying it's ACTIVE for that site), I simply clicked it to disable the add-on for that one site.

Simple and it works instantly. I hope it does for you too! If you don't have that add-on then it is still likely related to something similar so best of luck to you!

D

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • 5.1.30214.0
  • VLC media player Web Plugin 2.1.3
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • plugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Coupons, Inc. Coupon Printer Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • AmazonMP3DownloaderPlugin 1.0.15
  • Motive Plugin for Mozilla Browsers
  • Provides additional functionality on Facebook. See our web site for details.
  • Logitech Harmony Remote Plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

kobe 441 solutions 5048 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back to us! Thank you.

Question owner

I did all the clearing yesterday and again this morning just in case. Did not fix the problem.

I did all the clearing yesterday and again this morning just in case. Did not fix the problem.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Helpful Reply

Sometimes, sites divide their content and login logic over multiple servers. In that case, the sites may not recognize that you have logged in if you block third party cookies. Can you check your cookie settings, as described in this article: Websites say cookies are blocked - Unblock them.


During your earlier troubleshooting, did you try the site in Firefox's Safe Mode to rule out an extension as the potential culprit? More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Sometimes, sites divide their content and login logic over multiple servers. In that case, the sites may not recognize that you have logged in if you block third party cookies. Can you check your cookie settings, as described in this article: [[Websites say cookies are blocked - Unblock them]]. ---- During your earlier troubleshooting, did you try the site in Firefox's Safe Mode to rule out an extension as the potential culprit? More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled ''(Flash and other plugins still run)'' In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?

Question owner

Jscher2000

Thank you! Works in safe mode. I hope that when I add back in a couple of my menu bar buttons that I use on a frequent basis that it doesn't mess up the site again. I have been using myfitnesspal for over a year now and this is the first time I've had a problem with it.

I really appreciate the help and the response.

Thanks again, Suekuras

Jscher2000 Thank you! Works in safe mode. I hope that when I add back in a couple of my menu bar buttons that I use on a frequent basis that it doesn't mess up the site again. I have been using myfitnesspal for over a year now and this is the first time I've had a problem with it. I really appreciate the help and the response. Thanks again, Suekuras
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Life in Safe Mode is too limiting to be a full time solution, so the next step would be to consider which add-on might be affecting the site. What I suggest is two steps:

(1) Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then disable anything you don't really need for the next 72 hours.

Usually a link will appear above a disabled extension to restart Firefox. You can complete your work on the add-ons page and click the link as the last step.

(2) (If the problem continues) Try to make a site exception

One of your other extensions may be altering information Firefox normally sends to the site, for example, for privacy reasons. See whether you can make a site exception using its Options button on the Add-ons page.

Life in Safe Mode is too limiting to be a full time solution, so the next step would be to consider which add-on might be affecting the site. What I suggest is two steps: (1) Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions. Then disable anything you don't really need for the next 72 hours. Usually a link will appear above a disabled extension to restart Firefox. You can complete your work on the add-ons page and click the link as the last step. (2) (If the problem continues) Try to make a site exception One of your other extensions may be altering information Firefox normally sends to the site, for example, for privacy reasons. See whether you can make a site exception using its Options button on the Add-ons page.

Question owner

I have disabled the add-ons. Did a restart and am right back at not being able to do anything. I'll give it some time to see if it helps before enabling things again. This is a nightmare.

Thanks again.

I have disabled the add-ons. Did a restart and am right back at not being able to do anything. I'll give it some time to see if it helps before enabling things again. This is a nightmare. Thanks again.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Hi suekuras, are any extensions still enabled now? You can extract a list of enabled and disabled extensions from the Troubleshooting Information page. Either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the upper left corner of the page, click "Copy text to clipboard". Then you can paste into a reply. To keep it short, you can remove the part starting with "Important Modified Extensions" before posting.

Hi suekuras, are any extensions still enabled now? You can extract a list of enabled and disabled extensions from the Troubleshooting Information page. Either: * Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the upper left corner of the page, click "Copy text to clipboard". Then you can paste into a reply. To keep it short, you can remove the part starting with "Important Modified Extensions" before posting.

Question owner

Hi again.

Everything has been disabled. I hope this is the info your looking for.


Application Basics


Name: Firefox Version: 28.0 User Agent: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0

Crash Reports for the Last 3 Days


All Crash Reports (including 1 pending crash in the given time range)

Extensions


Name: Adblock Plus Version: 2.5.1 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Add to Amazon Wish List Button Version: 1.10 Enabled: false ID: amznUWL2@amazon.com

Name: E-Web Print Version: 1.19.00 Enabled: false ID: e-webprint@epson.com

Name: HTTPS-Everywhere Version: 3.5 Enabled: false ID: https-everywhere@eff.org

Name: iWinGames Plugin Version: 1.0 Enabled: false ID: {98e34367-8df7-42b4-837b-20b892ff0847}

Name: LastPass Version: 3.1.1 Enabled: false ID: support@lastpass.com

Name: Personas Plus Version: 1.7.3 Enabled: false ID: personas@christopher.beard

Name: StumbleUpon Version: 4.16 Enabled: false ID: {AE93811A-5C9A-4d34-8462-F7B864FC4696}


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Hi again. Everything has been disabled. I hope this is the info your looking for. Application Basics ------------------ Name: Firefox Version: 28.0 User Agent: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0 Crash Reports for the Last 3 Days --------------------------------- All Crash Reports (including 1 pending crash in the given time range) Extensions ---------- Name: Adblock Plus Version: 2.5.1 Enabled: false ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Name: Add to Amazon Wish List Button Version: 1.10 Enabled: false ID: amznUWL2@amazon.com Name: E-Web Print Version: 1.19.00 Enabled: false ID: e-webprint@epson.com Name: HTTPS-Everywhere Version: 3.5 Enabled: false ID: https-everywhere@eff.org Name: iWinGames Plugin Version: 1.0 Enabled: false ID: {98e34367-8df7-42b4-837b-20b892ff0847} Name: LastPass Version: 3.1.1 Enabled: false ID: support@lastpass.com Name: Personas Plus Version: 1.7.3 Enabled: false ID: personas@christopher.beard Name: StumbleUpon Version: 4.16 Enabled: false ID: {AE93811A-5C9A-4d34-8462-F7B864FC4696} JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

I think you can go ahead and re-enable Adblock Plus; that shouldn't interfere with logging in.

A couple of other differences between Firefox's Safe Mode and normal mode are:

(1) Hardware acceleration of graphics is disabled

While it's hard to see why that should make any difference, you can manually disable it in normal mode in the Options dialog:

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

That will take effect the next time you exit and start up Firefox again.

(2) JavaScript compilers are disabled

These compilers help improve performance of sites that use a lot of scripts (for example, Gmail), but sometimes run into trouble. I'll have to look up how to disable those in normal mode if you want to test that.

I think you can go ahead and re-enable Adblock Plus; that shouldn't interfere with logging in. A couple of other differences between Firefox's Safe Mode and normal mode are: (1) Hardware acceleration of graphics is disabled While it's hard to see why that should make any difference, you can manually disable it in normal mode in the Options dialog: orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" That will take effect the next time you exit and start up Firefox again. (2) JavaScript compilers are disabled These compilers help improve performance of sites that use a lot of scripts (for example, Gmail), but sometimes run into trouble. I'll have to look up how to disable those in normal mode if you want to test that.

Question owner

jscher2000,

Your brilliant.

It's interesting that you brought up Java. I have had some issue with it. I just installed the latest version and uninstalled the old. I tried myfitnesspal again and everything worked. To think it was something as simple as an update. I have my updates set to be done automatically. Apparently, that did not. I was running an older version, the newer version never installed. From now on, I will keep Java in mind if I have any other issues. Usually, things are issue free.

Your amazing! Thank you for spending so much time with this problem for me. I really do appreciate it. Wish there was someway to repay you for your help.

I hope others appreciate the time you spend with people to resolve problems.

Suekuras

jscher2000, Your brilliant. It's interesting that you brought up Java. I have had some issue with it. I just installed the latest version and uninstalled the old. I tried myfitnesspal again and everything worked. To think it was something as simple as an update. I have my updates set to be done automatically. Apparently, that did not. I was running an older version, the newer version never installed. From now on, I will keep Java in mind if I have any other issues. Usually, things are issue free. Your amazing! Thank you for spending so much time with this problem for me. I really do appreciate it. Wish there was someway to repay you for your help. I hope others appreciate the time you spend with people to resolve problems. Suekuras
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Jefferson was talking about JavaScript and not about Java.

To avoid confusion:

Jefferson was talking about JavaScript and not about Java. *http://kb.mozillazine.org/JavaScript To avoid confusion: *http://kb.mozillazine.org/JavaScript_is_not_Java

Question owner

Thank you for clearing that up for me. The Java didn't fix the problem. Something we did helped for a bit, but, myfitnesspal is back to the same problem I had before. So I really don't know what has happened and guess I'll just use chrome for that particular site. Everything else works fine in Firefox.

Thank you for clearing that up for me. The Java didn't fix the problem. Something we did helped for a bit, but, myfitnesspal is back to the same problem I had before. So I really don't know what has happened and guess I'll just use chrome for that particular site. Everything else works fine in Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Does it still work properly when you start Firefox in Safe Mode or doesn't that work as well?

This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page).

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

You can inspect and manage the permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

You can inspect and manage the permissions for all domains on the about:permissions page.

Does it still work properly when you start Firefox in Safe Mode or doesn't that work as well? This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page). Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" You can inspect and manage the permissions for the domain in the currently selected tab via these steps: *Click the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location bar *Click "More Information" to open "Tools > Page Info" with the Security tab selected *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab You can inspect and manage the permissions for all domains on the <b>about:permissions</b> page. *https://support.mozilla.org/kb/how-do-i-manage-website-permissions

Question owner

Most of this was done this morning. I just checked the site identity button and other items after that. Everything is fine. This is frustrating and I think I may as well just use Chrome for this site. My head is aching from 2 days of trying to fix the problem. I spent all day yesterday with the myfitnesspal people doing all the same steps. This is the only site I am having issues with. I keep Chrome on the desktop only because of another site that I use on occasion has specified that certain functions will only work in Chrome. So if I have to have 2 browsers running, then that's what I'll do. I don't know what else to do and don't have the time to keep going through the same things over and over. Obviously, you guys are as stumped as I am.

Thanks for the help.

Most of this was done this morning. I just checked the site identity button and other items after that. Everything is fine. This is frustrating and I think I may as well just use Chrome for this site. My head is aching from 2 days of trying to fix the problem. I spent all day yesterday with the myfitnesspal people doing all the same steps. This is the only site I am having issues with. I keep Chrome on the desktop only because of another site that I use on occasion has specified that certain functions will only work in Chrome. So if I have to have 2 browsers running, then that's what I'll do. I don't know what else to do and don't have the time to keep going through the same things over and over. Obviously, you guys are as stumped as I am. Thanks for the help.
debiansounds 1 solutions 1 answers

Chosen Solution

Hello.

I used to have this problem with only Firefox for quite some time. I was beyond frustrated. MyFitnessPal is 100% compatible with Firefox, however, a certain [type of] extension can cause major headaches. I hope this fix helps you too.

Do you by chance have the https-everywhere extension installed? It's a great add-on and I highly recommend using it, however, unless you "disable" it's usage with MyFitnessPal, you won't be able to login to your account, add food, update weight, see graphs, etc.

So don't panic. Your issue is likely to be what I had as well. I just went into the https-everywhere extension and where it said "MyFitnessPal" with a checkmark (saying it's ACTIVE for that site), I simply clicked it to disable the add-on for that one site.

Simple and it works instantly. I hope it does for you too! If you don't have that add-on then it is still likely related to something similar so best of luck to you!

D

Hello. I used to have this problem with only Firefox for quite some time. I was beyond frustrated. MyFitnessPal is 100% compatible with Firefox, however, a certain [type of] extension can cause major headaches. I hope this fix helps you too. Do you by chance have the https-everywhere extension installed? It's a great add-on and I highly recommend using it, however, unless you "disable" it's usage with MyFitnessPal, you won't be able to login to your account, add food, update weight, see graphs, etc. So don't panic. Your issue is likely to be what I had as well. I just went into the https-everywhere extension and where it said "MyFitnessPal" with a checkmark (saying it's ACTIVE for that site), I simply clicked it to disable the add-on for that one site. Simple and it works instantly. I hope it does for you too! If you don't have that add-on then it is still likely related to something similar so best of luck to you! D

Modified by debiansounds