X
Tap here to go to the mobile version of the site.

Support Forum

Go to google.com and search for "fishersci ca", try to open first result in new tab, this opens a blank page

Posted

Go to google.com and search for "fishersci ca", try to open first result in new tab, this opens a blank page. The same thing works perfectly in other browsers like Chrome or Safari

Many Thanks.

Go to google.com and search for "fishersci ca", try to open first result in new tab, this opens a blank page. The same thing works perfectly in other browsers like Chrome or Safari Many Thanks.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0

More Information

Diego Victor 658 solutions 4175 answers

Try clear your recent history:

Check if your anti-virus are blocking Firefox to conect to this page.

Also:

Try clear your recent history: *[https://support.mozilla.org/kb/remove-recent-browsing-search-and-download-history Clear recent history] Check if your anti-virus are blocking Firefox to conect to this page. Also: *[https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in safe mode] *[https://www.mozilla.org/en-US/plugincheck/ Plugin check] *[https://www.mozilla.org/en-US/firefox/new/ Newest Firefox]
Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 solutions 10731 answers

Helpful Reply

Please update to Firefox 28 (Update Firefox to the latest release) and try again.

Please update to Firefox 28 ([[Update Firefox to the latest version]]) and try again.

Helpful Reply

I have tried this many times, doesn't work

I have tried this many times, doesn't work

Question owner

Even updated firefox, doesn't work.

Even updated firefox, doesn't work.
Diego Victor 658 solutions 4175 answers

In safe mode you can see the website?

In safe mode you can see the website?

Question owner

Tried in safe mode, private browsing, still same experience :(

Tried in safe mode, private browsing, still same experience :(

Question owner

Clear recent history

   Firefox in safe mode
   Plugin check
   Newest Firefox 
   Private browsing mode
   Cookies enabled \ disabled \ cleared
   Safe mode

I have tried all of the above options but still I am facing the same problem

Clear recent history Firefox in safe mode Plugin check Newest Firefox Private browsing mode Cookies enabled \ disabled \ cleared Safe mode I have tried all of the above options but still I am facing the same problem
Diego Victor 658 solutions 4175 answers

When i went to the site I also cant get the page but I just select the url in urlbar and press Enter and then I get the page, try in your browser!

When i went to the site I also cant get the page but I just select the url in urlbar and press Enter and then I get the page, try in your browser!
FredMcD
  • Top 10 Contributor
4266 solutions 59806 answers

I think the page address has a problem. I looked at an empty page. Then I went to the main page; https://www.fishersci.ca and it redirected me to https://www.fishersci.ca/home.do

I think the page address has a problem. I looked at an empty page. Then I went to the main page; '''https://www.fishersci.ca''' and it redirected me to '''https://www.fishersci.ca/home.do'''

Question owner

Everything works perfectly in Chrome or Safari browser, what could be wrong with Firefox

Everything works perfectly in Chrome or Safari browser, what could be wrong with Firefox
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158872 answers

This looks like a problem with the referrer.
If the link is coming from the Google search page then I get an empty page unless I block the referrer.
The link that Google uses to do a safe browsing check seems to confuse the fishersci.ca site or the server is infected and blocks users coming via Google.

Blocking JavaScript and thus disallowing Google from modifying the link works as well disabling the referrer that is send.

Note that you can see the referrer in "Tools > Page Info > General".

This looks like a problem with the referrer.<br /> If the link is coming from the Google search page then I get an empty page unless I block the referrer.<br /> The link that Google uses to do a safe browsing check seems to confuse the fishersci<i></i>.ca site or the server is infected and blocks users coming via Google. Blocking JavaScript and thus disallowing Google from modifying the link works as well disabling the referrer that is send. Note that you can see the referrer in "Tools > Page Info > General".

Modified by cor-el

Question owner

I can guarantee that server is not infected and does not block any requests coming from Google.

Actually, there are many users who are facing this issue. 99% of users are using Firefox with default settings. Will you be able to tell me precise settings on Firefox that needs tweaking. Thanks

I can guarantee that server is not infected and does not block any requests coming from Google. Actually, there are many users who are facing this issue. 99% of users are using Firefox with default settings. Will you be able to tell me precise settings on Firefox that needs tweaking. Thanks

Question owner

I have found one solution, not sure if its the right one. in about:config page, setting network.http.sendSecureXSiteReferrer to "false", works.

I am able to see the page new tab.

Still I could not find the root cause

I have found one solution, not sure if its the right one. in about:config page, setting network.http.sendSecureXSiteReferrer to "false", works. I am able to see the page new tab. Still I could not find the root cause
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158872 answers

This would still sound like an issue with the DNS server of the website or otherwise, so maybe contact the hosting company and ask them to look into this.

This would still sound like an issue with the DNS server of the website or otherwise, so maybe contact the hosting company and ask them to look into this.