Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

when I click on a site that has a very long address, Firefox will NOT load the page. Why?

  • 3 replies
  • 2 have this problem
  • 6 views
  • Last reply by wmaden

more options

Whenever I click on a link that has a very long address for it, Firefox will NOT load the page. I ALWAYS have to "copy & paste" the address into another browser for it to load up in the other browser. Why is this??

Chosen solution

Hi wmaden,

Please try to open a link from the source you are clicking while Firefox is open and running in safe mode. This disables any extensions or add-on that may be affecting this.

Sometimes the formatting of a link can follow to the browser without the full link, to test this, could you please provide an example, and where the link is created and clicked?

The response for how to open the browser in safe mode is below :-) :

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Read this answer in context 👍 2

All Replies (3)

more options

Chosen Solution

Hi wmaden,

Please try to open a link from the source you are clicking while Firefox is open and running in safe mode. This disables any extensions or add-on that may be affecting this.

Sometimes the formatting of a link can follow to the browser without the full link, to test this, could you please provide an example, and where the link is created and clicked?

The response for how to open the browser in safe mode is below :-) :

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Could you provide the URL link

more options

Ii want to thank you for your help in resolving this issue I was having. By doing as you suggested by using the safe mode process, it did work, I also noticed that it also shortened the very long address as well.