Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In Firefox (have Windows Vista), shockwave plugin keeps failing & have to restart firefox - I have latest versions of both & resetting didn't help??

  • 1 reply
  • 8 have this problem
  • 985 views
  • Last reply by AliceWyman

more options

When I got to youtube, or other sites with videos or items that use shockwave, I get a popup that says shockwave isn't working - do I want to retry or stop it. No matter which option I try, firefox remains frozen and I have to restart it. I DO have the latest version of FIREFOX AND SHOCkWAVE. I HAVE ALREADY reset Firefox and that doesn't work either. Why hasn't this been addressed? I see many, many other people have this same problem and it's been going on for months and months and months! PLEASE fix this issue.

All Replies (1)

more options

Your plugins list shows Shockwave Flash 11.9 r900

If Firefox is freezing up (not responding) on sites that use the Flash plugin, try disabling hardware acceleration in both Flash settings aand in Firefox. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Also try disabling graphics hardware acceleration in Firefox settings. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.