Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why did my old computer all of a sudden update to version 2.0.0.20, when for years this update was available and it did not update when it was relevant?

  • 5 replies
  • 1 has this problem
  • 97 views
  • Last reply by moneykube

more options

I use the old computer for one purpose and only go to my bank site... This unexpected update makes me nervous. Once it had updated Firefox told me that my system was out of date ( which I know) and that firefox would not work.... yet it does work... What is going on ? I had no problems before the update.

Chosen solution

Just because your Firefox was updated from a older 2.0.0.* version to 2.0.0.20 does not mean your system was compromised.

The Firefox 2.0.0.20 was the last security and stability update for Firefox 2.0 that worked on the older OSX 10.2.x to 10.3.x. As of Firefox 3.0.x, 3.5.x, 3.6.x the minimum was OSX 10.4.x until Firefox 4.0 was released.


As for your G4 you may be interested in http://www.floodgap.com/software/tenfourfox/ however do note that it does not use any browser Plugins as the Plugins (like Flash, Quicktime) for these old systems are old and vulnerable now.

Read this answer in context 👍 1

All Replies (5)

more options

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Ajay the OP is using Mac OSX not windows. Note that for those not aware the Firefox 3.6.28 was the last for OSX 10.4 from Mozilla.org and TenFourFox is a option to use more current version since it is a PPC Mac.

Was this on the same Mac that you got the update for 2.0 0.20 ? as what version were you using before.

more options

All my macs are too old to update... I posted the question from my G5 PPC Quad Core Tower OS 10.4.11... using Fox 3.6.28... BUT,The computer that mysteriously updated itself was an older G3 Imac running OS 10.3.9... I am reasonably sure it had Firefox 2(.Something) on it ,but I never checked what it actually was before I restarted firefox and tried the new update... I just find it odd that it would even update Firefox 2 on that computer, when I can no longer update my G4... I became worried I have been hacked somehow... yet... the only site I go to with that computer is my bank... so with the firewalls up, I can't see how a hack would be possible... Maybe just a glitch in the old version... I just hope my security has not been compromised... Thank-you for the quick responses

more options

Chosen Solution

Just because your Firefox was updated from a older 2.0.0.* version to 2.0.0.20 does not mean your system was compromised.

The Firefox 2.0.0.20 was the last security and stability update for Firefox 2.0 that worked on the older OSX 10.2.x to 10.3.x. As of Firefox 3.0.x, 3.5.x, 3.6.x the minimum was OSX 10.4.x until Firefox 4.0 was released.


As for your G4 you may be interested in http://www.floodgap.com/software/tenfourfox/ however do note that it does not use any browser Plugins as the Plugins (like Flash, Quicktime) for these old systems are old and vulnerable now.

Modified by James

more options

Thanks... will try tenfourfox