X
Tap here to go to the mobile version of the site.

Support Forum

Question unanswered about enabling JavaScript

Posted

There was a question/response about enabling/disabling JavaScript by using "about:config" Another question in the responses added another question, which I also have:

"Despite my Javascript for Firefox 23 being "enabled" ( I checked re the "about:config" steps above), some websites are still asking me to enable my Javascript to view content. "

I am now running NoScript which I know blocks JavaScript, but it was happening before I started NoScript.

I hope someone can answer that question now.

Thank you, Bernadine

There was a question/response about enabling/disabling JavaScript by using "about:config" Another question in the responses added another question, which I also have: "Despite my Javascript for Firefox 23 being "enabled" ( I checked re the "about:config" steps above), some websites are still asking me to enable my Javascript to view content. " I am now running NoScript which I know blocks JavaScript, but it was happening before I started NoScript. I hope someone can answer that question now. Thank you, Bernadine

Chosen solution

That message from website may be triggered by other add-ons or by bad script on the website that throws that message.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • VLC media player Web Plugin 2.1.0
  • 5.1.20913.0
  • Foxit Reader Plug-In For Firefox and Netscape
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

XxDrAKoNxX 0 solutions 12 answers

To answer need you to be a little clearer Bernadine.

To answer need you to be a little clearer Bernadine.
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40418 answers

Chosen Solution

That message from website may be triggered by other add-ons or by bad script on the website that throws that message.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

That message from website may be triggered by other add-ons or by bad script on the website that throws that message. '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.''
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Firefox's internal JavaScript switch has only two settings: on and off. If JavaScript works on some sites and not others, then your switch is "on" and you can run down other potential culprits.

Ed's suggestion is a great place to start. If you aren't sure about your extensions and want more specific comments, you can extract the list from the Troubleshooting page. Either:

  • Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the upper left corner, click the "Copy text to clipboard" button. When pasting into a reply, you can delete the part from Important Modified Preferences to the end.

Firefox's internal JavaScript switch has only two settings: on and off. If JavaScript works on some sites and not others, then your switch is "on" and you can run down other potential culprits. Ed's suggestion is a great place to start. If you aren't sure about your extensions and want more specific comments, you can extract the list from the Troubleshooting page. Either: * Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the upper left corner, click the "Copy text to clipboard" button. When pasting into a reply, you can delete the part from Important Modified Preferences to the end.

Question owner

Thanks for the answers. It only happen once in a while so I'll keep your answers and if/when it happens again, I will try your suggestions.

So I guess this can be closed and if/when I encounter the problem, I can try the solutions and if they don't work, I'll write again.

Thanks, Bernadine

Thanks for the answers. It only happen once in a while so I'll keep your answers and if/when it happens again, I will try your suggestions. So I guess this can be closed and if/when I encounter the problem, I can try the solutions and if they don't work, I'll write again. Thanks, Bernadine