Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Download error during Save Image As makes Firefox unresponsive

  • 1 reply
  • 3 have this problem
  • 56 views
  • Last reply by FredMcD

more options

As I too often do, after saving a web page with cmd-S, I mistakenly closed the tab while the page was still "downloading", and as usual, that created the annoying "Download Error" dialog.

(Aside: I use the Mozilla Archive Format 3.0.0 extension, but still, the page is in the cache, so go figure why this error always happens.)

This time, I had moved on to another Save activity, this time Save Image As, from the context menu, in my now-front tab, just as the error dialog appeared.

This combo resulted in having the Download Error in one dialog and the Save Image As dialog both open at the same time, and none of the dialog buttons or available controls would dismiss any of the dialogs. I could press them, I could activate the menus, but Quit was unavailable from the File menu. So Firefox wasn't frozen or unresponsive in that way, but it was stuck. I couldn't get rid of the dialogs or do anything else until they were gone.

I force closed with Activity Monitor.

I realize there was an extension involved, but it still seems like I should have been able to activate the buttons or the close X on at least one of the dialog boxes.

I don't need an answer, but I wanted to tell you about the issue. Thanks.

All Replies (1)

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.