Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Don't close tabs on exit

  • 6 replies
  • 6 have this problem
  • 2053 views
  • Last reply by borthober

more options

How to restore: Don't close tabs on exit?

Chosen solution

As odd as it may sound, when I looked in "Options" and went to the "General" category, and changed the "Show my homepage" option TO "Show my windows and tabs from last time", this somehow STOPPED all my previous open tabs from reopening. It was already set to "Show my homepage"....Don't know why I tried clicking on the third option...just to see what would happen, since it was ALREADY opening back up with all the previous tabs, but I just tried it.....and it fixed it! I don't understand why it fixed it, but it did. I just thought I'd pass it on, for what it's worth. :)

Read this answer in context 👍 0

All Replies (6)

more options

If you want the warning message to re-appear, then it can be set from 'Tools->Options' window. Under the 'Tabs' section, just select "Warn me when closing multiple tabs". If you want the tabs to be saved & re-opened the next time you open the browser, then in the same options window, in the 'General Tab', select "Show my windows and tabs from last time" for 'When Firefox starts:'.

more options

I have this problem too. I close all the tabs and close Firefox. Then when I open Firefox again all the tabs (now around 10) appear. If I go to File on Firefox and click on close Firefox they still reappear. What a nightmare - the slow my computer down. Do I need a different Browser or is there and answer to this Problem?

more options

Rebeccaspeers10, I suggest part of the answer is above here. Your problem may be in your Startup condition. Go to Options/General and look at what's in the little window under Startup. There are 3 conditions possible, Show my Homepage, Show blank page, and Show my windows and tabs from last time. Maybe yours is set to the last one. If so, choose one of the others. Hope this helps

more options

You can also check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

more options

Hi rebeccaspeer10, you posted the same comment in 3 different threads. I replied here: https://support.mozilla.org/en-US/questions/966344#answer-504910

more options

Chosen Solution

As odd as it may sound, when I looked in "Options" and went to the "General" category, and changed the "Show my homepage" option TO "Show my windows and tabs from last time", this somehow STOPPED all my previous open tabs from reopening. It was already set to "Show my homepage"....Don't know why I tried clicking on the third option...just to see what would happen, since it was ALREADY opening back up with all the previous tabs, but I just tried it.....and it fixed it! I don't understand why it fixed it, but it did. I just thought I'd pass it on, for what it's worth. :)

Modified by borthober