Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

turn off session restore permanently

  • 2 replies
  • 17 have this problem
  • 32 views
  • Last reply by cor-el

more options

I want to turn off session restore permanently. Although I have set resume_from_crash to false several times, Firefox keeps setting it back to true.

Can I ask please specifically for an answer to the question - not a list of links to web pages that just happen to mention the terms 'session restore' but don't answer the question.

All Replies (2)

more options

Do you want to prevent Firefox from storing session data at all, i.e., disable both automatic and manual restoration of the earlier session? Or do you want your choice about browser.sessionstore.resume_from_crash to actually stick?

(1) Regarding preference changes that are overridden

Check out this article, particularly the part about the possible presence of a user.js file: How to fix preferences that won't save.

If you find numerous settings being reset to default, consider whether you have any systemwide cleanup utilities such as CCleaner running which might be helping you out by doing that.

(2) Possible workaround: After a crash, view window and tab list screen instead of resuming automatically

To prevent Firefox from automatically resuming your entire previous session after a crash, you can display a screen with a list of windows/tabs to restore. This may be helpful to avoid problem pages.

(i) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(ii) In the filter box, type or paste session and pause while the list is filtered

(iii) Double-click browser.sessionstore.max_resumed_crashes and change the value from 1 to 0 (that's a zero) and click OK.

(3) Remember nothing (also disables manual restore feature)

In about:config, set these to zero:

  • browser.sessionstore.max_tabs_undo
  • browser.sessionstore.max_windows_undo
more options

Do you have a special reason why you want to disable Session Restore?

The browser.sessionstore.resume_from_crash pref shouldn't change by itself.
If that happens then something else is wrong.

When does this change happen?
When you close Firefox or after you reboot the computer or just randomly?

If you do not keep changes after a Firefox restart, see:

Also make sure that your security software isn't changing prefs or other files in the profile folder.

Which security software (firewall, anti-virus) do you have?