X
Tap here to go to the mobile version of the site.

Support Forum

Firefox keeps displaying pages the way I see them with my phone but not with Internet Explorer. I also checked Java. Phone-mode was desactivated, what happened?

Posted

I tried visiting the same pages with Internet Explorer, and they were OK. I looked a the page style, nothing wrong here. Also, JavaScript is enabled, and I don't have any applications of any kind that could block it, or at least I think so. (I installed firefox yesterday on my new computer, and only added personnas and the facebook webcam application. and I'd be surprised if I learnt that it was my wacom tablet...) I don't know if the problem comes from the connection, since I'm connected to a "limited" public internet access. but since IE is OK and the problem only started yesterday's night, then I don't see why it would be it... I updated Java to be sure, it seems to be working OK, since my shimejis are happily climbing my screen... The problem seemed to have solved itself for fanfiction.net, but youtube keeps looking strange... facebook too. I tried refreshing the pages at least 10 times and nothing. The pages looks like if they didn't load the CSS codes or something of the kind. (well, they look exactly like on my phone, what can't load CSS pages I belive) I checked all that could be checked, and I don't see anything that could have provoked this. what can I do ?

I tried visiting the same pages with Internet Explorer, and they were OK. I looked a the page style, nothing wrong here. Also, JavaScript is enabled, and I don't have any applications of any kind that could block it, or at least I think so. (I installed firefox yesterday on my new computer, and only added personnas and the facebook webcam application. and I'd be surprised if I learnt that it was my wacom tablet...) I don't know if the problem comes from the connection, since I'm connected to a "limited" public internet access. but since IE is OK and the problem only started yesterday's night, then I don't see why it would be it... I updated Java to be sure, it seems to be working OK, since my shimejis are happily climbing my screen... The problem seemed to have solved itself for fanfiction.net, but youtube keeps looking strange... facebook too. I tried refreshing the pages at least 10 times and nothing. The pages looks like if they didn't load the CSS codes or something of the kind. (well, they look exactly like on my phone, what can't load CSS pages I belive) I checked all that could be checked, and I don't see anything that could have provoked this. what can I do ?

Chosen solution

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Facebook Video Calling Plugin
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Plugin for Wacom tablets.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Wacom Dynamic Link Library

Application

  • Firefox 20.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0/WINNT/fr/

Extensions

  • Personas Plus 1.7 (personas@christopher.beard)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16384
  • driverDate: 8-1-2012
  • driverDate2:
  • driverVersion: 8.982.6.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365274372
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17671 solutions 159860 answers

Chosen Solution

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Press and hold Shift and left-click the Reload button. *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (MAC) Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences

Question owner

It seems that clearing the cache and cookies solved the problem. Thank you for your advise, it realy helped !

It seems that clearing the cache and cookies solved the problem. Thank you for your advise, it realy helped !