Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java installed but states not working at java site

  • 4 replies
  • 65 have this problem
  • Last reply by sgauria

more options

Hello, I was checking my addins/ plugins and it stated that there was an update for java so I clicked the link to update the program. After doing so and going to the java site @ it is now stating that "something is wrong. Java is not working". I did restart the computer 3 different times as well as having uninstalled and reinstalled the program - restarting firefox and pc each time and the problem is still there.

When searching for information about the problem I came across a link that stated to go to to check my java and it is stating Java enabled No or unable to detect... Java supported No or unable to detect... Java version Yes - version 1.7.0_07 Java using object and applet tag Java isn't installed or isn't working and that I also need an additional plugin (which I clicked to install - but it keeps stating that it failed and to install manually which I have also tried).

As per the link all of my plugins are up to date and the java plugin information states Java Deployment Toolkit NPRuntime Script Plug-in Library for Java(TM) Deploy

The last thing I have tried was to go to the link again and clicked to download the java Version 7 update 7 and that is now giving me a page stating "download Java for windows In order to optimize your experience and provide you with accurate messages, please enable javascript in your browser for the duration of your Java installation. If you still have the Javascript disabled please click here."

which takes me right back to the page to download the current version and install it on my pc. Just how do I get java working on my pc - it is working with Google Chrome and it was working without any problems until I clicked to update it using the link through the about:plugins link.

Any Assistance would be so very much appreciated.

All Replies (4)

more options

Sometimes you may need to close Firefox to complete installation of plugins or extensions.

If the plugincheck page does not show this:

Java (TM) Platform SE U7...

Then most likely the plugin is disabled. Can you check toward the bottom of this page:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

There is a security update available (16.0.1). You can install it using Help > About Firefox > Check for Updates.

more options

I had a similar issue and I found this page really helpful for my case:

Modified by sgauria

more options

You need to click on the plugin icon that looks like a little square Lego block, see here:

more options

I think that box only shows up if you have the latest java version installed. Otherwise, you get something else indicating that you need to upgrade, and you can get stuck in the loop described in the original post, or at least something quite like it.