Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website autocomplete WILL NOT delete.

  • 6 replies
  • 7 have this problem
  • Last reply by jscher2000

more options

Ok. So I have been reading and reading on here. There is a website that autocompeltes in my awesome bar. It will NOT GO AWAY no matter how many times I clear ALL history, delete ALL cookies, etc. There is no bookmark saved with said website. (

The moment I type the letter "a" in my awesome bat, FF suggests I have also tried the SHIFT + DELETE on my mac. It is absolutely driving me crazy. What can I do short of resetting FF?

To update, this is happening with all letters of the keyboard. For example, "w" yield even though I have not visited it in months. "C" yield

Again, please note no bookmarks or the like are saved. All history and cookies have been cleared.

Thanks in advance.

Modified by maxcap

All Replies (6)

more options

Please see screenshot below.

more options

Please try this simple answer:

1- Close all Firefox windows. Be sure there is no Firefox process in the task manager!

2- Start Firefox.

3- Type "axl" in the address bar, the appears. Hover the mouse on it and then simply press Delete on the keyboard. Do this for all subURL's of the site too.

4- Clear "all recent histories", from Firefox menu => History => Clear recent history ... .

5- Close Firefox and stop any remaining open process in the task manager.

Now if you start Firefox and type 'a' in the address bar, there should be no! Have a nice day.

more options

I don't know whether you like this new auto-fill feature but, if not, you can turn it off. (I suppose you might want to pursue the mystery even if you turn it off, but it is one options for ending the torment.)

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste autofill and pause while the list is filtered

(3) Double-click browser.urlbar.autoFill to toggle it from true to false.

more options

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

You can try to check and repair the places database with this extension:

more options

I think I have a solution. First, download the add-on SQManager. This should be included with FireFox, it is really good. Look for the file moz_hosts in the folder places.sqlite. Don't delete the file, just delete the information in the file. My file has over 3600 websites, which go back years!! I did not know they were there, but I was frustrated about not being able to get rid of them. They popped up every time I used the address bar. Clearing my history did not get rid of them. This is where they are stored!!I found that by deleting the web site from moz_hosts, it does not appear in my address bar anymore!!! I think that if I just delete all the websites in moz_hosts.... Wa-la...History Gone!!! As long as you don't delete the file, just empty it, FireFox won't know the difference. It will just add websites to it until you empty it again. Why running "clear recent history" doesn't do this, I don't know. You are doing manually what "clear recent history" is not doing. Please tell me if you see any flaw in this. I think it's the solution we've all been looking for!

more options

Hi Dsmith01, I haven't checked recently, but some of the records in other tables in the Places database may make reference to the records in the moz_hosts table. If you haven't already cleared history, manually clearing a single table might leave orphaned records somewhere else. I assume you haven't noticed a problem, but others should edit with caution. You can always make a backup of the entire places.sqlite file first.

Edit: Upon further review, it appears that other bookmark and history tables do NOT depend on the data in moz_hosts.

Modified by jscher2000