Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 12 won't open tabs; just new windows. What's up?

  • 4 replies
  • 54 have this problem
  • 863 views
  • Last reply by iiv7

more options

I just updated to the latest version FF 12. After the update I can't open tabs anymore. There isn't even a button to open a new tab. The "Open link in New Tab ..." command opens the link in a new window instead.

It doesn't seem like a configuration problem. I was just wondering if a patch or fix update will be coming out soon?

In the meantime I have to use Chrome as a backup, and it's kind of a drag. :(

Chosen solution

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Read this answer in context 👍 3

All Replies (4)

more options

go to tools--options-->tabs---mark open windows in new tab instead

more options

Sorry, that's the first thing I tried. I checked all the options in the tools panel that could have an effect on tabs. Nothing fixed it.

It's a bug in the new update. They did something or forget to put something back in the latest build that was there before.

Tabs are broken.

Could someone post a download link to version 11. I'd like to uninstall and revert to the previous version. Because this one isn't ready yet.

more options

Chosen Solution

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Safe Mode fixed it. I can open links in a new tab now, and the new tab button stays in place so I can open a blank tab.

Great!! Thank you, cor-el!!

I just started up in Safe Mode, didn't change anything. And, then quit Firefox with the menu command. Firefox button ... "Exit Firefox"

Then started Firefox normally and the tabs and tabbing were back to normal.

Thanks again!! Have a great day!!