Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fox Tabs and Add To Top Sites is not working. All my tabs have disppeared right after upgrading. Help!

  • 2 replies
  • 10 have this problem
  • 548 views
  • Last reply by cor-el

more options

I upgraded to 11.0 and clicked to open tabs, which will take me to Fox Tabs, but I was unable to click any open. When I clicked Edit, every thing disappeared. When I clicked Done, the screen stated "Saving..." and it stayed like that for more than 5 minutes. I closed that tab and again clicked Open tabs, this time it was blank. When I right click on any page and chose Add To Top Sites nothing appears on Top Sites. I have made this my Home Page and when I click home, Fox Tabs is still blank.

I upgraded to 11.0 and clicked to open tabs, which will take me to Fox Tabs, but I was unable to click any open. When I clicked Edit, every thing disappeared. When I clicked Done, the screen stated "Saving..." and it stayed like that for more than 5 minutes. I closed that tab and again clicked Open tabs, this time it was blank. When I right click on any page and chose Add To Top Sites nothing appears on Top Sites. I have made this my Home Page and when I click home, Fox Tabs is still blank.

All Replies (2)

more options

Hi,

You can try to Remove and then install FoxTab via Tools (Alt + T) > Add-ons > Extensions. You can search for FoxTab on the top right search box and install it or install it from the AMO homepage.

Support

more options