Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 9 opens new window when opening new tab on Windows 7

more options

When I load FF 9, then click on the + to open a new tab, it does so, but in the quickstart bar in Windows 7, it shows as another window of FF, although the new tab "seems" to be in the original instance of FF. Effectively, what I mean is, if I have 4 tabs open, it shows 4 Firefox windows in the taskbar.

Is there a fix for this?

Thanks and regards, Clive

Modified by cliveg29

Chosen solution

You are welcome. Please be sure to mark your question as Solved if your question was answered.

Read this answer in context 👍 0

All Replies (8)

more options

Can you Alt+Tab between them? 'Cos if you can, that's exactly what I want FF to do... and until it can, I'm sticking with FF3.6.

more options

Yes I can alt+tab between them. But I don't want new windows!...and that's not really an answer. Anyway, I've solved it...just added it to compatability mode for XP...now works as expected i.e. ONE window, and as many tabs as I want to have open.

more options

I'm assuming you are referring to Tab Previews in the Win7 Taskbar. This can be turned of rather easily.

  • Open a New Tab
    • Type about:config in the address bar

When the page loads click "I'll be careful, I Promise"

In the "Filter" bar at the top of the page type

  • browser.taskbar.previews.enable
    • Double click it to set the Value to FALSE

If you simply type "Taskbar" in the filter, this will give you ever option that pertains to the windows 7 taskbar.

Modified by iMarshmellow

more options

Running FF in Compatibility Mode is not advised.

more options

Why not compatibility mode...seems to work fine

more options

Running in compatibility mode is your choice, the instructions I post above will allow you to run FF9 normally while removing the Tab previews.

And Before you switched to "Compatibility Mode" you still only had "One Window" - The taskbar FF icon was just display previews of each Tab, not creating multiple Windows.

Modified by iMarshmellow

more options

OK...I've now installed version 10 of FF, which did the same thing. I've followed your instructions and made the change in about:config...all fine now... thank you.

more options

Chosen Solution

You are welcome. Please be sure to mark your question as Solved if your question was answered.