Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

tried to upgrade to mozilla 8.0 but won't upgrade browser

  • 5 replies
  • 17 have this problem
  • 7 views
  • Last reply by James

more options

i just installed the latest version of mozilla, 8.0, and for some reason i still get messages on websties saying i'm on an outdated browser. in fact, the version of mozilla currently installed on my desktop, which says is 8.0, looks nothing like the version i have on my laptop, which is 8.0 and for websites don't have an upgrade issue.

i go to pages like youtube, myspace etc and get these 'your browser is outdated' message. i have uninstalled and reinstalled mozilla already (i did this as well when i upgraded to 7.0 a while ago, but nothing changed).

when i click 'help' on the top toolbar and go to 'about firefox' it tells me i'm on version 8.0, but there is no way the version i'm using is beyond 2.0. in fact, some of the add-ons for mozilla will not install because it doesn't see this version of mozilla as compatible with them (those that need to be 5.0 or higher).

can someone help? i'm not sure what to do here. thanks in advance.

here's an image showing the outdated browser message versus what the 'about mozilla' part states.

http://img683.imageshack.us/img683/3502/i2mage1.jpg

Chosen solution

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16 MEGAUPLOAD 2.0

Your UserAgent string in Firefox is messed up by another program that you installed.
http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

Read this answer in context 👍 3

All Replies (5)

more options

Try the alternate and easiest way by downloading and simply run

more options

Chosen Solution

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16 MEGAUPLOAD 2.0

Your UserAgent string in Firefox is messed up by another program that you installed.
http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

Modified by the-edmeister

more options

Swarnava, read again as he has been installing Firefox 8.0.1 and you suggest he download and install it again... try not to be so quick with the automated "upgrade Firefox and try again" replies you give.

@berthyy, is your desktop using Windows 2000 or Windows XP ?. The orange Firefox button for example is enable by default on Windows Vista and newer. Just right-click a toolbar and uncheck the Menu Bar to get it.

more options

I have the same problem, but when I followed these instructions none of the items were in bold. Since I am not a programmer and didn't want to tinker without guidance I exited without changing anything. When I go to Firefox/help/about it says I am on 8.0.1 but I still keep getting that message on the home page when I open FF. If I go back to the home page during a session, however, the message is not there. Any other possibilities/suggestions?

more options

Is your homepage http://www.google.com/firefox/ ? as that is a old default homepage in Firefox that is no longer used for quite sometime now and Google has not updated it.