Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I get notifications telling me my browser is out of date when it's not, & why does it "hang" so often?

  • 4 replies
  • 3 have this problem
  • 128 views
  • Last reply by cor-el

more options

Question I am using Firefox 8.0. I have been receiving notifications on many webpages that my version of Firefox is out of date (hotmail is one example) & to please update my browser. Also, I get way too many incidents of Firefox "(not responding)". Even after disabling ALL add-ons, even the ones I consider necessary to my enjoyment of the browser. For every hour I spend on the internet 15 mins of that time is spent staring @ a black screen & waiting for it to respond again. I am finding this very frustrating & would appreciate some assistance...or a better browser.

States that I am running a version of Firefox that I am not. It says below that I am running version 3.05 but according to the "about Firefox" tab I am running version 8.0 & when I check for updates it says that Firefox is up to date.

I have tried to re-download & re-install numerous times to no avail.

All Replies (4)

more options

You may need to reset your User Agent; it is showing that you are using Firefox 3.0.5. The User Agent can sometimes be changed by something you download/install.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Modified by SafeBrowser

more options

Thanks for trying SafeBrowser, but I only had one of the useragent preferences mentioned in the article & when I right-clicked on it I could see the reset option but it was blacked out & not available for me to click. :(

more options

Which preference could you see? What value did it have? Did you click on this preference, and then right-click? Did you try it while all your plugins were disabled?

more options

This is most likely caused by the general.useragent.override pref and probably added by Fast Browser Search (FBSMTWB).

See these pages and threads about Fast Browser Search (FBSMTWB in the user agent, Help > About).