Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

AVG warns me That memory usage is very high and I should restart.

  • 9 replies
  • 46 have this problem
  • 1134 views
  • Last reply by Azur

more options

Using Win XP vers. 3 and at your suggestion I have updated Firefox to vers. 7.0.1 and I still get this message That firefox is using too much memory, 300 megs or more.

Chosen solution

Ever since I upgraded to 8.0, I started getting the AVG warning. The matter of fact is that my FF has been consuming high CPU in 7.0.1 to begin with and I have been monitoring the memory usage and I don't see much difference on the usage between my 7.0.1 and 8.0. That's why I ignore such warning since that's probably a new AVG notification which wasn't available for FF 7.0.1. But each user is different and will have different results.

Read this answer in context 👍 1

All Replies (9)

more options

please upgrade your browser to Firefox 8 and try

more options

I upgraded to Firefox 8 after your first advisory. Still doing the same thing. On my initial startup of the day Firefox takes almost a minute to come onscreen. Seems very slow compared to explorer or google.

more options

I have been getting that warning ever since I upgraded to 8.0 (it didn't happen in 7.0.1). I don't think there's anything we can do since after restarting, the warning still appears. However, it doesn't appear all the time, just one or twice a day. So I don't think that's something need to worry about too much. FYI, Mine usually uses around 600-900 but my FF still runs very smoothly. Of course, I have at least 7 or 8 tabs open and lots of add-ons as well.

more options

So, I guess your recommendation is to do nothing. Its disturbing but I guess I will let it continue for now. Thanks for trying Jack

more options

jc401moo -- You might want to look into this add-on:

http://www.browsermemory.com/current-memory-fox/


I installed it earlier today and it seems it did lower the memory usage quite a bit. You can try it to see if that helps you or not since different users might have different result. Once you install it, you have to activate it, I use the "Browser Only" option.

more options

I wouldn't advise disabling the warning, and I don't think anyone on the AVG forum thread would be doing it either but here is their own thread:

Firefox can be quickly restarted with an extension that shuts down Firefox, restarts Firefox, and returns user to where they were automatically. "Restartless Restart" for current Firefox users. Firefox users up to Firefox 3.6.* would have to use the older extension "QuickRestart"

more options

Chosen Solution

Ever since I upgraded to 8.0, I started getting the AVG warning. The matter of fact is that my FF has been consuming high CPU in 7.0.1 to begin with and I have been monitoring the memory usage and I don't see much difference on the usage between my 7.0.1 and 8.0. That's why I ignore such warning since that's probably a new AVG notification which wasn't available for FF 7.0.1. But each user is different and will have different results.

more options

jc401moo -- Just give you an update. It has been 24 hours since I installed Memory Fox and the AVG warning hasn't come up at all and my memory usage has been around 300-400 (used to be 600-900). So I did see an improvement. You can try to see if that helps you, if it doesn't, you can always uninstall it.

more options

The memoryfox website is the dodgiest non-porn site I've ever seen. I'm not installing _anything_ from there.