Search Support

Unable to access websites but IE can

  • 10 replies
  • 58 have this problem
  • 103 views
  • Last reply by d0ubi3

more options

I am unable to access any website using FF 7. I get a popup window that says "Secure Connection Failed! xml.freecause.com: 443 uses an invalid security certificate. Error code: sec_error_expired_certificate" and it won't let me close it out. I have to use CTRL/ALT/DEL to close out FF. I am even unable to access any of the FF support pages (including FF Feedback) using FF. I had to use IE to submit this. IE has no problem opening the same websites.

Chosen solution

The security certificate for the xml.freecause.com domain has expired because it was not renewed in time.

You most likely have an extension that tries to contact that server and you will have to disable that extension until the site has renewed its certificate.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 👍 0

All Replies (10)

more options

I'm having this problem too only I'm using Firefox 6.0

more options

I am having the same exact problem, also using FF 6.0.2. I can't access anything, just like OP had to use IE. :(

more options

I had this problem too...for me it was caused by theGamers Unite snagbar that I had installed. For some people it was yahoo. I found a solution here: https://support.mozilla.com/en-US/questions/879011#answer-250883 wherein I changed my computer's date to two days ago (before the certificate expired) opened up Firefox (with no issue!) and uninstalled the toolbar. I closed Firefox, updated the date back to the correct date, and opened Firefox. Seems to have worked, I haven't had the error window pop up since.

more options

But I don't have the GamersUnite snagbar. What is the issue with Yahoo?

more options

Chosen Solution

The security certificate for the xml.freecause.com domain has expired because it was not renewed in time.

You most likely have an extension that tries to contact that server and you will have to disable that extension until the site has renewed its certificate.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Thank you. That worked.

more options

You're welcome.

I think that the website has now updated their certificate (Not before: 09/25/2011 00:00:00 GMT) and it should work again.

more options

I installed Firefox 7 the picture I attached never showed up again, however I have used the 'Safe Mode' option.

more options

I think it must have updated its certificate - no problems today.

more options

youtube com / watch?v=IJHwpZPunkQ


not really applicable.

Modified by James