Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I search an item on Google Shopping, it shows prices in US dollars instead of UK sterling

  • 5 replies
  • 3 have this problem
  • 35050 views
  • Last reply by hugletank

more options

If I search for a product in Google Shopping using Firefox, the results display in US dollars. I live in the UK so want my results in UK sterling.

The problem doesnt not occur in google Chrome so it must be an issue with firefox.

Does anyone have any ideas?

Thanks in advance.

NB - For anyone else with the problem see below. I sorted the problem out myself.

Modified by hugletank

Chosen solution

You can check the order of the installed languages and make sure that en-gb is the first choice to see if that hepls.

  • Tools > Options > Content : Languages->Choose
Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

You can check the order of the installed languages and make sure that en-gb is the first choice to see if that hepls.

  • Tools > Options > Content : Languages->Choose
more options

Thanks for the reply.

Checked and that is the default language. It seems to work correctly if I choose the shopping page and then search, but if I use the right click menu "search google for something" the prices display in dollars.

So for example, if I choose the shopping page first, and then search laptops, the results display in £. If i then use the right click to search on the word laptops, the shopping results display in $, and then will display in $ for the rest of that browsing session. I have to close the browser and reopen it to get it back to £.

Pretty weird.

more options

Do you get the other language setting back if you use Clear Recent History to clear the last hour?

Is 'en-us' or another 'en' language like 'en' installed as one of the languages under the installed?
Does it help if you only leave the en-gb choice?

more options

Have tried all your suggestions and the problem is still present.

I tried firefox in Safemode and the problem is still there.

Thanks for your help so far.

more options

I seem to have sorted the problem myself.

The default right click search engine was set to Google.com. I used an add on to change the default search engine to google.co.uk and everything is working well.

Thanks for the help anyway.