Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am now getting the Diginotar problem on 2 machines running 6.02

  • 7 replies
  • 1 has this problem
  • 1 view
  • Last reply by warped1a

more options

6.02 never cleared the invalid certificate from one machine but I never had it in my other two machines. This afternoon it appeared on my second machine. Apparently 6.02 did not fix this. What do I do?

Chosen solution

I repeat, you can not delete the certificates. If they are unchecked in "Edit Trust" they are disabled and will not be used.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Read this answer in context 👍 0

All Replies (7)

more options

In Firefox Options > Advanced > Encryption > View Certificates, locate and click each DigiNotar certificate, click "Edit Trust", all 3 items should not be checked.

  • The certificates cannot be removed, but are disabled by having the 3 items under "Edit Trust" not checked.
  • Compare to some other certificates by doing the same. There are others with all 3 items not checked, some with only one or two items checked.
  • Do not change any with good knowledge and good reason to do so.

The certificates are also still in Windows, but are marked as Revoked.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser

more options

All Edit Trust for DigiNotar are unchecked but the problem just reappeared.This did not fix it.

more options

Chosen Solution

I repeat, you can not delete the certificates. If they are unchecked in "Edit Trust" they are disabled and will not be used.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

What reappeared?

more options

The invalid certificate appeared once, but after I went through all the diginotar certificates and made sure they were unchecked and then closed the certificate screen, the problem disappeared. Thanks for the help. I greatly appreciated it.

more options

Do you need to access websites that are blocked by Firefox because the certificates are issued by DigiNotar?

more options

not so far. Thanks again for your help.