Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

You have asked Firefox to connect securely to accounts.google.co.in, but we can't confirm that your connection is secure.

  • 6 replies
  • 540 have this problem
  • 11381 views
  • Last reply by aiyayo

more options

I have been receiving this message everytime i try opening my gmail....what could be the problem?? But my date and time setting is correct

All Replies (6)

more options

This Connection is Untrusted



         You have asked Firefox to connect

securely to accounts.google.com, but we can't confirm that your connection is secure.

         Normally, when you try to connect securely,

sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.


         What Should I Do?
         
           If you usually connect to

this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.




         Technical Details
more options

yeah this is the most annoying thing I have come across on the internet because I get this same window for every site I go to!!!!!!!!!!!!!!!!!


I just installed firefox 2 days ago and am about to uninstall if I cant figure out how to fix this. Gmail??????? Really I need to be warned if I am going to my email account??? I even got this same window when coming to this support.mozilla site.

WTF!!!!!!!!!!!!!!!!

more options

If there are 432 people with this problem, 21 this week, how come there are no solutions posted?

-Puzzled

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

more options

Anyone with this problem, i solved this by setting my pc´s time and date to the current location (traveled to other country), using the "Internet Time" synchronization, and then this problem was gone

more options

xplain your issue in full detail here: This is the message I got from Firefox though I don't usually have a problem: This Connection is Untrusted You have asked Firefox to connect securely to mail.google.com, but we can't confirm that your connection is secure. more:http://www.jiagouyan9.com/archives/you-have-asked-firefox-to-connect-securely-to-accounts-google-co-in.html/

Modified by aiyayo