Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

mise à jour

  • 2 replies
  • 26 have this problem
  • 394 views
  • Last reply by cor-el

more options

I work on Mac with Os X (10.2.8). Why I can upgrade Firefox 2.0.0.20 for the last version ? Thank

ch paul

All Replies (2)

more options

You cannot update to Firefox 4 or 5 because they support only Mac OS X 10.5 and above on Intel hardware (details can be found here).

Instead, you can install Firefox 3.6 by following these steps:

  1. Open the Applications folder.
  2. Drag the Firefox application to the Trash.
  3. Download and install Firefox 3.6 from here. Instructions for this step can be found here: How to download and install Firefox on Mac.
more options

If you have Mac OS X 10.3 or less then you can't update to more recent Firefox versions.

Modified by cor-el