Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I change sites in the dropdown list

  • 13 replies
  • 42 have this problem
  • 9338 views
  • Last reply by cor-el

more options

This seems like it should be the easiest thing to do in firefox but I can't figure out how to change the sites that appear in my browser dropdown list. Who/What determines which sites are in this dropdown. It's definitely not the most frequently used. I have sites in there that I've been to only once. Please advise. Thanks

Chosen solution

You're welcome.

Could you please click the Solved It button next to the post which solved the problem for you? This will help others searching for a solution to the same question.

Thanks.

Read this answer in context 👍 0

All Replies (13)

more options

The control for the "Awesome Bar" as it's known as can be accessed by clicking the orange Firefox button, go to Options | Options | Privacy.

At the bottom of the menu, you'll see "Location Bar". Choices are located in the dropdown menu.


If this answers your question, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

more options

Thanks Xircal but, maybe I should have been more descriptive. I was hoping that I could choose which sites will remain in the drop down or at least have it show the most frequently visited sites. I see very few choices in this location bar setting and when I changed from "history and bookmarks" to "history" nothing changes. I was hoping it would be more customizable.

more options

The sites shown and the order they are shown is a complex algorithm. You can read the following, but I advise staying away from the configuration settings if you do not have time to experiment over and over and over. This was written some time ago and may have changed a little. Some details here (read "Frecency (misspelled) Calculation" and "Configuration"): https://wiki.mozilla.org/Firefox/Namoroka/Improved_form_history#Frecency_Calculation


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You need to update some plug-ins:

more options

Wow is it just me or doesn't this seem like something that should've been a no brainer- add the sites YOU prefer to your drop down list. As I said earlier, I have a few that I've only visited once. One is not even a site. It was a typo. But it remains in my drop down "Not so Awesome Bar"

Modified by vanderloo

more options

There's nothing to prevent you from deleting them manually. Simply right click them and choose "Delete" from the menu.

To delete from the Awesome bar, select a link and then hit the Delete key.

You can also decrease the number shown as follows.

  1. In the location bar where you normally type in a web address, type about:config and hit Enter.

  2. If you see a window which says "This might void your warranty!", click the button which says "I'll be careful, I promise" so you can continue with the next step.

  3. In the filter at the top, copy/paste the following: browser.urlbar.maxRichResults

  4. The default is "12". Right click it and choose "Modify" and then type in the number of links you want to be displayed.

  5. Close the tab afterwards.


If this answers your question, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

Modified by Xircal

more options

Thanks Xircal. When I right click on them nothing happens.

Modified by vanderloo

more options

You're welcome.

more options

Hang on a min. I'll test it.

more options

OK, just select and hit the Delete key instead.

more options

There you go. That worked. Thanks Again.

more options

Chosen Solution

You're welcome.

Could you please click the Solved It button next to the post which solved the problem for you? This will help others searching for a solution to the same question.

Thanks.

more options

I would like to know how to ADD to this list. I've already learned (by accident) how to remove an item from the list. I would like it back! Despite the "complex algorithm".

more options

Firefox should store new form data automatically and ask permission to store a new password.


Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"