Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I correct a "General failure....An error occurred in sending the command to the application." error message when clicking a web site link in MS Outlook email?

  • 4 replies
  • 73 have this problem
  • 2 views
  • Last reply by ddtgo2

more options

I get this error message every time I click on a web site link in my Outlook email. The page goes ahead and loads anyway. I just don't know why I get it and how I can get rid of it.

All Replies (4)

more options

I randomly started getting this problem and fixed it by doing the following:

  1. Close both the Firefox and Outlook (2010) programs. Make sure the processes have exited.
  2. In Control Panel, go to "Default Programs".
  3. Go to "Set default programs" and set Firefox as default.
  4. Go back and then to "Set program access and computer defaults" and set Firefox and Outlook as your default browser and email program respectively.
  5. Restart Firefox and Outlook at the problem should hopefully be fixed.

If this doesn't do the job, then you may want to attempt the registry hack described here here.

Modified by Noldorin

more options

Alexreg -- your solution worked for me, and after I searched around quite a bit. Thank you for posting and saving me more trouble.

more options

alexreg; Thank you so much, for the first time I have found and answer to my problem that the solution was very well explained; step by step.

more options

Works 100%. Thanks for saving me time. I started getting this error after a firefox upgrade. Must have been a bug somewhere, but working 100% now.

Modified by ddtgo2