Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

i upgraded to Firefox 4.01 but it keeps asking me to reboot whenever i want to launch the program even after rebooting for at least 7 times

  • 7 replies
  • 11 have this problem
  • Last reply by cor-el

more options

I have rebooted the system many times but I am not able to launch Mozilla F. 4.01. After upgrading it, I cant even redownload it or go back to the older version: it keeps asking me to reboot the system everytime I try to launch. Please HELP! I highly dislike IE! besides I got all my bookmarks with Firefox.

All Replies (7)

more options

You can do a clean (re-)install:

  • Uninstall your current Firefox version and remove the Firefox program folder before installing that copy of the Firefox installer.
  • Do not remove personal data if you uninstall the current version.
  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.

Your bookmarks and other profile data are stored elsewhere (not in the Firefox program folder) and won't be affected by a reinstall, but make sure that you do not select to remove personal data if you uninstall Firefox.

more options

Hi! and thank you so much for your reply! I have tried to do all that and I can't even uninstall the file from the Add/Remove folder. Do you know what else I can do to fix this? I truly think Firefox 4.01 is dangerously bugged!

Please help! :/

Thank you in advance, Fernanda

more options

If you can't uninstall then remove the Firefox program folder ("C:\Program Files\Mozilla Firefox\") manually.

more options

Hi again and thank you for your reply. The only option available to me is "Add or Remove Programs" and like i have said, when i click on Remove i get the same pop up window to reboot the system. even by doing so, i dont get to solve the situation -after rebooting, the program is still there. Firefox 4 is dangerously bugged. this is the first time something like this happens to me after all the years running Firefox. any other suggestion, advice...? thank you again!

more options

I can't uninstall either!!! I've tried rebooting 3 times. There is no firefox program running. I can't Add/Remove the program or install a recently downloaded install file. Attempting to Add/Remove or run the helper.exe uninstall program both tell me to reboot...which I keep doing to no avail. What is wrong?!! This is frustrating. Any help is appreciated. I'd like to use this browser for the FireFTP program. Is there anything else I can try?


more options

i dont think there is a solution. i have tried pretty much all i knew and everything i was told to do. this is driving me nuts. i am running IE and sucks big time!

Firefox 4 is dangerously bugged. i cant even go and reinstall the older version.

any help would be greatly appreciated!

more options

You need to remove the Firefox program folder yourself if uninstalling is impossible.
Either way even after uninstalling you still need to check if all files in the Firefox program folder were removed to prevent problems with updating.